Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка пустых строк по значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка пустых строк по значению (Иное/Other)
Вставка пустых строк по значению
baneska Дата: Суббота, 06.02.2016, 13:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем доброго вечера. :) Прошу помощи.. :'(

В документе представлена температура по годам, месяцам и дням. На каждый день по несколько значений, без всякой закономерности. Мне нужно разделить дни пустыми строками. В ручную это делать нереально, т.к. много данных и подобных документов ещё много. Подскажите, пожалуйста, возможно ли прибегнуть к какому-нибудь хитроумному маневру? :)

В документе несколько дней я разделила (для примера).
К сообщению приложен файл: 123.xlsx(88Kb)


Новичок
 
Ответить
СообщениеВсем доброго вечера. :) Прошу помощи.. :'(

В документе представлена температура по годам, месяцам и дням. На каждый день по несколько значений, без всякой закономерности. Мне нужно разделить дни пустыми строками. В ручную это делать нереально, т.к. много данных и подобных документов ещё много. Подскажите, пожалуйста, возможно ли прибегнуть к какому-нибудь хитроумному маневру? :)

В документе несколько дней я разделила (для примера).

Автор - baneska
Дата добавления - 06.02.2016 в 13:54
_Boroda_ Дата: Суббота, 06.02.2016, 14:03 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
baneska, а зачем Вам это нужно?

Впрочем, если так хочется, то можно, например, так - выделяете всю таблицу - Данные - промежуточный итог - далее как на скрине, который в файле

Еще можно сводную таблицу туда прилепить, макросом можно, ...
Главный вопрос - зачем Вам это?
К сообщению приложен файл: 123456_1.xlsb(69Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеbaneska, а зачем Вам это нужно?

Впрочем, если так хочется, то можно, например, так - выделяете всю таблицу - Данные - промежуточный итог - далее как на скрине, который в файле

Еще можно сводную таблицу туда прилепить, макросом можно, ...
Главный вопрос - зачем Вам это?

Автор - _Boroda_
Дата добавления - 06.02.2016 в 14:03
baneska Дата: Суббота, 06.02.2016, 14:08 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Без этих строк я не могу воспользоваться формулами, для обработки данных. А вообще, мне нужно среднее, max и min значения за каждый день. :(

Спасибо, но этот вариант не подходит, мне нужная пустая строка после каждого дня, без каких либо итогов и т.д. :)


Новичок

Сообщение отредактировал baneska - Суббота, 06.02.2016, 14:11
 
Ответить
Сообщение_Boroda_, Без этих строк я не могу воспользоваться формулами, для обработки данных. А вообще, мне нужно среднее, max и min значения за каждый день. :(

Спасибо, но этот вариант не подходит, мне нужная пустая строка после каждого дня, без каких либо итогов и т.д. :)

Автор - baneska
Дата добавления - 06.02.2016 в 14:08
Udik Дата: Суббота, 06.02.2016, 14:40 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
если данные везде идут как в нижних строках примера, т.е. в ненужных строках ячейка D=""
Код
=ЕСЛИ(Лист1!$D2="";"";Лист1!D2)
К сообщению приложен файл: 3662050.xlsx(57Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Суббота, 06.02.2016, 14:47
 
Ответить
Сообщениеесли данные везде идут как в нижних строках примера, т.е. в ненужных строках ячейка D=""
Код
=ЕСЛИ(Лист1!$D2="";"";Лист1!D2)

Автор - Udik
Дата добавления - 06.02.2016 в 14:40
baneska Дата: Суббота, 06.02.2016, 15:00 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Udik, Простите, но я ничего не поняла. Ведь ничего не изменилось..


Новичок
 
Ответить
СообщениеUdik, Простите, но я ничего не поняла. Ведь ничего не изменилось..

Автор - baneska
Дата добавления - 06.02.2016 в 15:00
Udik Дата: Суббота, 06.02.2016, 15:27 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
похоже не одинаковый формат, сейчас ещё гляну
==
да, сначала нет маркера


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Суббота, 06.02.2016, 15:39
 
Ответить
Сообщениепохоже не одинаковый формат, сейчас ещё гляну
==
да, сначала нет маркера

Автор - Udik
Дата добавления - 06.02.2016 в 15:27
_Boroda_ Дата: Суббота, 06.02.2016, 16:25 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без этих строк я не могу воспользоваться формулами
Так может не придумывать, а просто объяснить нам итоговую хотелку свою?
мне нужно среднее, max и min значения за каждый день.
Еще раз спрашиваю - ЗАЧЕМ Вам для этого пустая строка?
Приведите в файле пример желаемого ИТОГОВОГО результата.
А пока держите сводной таблицей
К сообщению приложен файл: 123456_3.xlsb(60Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Без этих строк я не могу воспользоваться формулами
Так может не придумывать, а просто объяснить нам итоговую хотелку свою?
мне нужно среднее, max и min значения за каждый день.
Еще раз спрашиваю - ЗАЧЕМ Вам для этого пустая строка?
Приведите в файле пример желаемого ИТОГОВОГО результата.
А пока держите сводной таблицей

Автор - _Boroda_
Дата добавления - 06.02.2016 в 16:25
Udik Дата: Суббота, 06.02.2016, 17:46 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
формулами только с допстолбцом получилось, причём с 3-й строки

доп. столбец
Код
=ЕСЛИ(G2<G1;G2;G2-(СМЕЩ(Лист1!C3;G2;0)<>СМЕЩ(Лист1!C3;G2-1;0)))


искомые данные
Код
=ЕСЛИ($G2<>$G1;"";СМЕЩ(Лист1!A2;$G2;0))


[p.s.]цель этого действа тоже непонятна
К сообщению приложен файл: 4265007.xlsx(40Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Суббота, 06.02.2016, 17:50
 
Ответить
Сообщениеформулами только с допстолбцом получилось, причём с 3-й строки

доп. столбец
Код
=ЕСЛИ(G2<G1;G2;G2-(СМЕЩ(Лист1!C3;G2;0)<>СМЕЩ(Лист1!C3;G2-1;0)))


искомые данные
Код
=ЕСЛИ($G2<>$G1;"";СМЕЩ(Лист1!A2;$G2;0))


[p.s.]цель этого действа тоже непонятна

Автор - Udik
Дата добавления - 06.02.2016 в 17:46
Nic70y Дата: Суббота, 06.02.2016, 18:10 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3474
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
УФ и т.д.
К сообщению приложен файл: 456-1.xlsx(56Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеУФ и т.д.

Автор - Nic70y
Дата добавления - 06.02.2016 в 18:10
SLAVICK Дата: Понедельник, 07.03.2016, 11:18 | Сообщение № 10
Группа: Модераторы
Ранг: Старожил
Сообщений: 1834
Репутация: 613 ±
Замечаний: 0% ±

2007,2010,2013,2016
А пока держите сводной таблицей

Я тоже за сводную.
НЕмного дополнил таблицу _Boroda_,
Добавил повторение строк и промежуточный итог по дням.
К сообщению приложен файл: 7770406.xlsb(99Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
А пока держите сводной таблицей

Я тоже за сводную.
НЕмного дополнил таблицу _Boroda_,
Добавил повторение строк и промежуточный итог по дням.

Автор - SLAVICK
Дата добавления - 07.03.2016 в 11:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка пустых строк по значению (Иное/Other)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!