Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения из нескольких массивов (сопоставление условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из нескольких массивов (сопоставление условий (Формулы/Formulas)
Выбор значения из нескольких массивов (сопоставление условий
Xsimple Дата: Понедельник, 08.02.2016, 12:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нужна формула в ячейку столбца М (% от продаж (премия))
Смысл формулы:
1. Значение из столбца L (Выставленные акты), проверяется из множества диапазонов столбцов A (Сумма выставленных актов"от") и B (Сумма выставленных актов "до"), должно найти между ними (от и до)
2. Когда формула находит соответствие определенной строке, то подставляет значение из столбца С (% от продаж (премия)) той же строки в столбец М (% от продаж (премия))
К сообщению приложен файл: 2307242.xlsx(23Kb)
 
Ответить
СообщениеНужна формула в ячейку столбца М (% от продаж (премия))
Смысл формулы:
1. Значение из столбца L (Выставленные акты), проверяется из множества диапазонов столбцов A (Сумма выставленных актов"от") и B (Сумма выставленных актов "до"), должно найти между ними (от и до)
2. Когда формула находит соответствие определенной строке, то подставляет значение из столбца С (% от продаж (премия)) той же строки в столбец М (% от продаж (премия))

Автор - Xsimple
Дата добавления - 08.02.2016 в 12:16
китин Дата: Понедельник, 08.02.2016, 12:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4106
Репутация: 633 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=СУММПРОИЗВ($C$2:$C$430*($L2>=$A$2:$A$430)*($L2<=$B$2:$B$430))
или
Код
=ПРОСМОТР(L2;$A$2:$A$430;$C$2:$C$430)
или
Код
=ВПР(L2;$A$2:$C$430;3;1)
или
Код
=ИНДЕКС($C$2:$C$430;ПОИСКПОЗ(L2;$A$2:$A$430;1))
К сообщению приложен файл: Xsimple.xlsx(25Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 08.02.2016, 12:45
 
Ответить
Сообщениетак надо?
Код
=СУММПРОИЗВ($C$2:$C$430*($L2>=$A$2:$A$430)*($L2<=$B$2:$B$430))
или
Код
=ПРОСМОТР(L2;$A$2:$A$430;$C$2:$C$430)
или
Код
=ВПР(L2;$A$2:$C$430;3;1)
или
Код
=ИНДЕКС($C$2:$C$430;ПОИСКПОЗ(L2;$A$2:$A$430;1))

Автор - китин
Дата добавления - 08.02.2016 в 12:33
Xsimple Дата: Понедельник, 08.02.2016, 12:45 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Да именно так, очень круто!!!!! Спасибо!
 
Ответить
СообщениеДа именно так, очень круто!!!!! Спасибо!

Автор - Xsimple
Дата добавления - 08.02.2016 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения из нескольких массивов (сопоставление условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!