Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/"Если" в применении с датой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » "Если" в применении с датой (Формулы/Formulas)
"Если" в применении с датой
rus_31 Дата: Вторник, 09.02.2016, 11:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, прошу откликнуться на вопрос. Суть задачи - есть три столбца - оплачен, дата оплаты, срок поставки. Как применить в формуле чтобы отражалось ежедневно, сколько осталось дней до отгрузки. Заранее всех благодарю!
К сообщению приложен файл: _1.xlsx(10Kb)
 
Ответить
СообщениеДобрый день, прошу откликнуться на вопрос. Суть задачи - есть три столбца - оплачен, дата оплаты, срок поставки. Как применить в формуле чтобы отражалось ежедневно, сколько осталось дней до отгрузки. Заранее всех благодарю!

Автор - rus_31
Дата добавления - 09.02.2016 в 11:20
YouGreed Дата: Вторник, 09.02.2016, 11:34 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 429
Репутация: 93 ±
Замечаний: 0% ±

Excel 2010
rus_31, Так?
Код
=ЕСЛИ($B7<>"";($B7+ЛЕВБ($C7;НАЙТИ(" ";$C7;1)))-СЕГОДНЯ();"")


Код
ЕСЛИ($B3<>"";РАБДЕНЬ($B3;ЛЕВБ($C3;НАЙТИ(" ";$C3;1));)-СЕГОДНЯ();"")


[p.s.]Не так... не учел рабочие дни...
К сообщению приложен файл: ___.xlsx(10Kb)


Сообщение отредактировал YouGreed - Вторник, 09.02.2016, 11:46
 
Ответить
Сообщениеrus_31, Так?
Код
=ЕСЛИ($B7<>"";($B7+ЛЕВБ($C7;НАЙТИ(" ";$C7;1)))-СЕГОДНЯ();"")


Код
ЕСЛИ($B3<>"";РАБДЕНЬ($B3;ЛЕВБ($C3;НАЙТИ(" ";$C3;1));)-СЕГОДНЯ();"")


[p.s.]Не так... не учел рабочие дни...

Автор - YouGreed
Дата добавления - 09.02.2016 в 11:34
vikttur Дата: Вторник, 09.02.2016, 11:36 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2042
Репутация: 355 ±
Замечаний: 0% ±

=ЕСЛИ(B3;B3+C3;"нет")

Не так понял.
=ЕСЛИ(B3;B3+C3-$E$2;"нет")
$E$2 - сегодня.
К сообщению приложен файл: 6274079.xlsx(12Kb)


Сообщение отредактировал vikttur - Вторник, 09.02.2016, 11:50
 
Ответить
Сообщение=ЕСЛИ(B3;B3+C3;"нет")

Не так понял.
=ЕСЛИ(B3;B3+C3-$E$2;"нет")
$E$2 - сегодня.

Автор - vikttur
Дата добавления - 09.02.2016 в 11:36
Manyasha Дата: Вторник, 09.02.2016, 11:36 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
rus_31, не очень поняла, но вдруг правильно:
Код
=ЕСЛИ(B3;РАБДЕНЬ(B3;--ПСТР(C3;1;ПОИСК(" ";C3)-1))-СЕГОДНЯ();"")

В РАБЕНЬ можно праздники добавить
К сообщению приложен файл: _1-1.xlsx(12Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеrus_31, не очень поняла, но вдруг правильно:
Код
=ЕСЛИ(B3;РАБДЕНЬ(B3;--ПСТР(C3;1;ПОИСК(" ";C3)-1))-СЕГОДНЯ();"")

В РАБЕНЬ можно праздники добавить

Автор - Manyasha
Дата добавления - 09.02.2016 в 11:36
VIDEO56 Дата: Вторник, 09.02.2016, 11:44 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(B7=0;"";ЕСЛИ(A7="оплачен";ЧИСТРАБДНИ(B7;СЕГОДНЯ();0)-ЧИСТРАБДНИ(B7;(B7+C7);0);"Оплаты не поступало"))
К сообщению приложен файл: 8479924.xlsx(12Kb)


Всем удачного дня!

Сообщение отредактировал VIDEO56 - Вторник, 09.02.2016, 11:46
 
Ответить
Сообщение
Код
=ЕСЛИ(B7=0;"";ЕСЛИ(A7="оплачен";ЧИСТРАБДНИ(B7;СЕГОДНЯ();0)-ЧИСТРАБДНИ(B7;(B7+C7);0);"Оплаты не поступало"))

Автор - VIDEO56
Дата добавления - 09.02.2016 в 11:44
rus_31 Дата: Вторник, 09.02.2016, 11:53 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем форумчанам что откликнулись, буду выбирать что более приемлемо к нашим условиям. Бодрого и продуктивного вам!
 
Ответить
СообщениеСпасибо всем форумчанам что откликнулись, буду выбирать что более приемлемо к нашим условиям. Бодрого и продуктивного вам!

Автор - rus_31
Дата добавления - 09.02.2016 в 11:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » "Если" в применении с датой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!