Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет непустых ячеек, пустую строку считать пустой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет непустых ячеек, пустую строку считать пустой (Формулы/Formulas)
Подсчет непустых ячеек, пустую строку считать пустой
AM2017 Дата: Среда, 10.02.2016, 22:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Приветствую участников форума!
Некоторые формулы возвращают в ячейку пустую строку "".
Я хочу подсчитать, сколько непустых ячеек, используя такую формулу
Код
=СЧЁТЕСЛИ(E1:E5;"<>")

Если в диапазоне E1:E5 есть ячейка, в которой "", а остальные пустые, то возвращается 1.
Как написать формулу, используя СЧЁТЕСЛИ или СЧЁТЕСЛИМН, чтобы в данном случае формула возвращала 0.
Спасибо.
 
Ответить
СообщениеПриветствую участников форума!
Некоторые формулы возвращают в ячейку пустую строку "".
Я хочу подсчитать, сколько непустых ячеек, используя такую формулу
Код
=СЧЁТЕСЛИ(E1:E5;"<>")

Если в диапазоне E1:E5 есть ячейка, в которой "", а остальные пустые, то возвращается 1.
Как написать формулу, используя СЧЁТЕСЛИ или СЧЁТЕСЛИМН, чтобы в данном случае формула возвращала 0.
Спасибо.

Автор - AM2017
Дата добавления - 10.02.2016 в 22:55
antycapral Дата: Среда, 10.02.2016, 23:20 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 61
Репутация: 5 ±
Замечаний: 0% ±

Excel 2016
Код
=СЧЁТЕСЛИ(E2:E17;"<>")-СЧЁТЕСЛИ(E2:E17;"""""")


Сообщение отредактировал antycapral - Среда, 10.02.2016, 23:21
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(E2:E17;"<>")-СЧЁТЕСЛИ(E2:E17;"""""")

Автор - antycapral
Дата добавления - 10.02.2016 в 23:20
Pelena Дата: Среда, 10.02.2016, 23:26 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11041
Репутация: 2465 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Так можно
Код
=СУММПРОИЗВ(--(E1:E5<>""))

или
Код
=ЧСТРОК(E1:E5)-СЧИТАТЬПУСТОТЫ(E1:E5)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Так можно
Код
=СУММПРОИЗВ(--(E1:E5<>""))

или
Код
=ЧСТРОК(E1:E5)-СЧИТАТЬПУСТОТЫ(E1:E5)

Автор - Pelena
Дата добавления - 10.02.2016 в 23:26
_Boroda_ Дата: Среда, 10.02.2016, 23:51 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
С условием
написать формулу, используя СЧЁТЕСЛИ или СЧЁТЕСЛИМН

Если формула выводит кроме пустой строки еще буквы, то можно так
Код
=СЧЁТЕСЛИ(A2:A10;"?*")

Если цифры, то
Код
=СЧЁТЕСЛИ(D2:D10;"<"&9^9)

Если могут быть и цифры, и буквы, то
Код
=ЧСТРОК(G2:G10)-СЧЁТЕСЛИ(G2:G10;"")

Примеры в файле
К сообщению приложен файл: 6871979.xlsx(8Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеС условием
написать формулу, используя СЧЁТЕСЛИ или СЧЁТЕСЛИМН

Если формула выводит кроме пустой строки еще буквы, то можно так
Код
=СЧЁТЕСЛИ(A2:A10;"?*")

Если цифры, то
Код
=СЧЁТЕСЛИ(D2:D10;"<"&9^9)

Если могут быть и цифры, и буквы, то
Код
=ЧСТРОК(G2:G10)-СЧЁТЕСЛИ(G2:G10;"")

Примеры в файле

Автор - _Boroda_
Дата добавления - 10.02.2016 в 23:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет непустых ячеек, пустую строку считать пустой (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!