Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста и привязка к строке. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста и привязка к строке. (Формулы/Formulas)
Поиск текста и привязка к строке.
valermihali4 Дата: Четверг, 11.02.2016, 08:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Пример описан во вложении.
Готов разумно отблагодарить.
К сообщению приложен файл: 0248671.xlsx(15Kb)
 
Ответить
СообщениеПример описан во вложении.
Готов разумно отблагодарить.

Автор - valermihali4
Дата добавления - 11.02.2016 в 08:37
китин Дата: Четверг, 11.02.2016, 08:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4099
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
Код
=ИНДЕКС(Таблица_PartDB[PartName];ПОИСКПОЗ(A4&"*";Таблица_PartDB[PartName];0))
К сообщению приложен файл: _0248671.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 11.02.2016, 08:47
 
Ответить
Сообщениетак надо?
Код
=ИНДЕКС(Таблица_PartDB[PartName];ПОИСКПОЗ(A4&"*";Таблица_PartDB[PartName];0))

Автор - китин
Дата добавления - 11.02.2016 в 08:47
valermihali4 Дата: Четверг, 11.02.2016, 09:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Все так как надо.
Можно ли еще к формуле "
Код
=ИНДЕКС(Таблица_PartDB[CpFile];ПОИСКПОЗ(Лист1!C4;Таблица_PartDB[PartName];0))
"
Так сейчас C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\735312
А так должно быть C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\735312\найденный текст.cp
Текст который искали "745427.240-07"
Текст который нашли "745427.240-07-v1 Дно"
Ссылка которая получится с расширением файла "cp" C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\745427.240-07-v1 Дно.cp
[moder]Оформляйте формулы тегами (кнопка fx)[/moder]


Сообщение отредактировал Pelena - Четверг, 11.02.2016, 09:09
 
Ответить
СообщениеВсе так как надо.
Можно ли еще к формуле "
Код
=ИНДЕКС(Таблица_PartDB[CpFile];ПОИСКПОЗ(Лист1!C4;Таблица_PartDB[PartName];0))
"
Так сейчас C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\735312
А так должно быть C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\735312\найденный текст.cp
Текст который искали "745427.240-07"
Текст который нашли "745427.240-07-v1 Дно"
Ссылка которая получится с расширением файла "cp" C:\fms\ncexpress\12\PARTDIR\pro fin\2010\85. Металлоконструкции\745427.240-07-v1 Дно.cp
[moder]Оформляйте формулы тегами (кнопка fx)[/moder]

Автор - valermihali4
Дата добавления - 11.02.2016 в 09:04
китин Дата: Четверг, 11.02.2016, 09:15 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4099
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=ИНДЕКС(Таблица_PartDB[CpFile];ПОИСКПОЗ(Лист1!$C$4;Таблица_PartDB[PartName];0))&ПОДСТАВИТЬ(C4;ЛЕВБ(C4;ПОИСК(".";C4)-1);"")

[p.s.]формулы надо обрамлять в тэги (кнопочка fx. Совершенно нечитаемый вид
К сообщению приложен файл: 8671.xlsx(16Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
Код
=ИНДЕКС(Таблица_PartDB[CpFile];ПОИСКПОЗ(Лист1!$C$4;Таблица_PartDB[PartName];0))&ПОДСТАВИТЬ(C4;ЛЕВБ(C4;ПОИСК(".";C4)-1);"")

[p.s.]формулы надо обрамлять в тэги (кнопочка fx. Совершенно нечитаемый вид

Автор - китин
Дата добавления - 11.02.2016 в 09:15
valermihali4 Дата: Четверг, 11.02.2016, 09:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Огромное спасибо.
 
Ответить
СообщениеОгромное спасибо.

Автор - valermihali4
Дата добавления - 11.02.2016 в 09:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста и привязка к строке. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!