Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Упростить формулу суммирования с условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу суммирования с условиями (Формулы/Formulas)
Упростить формулу суммирования с условиями
Maja Дата: Четверг, 11.02.2016, 15:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. Подскажите пожалуйста как решить данную задачу:
Надо упростить формулу:
Код
=СУММ(ЕСЛИ(A$12[b]=1[/b];$C$12;0)+ЕСЛИ(A$13[b]=1[/b];$C$13;0)+ЕСЛИ(A$14[b]=1[/b];$C$14;0)+ЕСЛИ(A$15[b]=1[/b];$C$15;0)
и т.д
и можно ли несколько таких формул как-то заменить одной
Код
=СУММ(ЕСЛИ(A$12[b]=2[/b];$C$12;0)+ЕСЛИ(A$13[b]=2[/b];$C$13;0)+ЕСЛИ(A$14=2;$C$14;0)+ЕСЛИ(A$15=2;$C$15;0)

Код
=СУММ(ЕСЛИ(A$12[b]=3[/b];$C$12;0)+ЕСЛИ(A$13[b]=3[/b];$C$13;0)+ЕСЛИ(A$14=3;$C$14;0)+ЕСЛИ(A$15=3;$C$15;0)

Извиняюсь, если не смогла понятно объяснить суть проблемы. Не владею терминологией.
Заранее всем спасибо
Файлик прилагаю
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]
К сообщению приложен файл: 4600359.xlsx(34Kb)
 
Ответить
СообщениеЗдравствуйте. Подскажите пожалуйста как решить данную задачу:
Надо упростить формулу:
Код
=СУММ(ЕСЛИ(A$12[b]=1[/b];$C$12;0)+ЕСЛИ(A$13[b]=1[/b];$C$13;0)+ЕСЛИ(A$14[b]=1[/b];$C$14;0)+ЕСЛИ(A$15[b]=1[/b];$C$15;0)
и т.д
и можно ли несколько таких формул как-то заменить одной
Код
=СУММ(ЕСЛИ(A$12[b]=2[/b];$C$12;0)+ЕСЛИ(A$13[b]=2[/b];$C$13;0)+ЕСЛИ(A$14=2;$C$14;0)+ЕСЛИ(A$15=2;$C$15;0)

Код
=СУММ(ЕСЛИ(A$12[b]=3[/b];$C$12;0)+ЕСЛИ(A$13[b]=3[/b];$C$13;0)+ЕСЛИ(A$14=3;$C$14;0)+ЕСЛИ(A$15=3;$C$15;0)

Извиняюсь, если не смогла понятно объяснить суть проблемы. Не владею терминологией.
Заранее всем спасибо
Файлик прилагаю
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]

Автор - Maja
Дата добавления - 11.02.2016 в 15:05
buchlotnik Дата: Четверг, 11.02.2016, 15:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2209
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=СУММПРОИЗВ(($A$12:$A$50=A77)*$C$12:$C$50)
К сообщению приложен файл: 8479123.xlsx(32Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=СУММПРОИЗВ(($A$12:$A$50=A77)*$C$12:$C$50)

Автор - buchlotnik
Дата добавления - 11.02.2016 в 15:12
китин Дата: Четверг, 11.02.2016, 15:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3730
Репутация: 590 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или так
Код
=СУММЕСЛИ($A$12:$A$30;$A77;$C$12:$C$30)
или массивная
Код
=СУММ(ЕСЛИ($A$12:$A$30=A77;$C$12:$C$30))
К сообщению приложен файл: 359.xlsx(34Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 11.02.2016, 15:21
 
Ответить
Сообщениеили так
Код
=СУММЕСЛИ($A$12:$A$30;$A77;$C$12:$C$30)
или массивная
Код
=СУММ(ЕСЛИ($A$12:$A$30=A77;$C$12:$C$30))

Автор - китин
Дата добавления - 11.02.2016 в 15:19
Maja Дата: Пятница, 12.02.2016, 09:32 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята, дорогие, Спасибо огромное. Это то что надо. Всех люблю.
 
Ответить
СообщениеРебята, дорогие, Спасибо огромное. Это то что надо. Всех люблю.

Автор - Maja
Дата добавления - 12.02.2016 в 09:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Упростить формулу суммирования с условиями (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!