Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не показывать нули при арифметических операциях - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не показывать нули при арифметических операциях (Формулы/Formulas)
Не показывать нули при арифметических операциях
Arcanum Дата: Четверг, 11.02.2016, 19:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Не могу понять простую вещь, как сделать так, чтобы при относительном копировании формулы в другие ячейки, результат равный нулю не показывался? Получается следующее: если есть числа, то они суммируются и получается результат, а если чисел нет, то получается 0, что мне не нужно, должно получиться пустое поле. Пробую следующую формулу:
Код
=СУММ(ЕСЛИ(B3:B5<>0;B3:B5;""))

Ее ввожу массивом, результат получаю, но нули остаются. Вроде как иду в правильно направлении, но не пойму, как получить нужный результат. Помоги пожалуйста. Файл для примера прикрепляю
К сообщению приложен файл: 11.xlsx(8Kb)


Сообщение отредактировал Arcanum - Четверг, 11.02.2016, 19:52
 
Ответить
СообщениеЗдравствуйте! Не могу понять простую вещь, как сделать так, чтобы при относительном копировании формулы в другие ячейки, результат равный нулю не показывался? Получается следующее: если есть числа, то они суммируются и получается результат, а если чисел нет, то получается 0, что мне не нужно, должно получиться пустое поле. Пробую следующую формулу:
Код
=СУММ(ЕСЛИ(B3:B5<>0;B3:B5;""))

Ее ввожу массивом, результат получаю, но нули остаются. Вроде как иду в правильно направлении, но не пойму, как получить нужный результат. Помоги пожалуйста. Файл для примера прикрепляю

Автор - Arcanum
Дата добавления - 11.02.2016 в 19:51
_Boroda_ Дата: Четверг, 11.02.2016, 19:58 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(СУММ(B3:B5);СУММ(B3:B5);"")

Или пишите просто СУММ и формат ячеек
0;-0;;
К сообщению приложен файл: 4221719718.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(СУММ(B3:B5);СУММ(B3:B5);"")

Или пишите просто СУММ и формат ячеек
0;-0;;

Автор - _Boroda_
Дата добавления - 11.02.2016 в 19:58
gling Дата: Четверг, 11.02.2016, 20:08 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Здравствуйте. А может скрыть все нулевые значения на листе? Есть такая возможность в Параметры Excel--Дополнительно--Показывать параметры для следующего листа--Показывать нули в ячейках, которые содержат нулевые знасения (убрать галку)


Сообщение отредактировал gling - Четверг, 11.02.2016, 20:09
 
Ответить
СообщениеЗдравствуйте. А может скрыть все нулевые значения на листе? Есть такая возможность в Параметры Excel--Дополнительно--Показывать параметры для следующего листа--Показывать нули в ячейках, которые содержат нулевые знасения (убрать галку)

Автор - gling
Дата добавления - 11.02.2016 в 20:08
Arcanum Дата: Четверг, 11.02.2016, 20:30 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

О, то что нужно. Благодарю Вас :)
А может скрыть все нулевые значения на листе?

Здравствуйте. Читал про этот способ, но хотелось добиться результата именно формулой :)
 
Ответить
Сообщение
Так нужно?

О, то что нужно. Благодарю Вас :)
А может скрыть все нулевые значения на листе?

Здравствуйте. Читал про этот способ, но хотелось добиться результата именно формулой :)

Автор - Arcanum
Дата добавления - 11.02.2016 в 20:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не показывать нули при арифметических операциях (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!