Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка значения по условию из массива. Формула ЕСЛИ. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значения по условию из массива. Формула ЕСЛИ. (Формулы/Formulas)
Выборка значения по условию из массива. Формула ЕСЛИ.
denw Дата: Пятница, 12.02.2016, 12:43 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день,
Прошу помочь определиться с формулой (пример прикладываю), необходимо в столбец "Раздел" проставить их названия исходя из условия сравнения массива значений с минимальным значением, и выбрать названия разделов тоже из массива. Не знаю насколько понятно написал, но в примере все можно понять.
Если бы отобрать из массива надо было числовые значения, можно было бы воспользоваться функциями МИН, МАКС или СРЗНАЧ, но здесь текстовые значения, поэтому прошу помочь.
К сообщению приложен файл: 3246467.xlsx(10Kb)
 
Ответить
СообщениеДобрый день,
Прошу помочь определиться с формулой (пример прикладываю), необходимо в столбец "Раздел" проставить их названия исходя из условия сравнения массива значений с минимальным значением, и выбрать названия разделов тоже из массива. Не знаю насколько понятно написал, но в примере все можно понять.
Если бы отобрать из массива надо было числовые значения, можно было бы воспользоваться функциями МИН, МАКС или СРЗНАЧ, но здесь текстовые значения, поэтому прошу помочь.

Автор - denw
Дата добавления - 12.02.2016 в 12:43
SLAVICK Дата: Пятница, 12.02.2016, 12:50 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 2007
Репутация: 674 ±
Замечаний: 0% ±

2007,2010,2013,2016
Так?
Код
=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))
К сообщению приложен файл: 5574677.xlsx(10Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеТак?
Код
=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))

Автор - SLAVICK
Дата добавления - 12.02.2016 в 12:50
denw Дата: Пятница, 12.02.2016, 12:55 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так?

=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))


Точно!!! Спасибо большое, а то я уже весь мозг сломал, теперь буду пользоваться ИНДЕКСом!
 
Ответить
Сообщение
Так?

=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))


Точно!!! Спасибо большое, а то я уже весь мозг сломал, теперь буду пользоваться ИНДЕКСом!

Автор - denw
Дата добавления - 12.02.2016 в 12:55
_Boroda_ Дата: Пятница, 12.02.2016, 12:58 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для ТТР (?) вот так можно
Код
="ТРР ("&ПОИСКПОЗ(F2;A2:E2;)&")"

или
Код
=ТЕКСТ(ПОИСКПОЗ(F2;A2:E2;);"ТТР (0)")
К сообщению приложен файл: 3246467_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля ТТР (?) вот так можно
Код
="ТРР ("&ПОИСКПОЗ(F2;A2:E2;)&")"

или
Код
=ТЕКСТ(ПОИСКПОЗ(F2;A2:E2;);"ТТР (0)")

Автор - _Boroda_
Дата добавления - 12.02.2016 в 12:58
denw Дата: Пятница, 12.02.2016, 13:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Для ТТР (?) вот так можно


Спасибо, к этому примеру подойдет, но в шапке могут быть разные наименования, не обязательно ТРР (n)

Код
=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))


формула идеально подходит.
[moder]Весь пост цитировать запрещено Правилами форума. Почистил.
Формы нужно засовывать вовнутря тегов кнопочкой fx. Поправил.


Сообщение отредактировал _Boroda_ - Пятница, 12.02.2016, 13:15
 
Ответить
Сообщение
Для ТТР (?) вот так можно


Спасибо, к этому примеру подойдет, но в шапке могут быть разные наименования, не обязательно ТРР (n)

Код
=ИНДЕКС($A$1:$F$1;1;ПОИСКПОЗ(F2;$A2:$E2;0))


формула идеально подходит.
[moder]Весь пост цитировать запрещено Правилами форума. Почистил.
Формы нужно засовывать вовнутря тегов кнопочкой fx. Поправил.

Автор - denw
Дата добавления - 12.02.2016 в 13:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка значения по условию из массива. Формула ЕСЛИ. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!