Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Невидимый апостроф - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Невидимый апостроф (Формулы/Formulas)
Невидимый апостроф
Терминатор Дата: Пятница, 12.02.2016, 15:25 | Сообщение № 1
Группа: Заблокированные
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 60% ±

2003
В файле в столбце D цифры с апострофом вначале. Поиском его не находит, зато если написать в поиске число без апострофа - выделяет ячейку столбца D. Как удалить этот апостроф, чтобы в ячейке остались только цифры?
К сообщению приложен файл: 7356734.xls(78Kb)
 
Ответить
СообщениеВ файле в столбце D цифры с апострофом вначале. Поиском его не находит, зато если написать в поиске число без апострофа - выделяет ячейку столбца D. Как удалить этот апостроф, чтобы в ячейке остались только цифры?

Автор - Терминатор
Дата добавления - 12.02.2016 в 15:25
buchlotnik Дата: Пятница, 12.02.2016, 15:29 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Терминатор, в упор не вижу апострофа. Где вы его наблюдаете?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
СообщениеТерминатор, в упор не вижу апострофа. Где вы его наблюдаете?

Автор - buchlotnik
Дата добавления - 12.02.2016 в 15:29
Терминатор Дата: Пятница, 12.02.2016, 15:31 | Сообщение № 3
Группа: Заблокированные
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 60% ±

2003
Поставьте числовой формат. В столбце D войдите в ячейку, чтобы дописать числа - Вы увидите, что первым в ячейке идёт апостроф.


Сообщение отредактировал Терминатор - Пятница, 12.02.2016, 15:34
 
Ответить
СообщениеПоставьте числовой формат. В столбце D войдите в ячейку, чтобы дописать числа - Вы увидите, что первым в ячейке идёт апостроф.

Автор - Терминатор
Дата добавления - 12.02.2016 в 15:31
SLAVICK Дата: Пятница, 12.02.2016, 15:32 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Апостроф - это принудительное назначение содержимому текстового формата.
Избавится можно:
формулой - например:
Код
=ЕСЛИОШИБКА(--A2;A2)

Или так:
Выделить ячейки
Вкладка Данные -- текст по столбцам -- с разделителями -- готово
Перевложил файл
К сообщению приложен файл: 7356734-1-.zip(39Kb)


Иногда все проще чем кажется с первого взгляда.

Сообщение отредактировал SLAVICK - Пятница, 12.02.2016, 15:33
 
Ответить
СообщениеАпостроф - это принудительное назначение содержимому текстового формата.
Избавится можно:
формулой - например:
Код
=ЕСЛИОШИБКА(--A2;A2)

Или так:
Выделить ячейки
Вкладка Данные -- текст по столбцам -- с разделителями -- готово
Перевложил файл

Автор - SLAVICK
Дата добавления - 12.02.2016 в 15:32
Терминатор Дата: Пятница, 12.02.2016, 15:37 | Сообщение № 5
Группа: Заблокированные
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 60% ±

2003
Славик, в Эксель 2003 нет ЕСЛИОШИБКА. Как быть? Да, и надо, чтобы нули вначале числа не терялись.


Сообщение отредактировал Терминатор - Пятница, 12.02.2016, 15:40
 
Ответить
СообщениеСлавик, в Эксель 2003 нет ЕСЛИОШИБКА. Как быть? Да, и надо, чтобы нули вначале числа не терялись.

Автор - Терминатор
Дата добавления - 12.02.2016 в 15:37
buchlotnik Дата: Пятница, 12.02.2016, 15:41 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
не, не увижу - у меня 2016-ый
Код
ЕСЛИОШИБКА=ЕСЛИ(ЕОШ(условие);ошибка;не_ошибка)
Код
=ЕСЛИ(ЕОШ(--D2);D2;--D2)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 12.02.2016, 15:42
 
Ответить
Сообщениене, не увижу - у меня 2016-ый
Код
ЕСЛИОШИБКА=ЕСЛИ(ЕОШ(условие);ошибка;не_ошибка)
Код
=ЕСЛИ(ЕОШ(--D2);D2;--D2)

Автор - buchlotnik
Дата добавления - 12.02.2016 в 15:41
buchlotnik Дата: Пятница, 12.02.2016, 15:43 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Да, и надо, чтобы нули вначале числа не терялись
так для этого числа как текст и форматируют! Еще раз - чем вам апостроф не угодил?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
Да, и надо, чтобы нули вначале числа не терялись
так для этого числа как текст и форматируют! Еще раз - чем вам апостроф не угодил?

Автор - buchlotnik
Дата добавления - 12.02.2016 в 15:43
SLAVICK Дата: Пятница, 12.02.2016, 15:49 | Сообщение № 8
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
[offtop]
не, не увижу - у меня 2016-ый
:D :D :D
Нужно как-то заставить себя смотреть на версию ТС сразу :o
Просто привык, что у меня даже не работе у всех давно не ниже 2007-го.[/offtop]


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение[offtop]
не, не увижу - у меня 2016-ый
:D :D :D
Нужно как-то заставить себя смотреть на версию ТС сразу :o
Просто привык, что у меня даже не работе у всех давно не ниже 2007-го.[/offtop]

Автор - SLAVICK
Дата добавления - 12.02.2016 в 15:49
TimSha Дата: Пятница, 12.02.2016, 16:22 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 459
Репутация: 74 ±
Замечаний: 0% ±

Excel 2013 Pro +
[offtop]Ситуация РазДваЯица - где начало/финиш: то добавляем "0", то убираем " ' ", то ли 11зн, альбо менее?!. ;)
- http://www.excelworld.ru/forum/2-21525-1#173805
- http://www.excelworld.ru/forum/2-21525-173834-9-1[/offtop]


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

Сообщение отредактировал TimSha - Пятница, 12.02.2016, 16:24
 
Ответить
Сообщение[offtop]Ситуация РазДваЯица - где начало/финиш: то добавляем "0", то убираем " ' ", то ли 11зн, альбо менее?!. ;)
- http://www.excelworld.ru/forum/2-21525-1#173805
- http://www.excelworld.ru/forum/2-21525-173834-9-1[/offtop]

Автор - TimSha
Дата добавления - 12.02.2016 в 16:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Невидимый апостроф (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!