Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/не могу убрать запятые - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не могу убрать запятые (Формулы/Formulas)
не могу убрать запятые
dastal Дата: Понедельник, 15.02.2016, 17:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!

Помогите убрать запятые в конце строке, но оставив которые внутри. Строки разные пример во вложениие.
К сообщению приложен файл: 6263932.xlsx(78Kb)
 
Ответить
СообщениеДобрый день!

Помогите убрать запятые в конце строке, но оставив которые внутри. Строки разные пример во вложениие.

Автор - dastal
Дата добавления - 15.02.2016 в 17:49
Nic70y Дата: Понедельник, 15.02.2016, 17:56 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
вариант(ы)
Код
=ЛЕВБ(A1;ДЛСТР(A1)-1)
Код
=ЛЕВБ(A1;ДЛСТР(A1)-(ПРАВБ(A1)=","))
К сообщению приложен файл: 1-14.xlsx(15Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант(ы)
Код
=ЛЕВБ(A1;ДЛСТР(A1)-1)
Код
=ЛЕВБ(A1;ДЛСТР(A1)-(ПРАВБ(A1)=","))

Автор - Nic70y
Дата добавления - 15.02.2016 в 17:56
dastal Дата: Понедельник, 15.02.2016, 17:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо
 
Ответить
СообщениеСпасибо

Автор - dastal
Дата добавления - 15.02.2016 в 17:57
Udik Дата: Понедельник, 15.02.2016, 18:05 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
я бы проверку провёл предварительно :)
Код
=ЕСЛИ(ПРАВСИМВ(RC[-8];1)=",";ЛЕВСИМВ(RC[-8];ДЛСТР(RC[-8])-1);RC[-8])

а, во второй формуле она есть


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Понедельник, 15.02.2016, 18:09
 
Ответить
Сообщениея бы проверку провёл предварительно :)
Код
=ЕСЛИ(ПРАВСИМВ(RC[-8];1)=",";ЛЕВСИМВ(RC[-8];ДЛСТР(RC[-8])-1);RC[-8])

а, во второй формуле она есть

Автор - Udik
Дата добавления - 15.02.2016 в 18:05
Nic70y Дата: Понедельник, 15.02.2016, 18:07 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
я бы проверку

-(ПРАВБ(A1)=",")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
я бы проверку

-(ПРАВБ(A1)=",")

Автор - Nic70y
Дата добавления - 15.02.2016 в 18:07
Udik Дата: Понедельник, 15.02.2016, 18:08 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1209
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
увидел уже B)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеувидел уже B)

Автор - Udik
Дата добавления - 15.02.2016 в 18:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не могу убрать запятые (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!