Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула найти дату(ДД.ММММ.ГГГГ) в тексте ячейки Excel - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула найти дату(ДД.ММММ.ГГГГ) в тексте ячейки Excel (Формулы/Formulas)
Формула найти дату(ДД.ММММ.ГГГГ) в тексте ячейки Excel
Dirc Дата: Четверг, 18.02.2016, 12:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток.
Прошу помощи в решения данного вопроса.
Смысл задачи:
Есть строка в таблице: Счет № 19 от 15 Февраля 2016 г.
Требуется вернуть дату из этой строки: 15 Февраля 2016 г.
--------------------------------------------------
Нашёл решение, но оно не подходит для данного примера
При помощи функции:
Код
=ЕСЛИ(ЕТЕКСТ(A1);ПСТР(A1;ПОИСК("??.??.???? г."; A1);10);0)

Можно вернуть дату но при условии того что в искомой строке дата будет в формате:
Счет № 19 от 15.02.2016 г.
--------------------------------------------------
Вопрос: Как вернуть дату в тексте ячейки Excel при формате даты: от 15 Февраля 2016 г.
К сообщению приложен файл: 9385465.xls(24Kb)


Сообщение отредактировал Dirc - Четверг, 18.02.2016, 14:07
 
Ответить
СообщениеДоброго времени суток.
Прошу помощи в решения данного вопроса.
Смысл задачи:
Есть строка в таблице: Счет № 19 от 15 Февраля 2016 г.
Требуется вернуть дату из этой строки: 15 Февраля 2016 г.
--------------------------------------------------
Нашёл решение, но оно не подходит для данного примера
При помощи функции:
Код
=ЕСЛИ(ЕТЕКСТ(A1);ПСТР(A1;ПОИСК("??.??.???? г."; A1);10);0)

Можно вернуть дату но при условии того что в искомой строке дата будет в формате:
Счет № 19 от 15.02.2016 г.
--------------------------------------------------
Вопрос: Как вернуть дату в тексте ячейки Excel при формате даты: от 15 Февраля 2016 г.

Автор - Dirc
Дата добавления - 18.02.2016 в 12:57
AlexM Дата: Четверг, 18.02.2016, 14:21 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Код
=ПРОСМОТР(9^9;--ПРАВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"ая";"ай ");"я ";" ");" г.";"");СТРОКА($10:$15)))
К сообщению приложен файл: 9385465_1.xls(24Kb)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=ПРОСМОТР(9^9;--ПРАВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A1;"ая";"ай ");"я ";" ");" г.";"");СТРОКА($10:$15)))

Автор - AlexM
Дата добавления - 18.02.2016 в 14:21
_Boroda_ Дата: Четверг, 18.02.2016, 14:35 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не так универсально, зато покороче
Код
=--(ПСТР(A2;ПОИСК(" от ";A2)+4;6)&ЛЕВБ(ПРАВБ(A2;7);4))
К сообщению приложен файл: 0376784.xls(24Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе так универсально, зато покороче
Код
=--(ПСТР(A2;ПОИСК(" от ";A2)+4;6)&ЛЕВБ(ПРАВБ(A2;7);4))

Автор - _Boroda_
Дата добавления - 18.02.2016 в 14:35
Dirc Дата: Четверг, 18.02.2016, 14:37 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо за решения.


Сообщение отредактировал Dirc - Четверг, 18.02.2016, 15:30
 
Ответить
СообщениеСпасибо за решения.

Автор - Dirc
Дата добавления - 18.02.2016 в 14:37
Dirc Дата: Четверг, 18.02.2016, 15:24 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
И последний вопрос, если строка будет такого вида: Контракт № 27ПК/15 от «01» Декабря 2015 года
 
Ответить
СообщениеИ последний вопрос, если строка будет такого вида: Контракт № 27ПК/15 от «01» Декабря 2015 года

Автор - Dirc
Дата добавления - 18.02.2016 в 15:24
AlexM Дата: Четверг, 18.02.2016, 15:41 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

О функции СТРОКА() можно прочитать в справке, а фрагмент формулы с этой функцией возвращает массив чисел {10:11:12:13:14:15}
По последнему вопросу. В моей формуле надо вместо " г." вставить " года"
Если формулу делать универсальной, например под эти два варианта, еще надо "»" заменить на пусто


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеО функции СТРОКА() можно прочитать в справке, а фрагмент формулы с этой функцией возвращает массив чисел {10:11:12:13:14:15}
По последнему вопросу. В моей формуле надо вместо " г." вставить " года"
Если формулу делать универсальной, например под эти два варианта, еще надо "»" заменить на пусто

Автор - AlexM
Дата добавления - 18.02.2016 в 15:41
Dirc Дата: Четверг, 18.02.2016, 15:54 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Благодарю
 
Ответить
СообщениеБлагодарю

Автор - Dirc
Дата добавления - 18.02.2016 в 15:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула найти дату(ДД.ММММ.ГГГГ) в тексте ячейки Excel (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!