Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/% от количества текстовых значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » % от количества текстовых значений (Формулы/Formulas)
% от количества текстовых значений
Pillow Дата: Четверг, 18.02.2016, 13:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Помогите пожалуйста. Как определить процент количества из оценки каждой категории типа "A", "B", "C", "D", "E" (текстовой) от общего количества оценок в ряде. Надеюсь нормально объяснила. За ранее благодарю
К сообщению приложен файл: table1.xlsx(9Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста. Как определить процент количества из оценки каждой категории типа "A", "B", "C", "D", "E" (текстовой) от общего количества оценок в ряде. Надеюсь нормально объяснила. За ранее благодарю

Автор - Pillow
Дата добавления - 18.02.2016 в 13:47
_Boroda_ Дата: Четверг, 18.02.2016, 13:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИ($B3:$J3;L$1;$C3:$K3)/СУММ($C3:$K3)
К сообщению приложен файл: table1_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИ($B3:$J3;L$1;$C3:$K3)/СУММ($C3:$K3)

Автор - _Boroda_
Дата добавления - 18.02.2016 в 13:52
Pillow Дата: Четверг, 18.02.2016, 16:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

нет. это скорее вот так: =СЧЁТЕСЛИ(B3:K3;"A")/5
только вместо деления на конкретное число (количество столбиков), нужно, чтоб само считало это количество столбиков с буквенными значениями
К сообщению приложен файл: 1290563.xlsx(10Kb)
 
Ответить
Сообщениенет. это скорее вот так: =СЧЁТЕСЛИ(B3:K3;"A")/5
только вместо деления на конкретное число (количество столбиков), нужно, чтоб само считало это количество столбиков с буквенными значениями

Автор - Pillow
Дата добавления - 18.02.2016 в 16:45
_Boroda_ Дата: Четверг, 18.02.2016, 16:49 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А, вон Вы о чем. Тогда так
Код
=СЧЁТЕСЛИ($B3:$K3;L$1)/СЧЁТЕСЛИ($B3:$K3;"*")
К сообщению приложен файл: 1290563_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА, вон Вы о чем. Тогда так
Код
=СЧЁТЕСЛИ($B3:$K3;L$1)/СЧЁТЕСЛИ($B3:$K3;"*")

Автор - _Boroda_
Дата добавления - 18.02.2016 в 16:49
Pillow Дата: Четверг, 18.02.2016, 17:07 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Спасибо. Счет правильный.
А "*"-звездочка, что задает, как она работает?
 
Ответить
СообщениеСпасибо. Счет правильный.
А "*"-звездочка, что задает, как она работает?

Автор - Pillow
Дата добавления - 18.02.2016 в 17:07
Udik Дата: Четверг, 18.02.2016, 17:10 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1215
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
А "*"-звездочка, что задает,

ячейки с текстом, не с цифрами


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщение
А "*"-звездочка, что задает,

ячейки с текстом, не с цифрами

Автор - Udik
Дата добавления - 18.02.2016 в 17:10
_Boroda_ Дата: Четверг, 18.02.2016, 17:10 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А "*"-звездочка, что задает

* - любое кол-во любых текстовых символов.
? - один любой текстовой символ
Для поиска самих * и ? перед ними нужно поставить тильду, вот так -
Код
=СЧЁТЕСЛИ(диапазон;"~*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
А "*"-звездочка, что задает

* - любое кол-во любых текстовых символов.
? - один любой текстовой символ
Для поиска самих * и ? перед ними нужно поставить тильду, вот так -
Код
=СЧЁТЕСЛИ(диапазон;"~*")

Автор - _Boroda_
Дата добавления - 18.02.2016 в 17:10
Pillow Дата: Четверг, 18.02.2016, 17:19 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Круто) а символ для числовых значений стало быть тоже есть?
 
Ответить
СообщениеКруто) а символ для числовых значений стало быть тоже есть?

Автор - Pillow
Дата добавления - 18.02.2016 в 17:19
_Boroda_ Дата: Четверг, 18.02.2016, 17:27 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПочти
http://www.excelworld.ru/forum/2-21472-173471-16-1455137502

Автор - _Boroda_
Дата добавления - 18.02.2016 в 17:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » % от количества текстовых значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!