Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из одной таблицы в другую - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одной таблицы в другую (Формулы/Formulas)
Перенос данных из одной таблицы в другую
Rodger Дата: Четверг, 18.02.2016, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Помогите пожалуйста решить проблему. Как можно быстро преобразовать таблицу из "Лист 1" в таблицу которая на листе "Должно получиться"? Голову уже сломал, ничего не получается. ВПР бы сделал, но косяк в том, что некоторые Контрагенты встречаются по несколько раз, с разными договорами. А ВПР берет значение по первому вхождению и как это исправить я не знаю. Или другими формулами может надо...
[moder]Как-то переназовите тему, а то она прямо подпадает под п.2 Правил форума. Сразу скажу, что не знаю, как.
К сообщению приложен файл: 0976152.xlsx(16Kb)


Сообщение отредактировал Rodger - Четверг, 18.02.2016, 15:46
 
Ответить
СообщениеДобрый день. Помогите пожалуйста решить проблему. Как можно быстро преобразовать таблицу из "Лист 1" в таблицу которая на листе "Должно получиться"? Голову уже сломал, ничего не получается. ВПР бы сделал, но косяк в том, что некоторые Контрагенты встречаются по несколько раз, с разными договорами. А ВПР берет значение по первому вхождению и как это исправить я не знаю. Или другими формулами может надо...
[moder]Как-то переназовите тему, а то она прямо подпадает под п.2 Правил форума. Сразу скажу, что не знаю, как.

Автор - Rodger
Дата добавления - 18.02.2016 в 15:17
Manyasha Дата: Четверг, 18.02.2016, 16:01 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 661 ±
Замечаний: 0% ±

Excel 2007, 2010
Rodger, так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2016'!$E$3:$E$11;НАИМЕНЬШИЙ(ЕСЛИ('2016'!$D$3:$D$11='Должно получиться'!$D3;СТРОКА($A$1:$A$9));СТОЛБЕЦ(A1)));"")

формула массива, вводить через ctrl+shift+enter
К сообщению приложен файл: 0976152_1.xlsx(16Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеRodger, так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС('2016'!$E$3:$E$11;НАИМЕНЬШИЙ(ЕСЛИ('2016'!$D$3:$D$11='Должно получиться'!$D3;СТРОКА($A$1:$A$9));СТОЛБЕЦ(A1)));"")

формула массива, вводить через ctrl+shift+enter

Автор - Manyasha
Дата добавления - 18.02.2016 в 16:01
Rodger Дата: Четверг, 18.02.2016, 16:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, Спасибо большое. То, что надо и очень оперативно.
 
Ответить
СообщениеManyasha, Спасибо большое. То, что надо и очень оперативно.

Автор - Rodger
Дата добавления - 18.02.2016 в 16:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одной таблицы в другую (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!