Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать совпадающие значения в разных файлах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать совпадающие значения в разных файлах (Формулы/Formulas)
Выбрать совпадающие значения в разных файлах
CatalinaOwl Дата: Четверг, 18.02.2016, 16:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.

Есть два файла. В каждом по 8 -10 столбцов, и по 1200 строк (количество строк приблизительно, в двух файлах кол. может отличаться).

В первом столбце, каждого файла, стоят номера, например - rkjh1187, 11178, jhjhd537re. (В остальных столбцах, информация по этим номерам).

Некоторые такие номера, совпадают в этих двух файлах. Таких номеров 1100. Количество номеров в двух файлах не совпадает, т.е. в первом файле их 1100, а во втором их может быть 200.

Нужно выбрать и занести в третий документ, только совпадающие номера.
[moder]
Цитата
Есть два файла
Показывайте![/moder]


Сообщение отредактировал Manyasha - Четверг, 18.02.2016, 16:21
 
Ответить
СообщениеДобрый день.

Есть два файла. В каждом по 8 -10 столбцов, и по 1200 строк (количество строк приблизительно, в двух файлах кол. может отличаться).

В первом столбце, каждого файла, стоят номера, например - rkjh1187, 11178, jhjhd537re. (В остальных столбцах, информация по этим номерам).

Некоторые такие номера, совпадают в этих двух файлах. Таких номеров 1100. Количество номеров в двух файлах не совпадает, т.е. в первом файле их 1100, а во втором их может быть 200.

Нужно выбрать и занести в третий документ, только совпадающие номера.
[moder]
Цитата
Есть два файла
Показывайте![/moder]

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 16:17
CatalinaOwl Дата: Четверг, 18.02.2016, 16:33 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добавила файл.

Сделала, не в двух файлах, а на двух листах.
К сообщению приложен файл: _2.xlsx(14Kb)
 
Ответить
СообщениеДобавила файл.

Сделала, не в двух файлах, а на двух листах.

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 16:33
CatalinaOwl Дата: Четверг, 18.02.2016, 17:03 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
В третьем документе, должны быть совпадающие "номера" и информация по ним (из других столбцов, т.е. вся строка),

т.е. получается что нужно выбрать по первым столбцам совпадающие "номера",

их отметить, цветом например, остальные строки скрыть.

Когда элементов более 1000, в ручную, это занимает много времени, а нужно быстро.

(При этом поиск должен быть только, по первым столбцам, т.к. в других столбцах эти номера тоже могут повторятся - но это не актуально).
 
Ответить
СообщениеВ третьем документе, должны быть совпадающие "номера" и информация по ним (из других столбцов, т.е. вся строка),

т.е. получается что нужно выбрать по первым столбцам совпадающие "номера",

их отметить, цветом например, остальные строки скрыть.

Когда элементов более 1000, в ручную, это занимает много времени, а нужно быстро.

(При этом поиск должен быть только, по первым столбцам, т.к. в других столбцах эти номера тоже могут повторятся - но это не актуально).

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 17:03
Manyasha Дата: Четверг, 18.02.2016, 17:19 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 660 ±
Замечаний: 0% ±

Excel 2007, 2010
CatalinaOwl, так подойдет?
для первого столбца:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$5:$A$100;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(Лист1!$A$3:$A$100;Лист2!$A$5:$A$100);СТРОКА(Лист2!$A$5:$A$100)-4);СТРОКА(A1)));"")
формула массива, вводится сочетанием ctrl+shift+enter.
Остальные столбцы можно ВПРом вытянуть
К сообщению приложен файл: _2_1.xlsx(15Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеCatalinaOwl, так подойдет?
для первого столбца:
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$5:$A$100;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ(Лист1!$A$3:$A$100;Лист2!$A$5:$A$100);СТРОКА(Лист2!$A$5:$A$100)-4);СТРОКА(A1)));"")
формула массива, вводится сочетанием ctrl+shift+enter.
Остальные столбцы можно ВПРом вытянуть

Автор - Manyasha
Дата добавления - 18.02.2016 в 17:19
CatalinaOwl Дата: Четверг, 18.02.2016, 17:26 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Попробую. А если нужно сравнивать не на литах, а в двух разных файлах?
 
Ответить
СообщениеСпасибо. Попробую. А если нужно сравнивать не на литах, а в двух разных файлах?

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 17:26
CatalinaOwl Дата: Четверг, 18.02.2016, 17:26 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
бывает и так и так
 
Ответить
Сообщениебывает и так и так

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 17:26
Manyasha Дата: Четверг, 18.02.2016, 17:37 | Сообщение № 7
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 660 ±
Замечаний: 0% ±

Excel 2007, 2010
в двух разных файлах
замените Лист2!$A$5:$A$100 на [Книга1.xlsx]Лист1!$A$5:$A$100, остальные ссылки по аналогии.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщение
в двух разных файлах
замените Лист2!$A$5:$A$100 на [Книга1.xlsx]Лист1!$A$5:$A$100, остальные ссылки по аналогии.

Автор - Manyasha
Дата добавления - 18.02.2016 в 17:37
CatalinaOwl Дата: Четверг, 18.02.2016, 17:47 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо. Попробую.
 
Ответить
СообщениеСпасибо. Попробую.

Автор - CatalinaOwl
Дата добавления - 18.02.2016 в 17:47
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать совпадающие значения в разных файлах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!