Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск по столбцу и подсчет значений в соседнем столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по столбцу и подсчет значений в соседнем столбце (Формулы/Formulas)
Поиск по столбцу и подсчет значений в соседнем столбце
atomrus1993 Дата: Суббота, 20.02.2016, 14:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Такая проблема...
Есть 2 столбца:
В первом содержатся буквы, во втором цифры(0 или 1)
Как посчитать количество одинаковых цифр (например 1) в соответствии с буквой.

[vba]
Код
Г    0
Г    1
Ш    1
Ш    0
Ш    1
Г    0
Г    1
Г    0
Г    0
Г    0
Ш    1
Г    1
Г    1
А    1
К    0
К    0
Г    1
[/vba]
Как подсчитать сколько раз цифра 1 соответствует букве Г например.
p.s.: смог только посчитать сколько раз упоминается буква(через СЧЕТЕСЛИ)... а соответствие установить не удалось
 
Ответить
СообщениеЗдравствуйте. Такая проблема...
Есть 2 столбца:
В первом содержатся буквы, во втором цифры(0 или 1)
Как посчитать количество одинаковых цифр (например 1) в соответствии с буквой.

[vba]
Код
Г    0
Г    1
Ш    1
Ш    0
Ш    1
Г    0
Г    1
Г    0
Г    0
Г    0
Ш    1
Г    1
Г    1
А    1
К    0
К    0
Г    1
[/vba]
Как подсчитать сколько раз цифра 1 соответствует букве Г например.
p.s.: смог только посчитать сколько раз упоминается буква(через СЧЕТЕСЛИ)... а соответствие установить не удалось

Автор - atomrus1993
Дата добавления - 20.02.2016 в 14:12
Manyasha Дата: Суббота, 20.02.2016, 14:23 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1582
Репутация: 659 ±
Замечаний: 0% ±

Excel 2007, 2010
atomrus1993, используйте СУММЕСЛИМН или СУММПРОИЗВ или сводную.
Подробнее только с файлом!


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеatomrus1993, используйте СУММЕСЛИМН или СУММПРОИЗВ или сводную.
Подробнее только с файлом!

Автор - Manyasha
Дата добавления - 20.02.2016 в 14:23
atomrus1993 Дата: Суббота, 20.02.2016, 14:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
atomrus1993, используйте СУММЕСЛИМН или СУММПРОИЗВ или сводную.
Подробнее только с файлом!

Спасибо большое! направили :) ) СУММЕСЛИ помог и в добавок документацию прочитал ещё) не болейте ^_^ hands


Сообщение отредактировал atomrus1993 - Суббота, 20.02.2016, 14:43
 
Ответить
Сообщение
atomrus1993, используйте СУММЕСЛИМН или СУММПРОИЗВ или сводную.
Подробнее только с файлом!

Спасибо большое! направили :) ) СУММЕСЛИ помог и в добавок документацию прочитал ещё) не болейте ^_^ hands

Автор - atomrus1993
Дата добавления - 20.02.2016 в 14:40
buchlotnik Дата: Суббота, 20.02.2016, 14:44 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
можно вроде такого
Код
=СУММПРОИЗВ(--(A1:A20&B1:B20="Г1"))
детали при наличии файла


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеможно вроде такого
Код
=СУММПРОИЗВ(--(A1:A20&B1:B20="Г1"))
детали при наличии файла

Автор - buchlotnik
Дата добавления - 20.02.2016 в 14:44
atomrus1993 Дата: Суббота, 20.02.2016, 14:48 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
можно вроде такого

=СУММПРОИЗВ(--(A1:A20&B1:B20="Г1"))
детали при наличии файла
К сообщению приложен файл: 2634931.xlsx(14Kb)
 
Ответить
Сообщение
можно вроде такого

=СУММПРОИЗВ(--(A1:A20&B1:B20="Г1"))
детали при наличии файла

Автор - atomrus1993
Дата добавления - 20.02.2016 в 14:48
_Boroda_ Дата: Суббота, 20.02.2016, 15:05 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9346
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
atomrus1993, обратите внимание на доллары в формуле - так ее (формулу) можно протягивать вправо
Код
=СУММЕСЛИ($C2:$D74;O$12;$D2:$D74)
К сообщению приложен файл: 2634931_1.xlsx(14Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщениеatomrus1993, обратите внимание на доллары в формуле - так ее (формулу) можно протягивать вправо
Код
=СУММЕСЛИ($C2:$D74;O$12;$D2:$D74)

Автор - _Boroda_
Дата добавления - 20.02.2016 в 15:05
atomrus1993 Дата: Суббота, 20.02.2016, 15:16 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
atomrus1993, обратите внимание на доллары в формуле - так ее (формулу) можно протягивать вправо

спасибо учту))
 
Ответить
Сообщение
atomrus1993, обратите внимание на доллары в формуле - так ее (формулу) можно протягивать вправо

спасибо учту))

Автор - atomrus1993
Дата добавления - 20.02.2016 в 15:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск по столбцу и подсчет значений в соседнем столбце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!