Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/входит ли Тдата() во временной интервал? + условное форматир - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » входит ли Тдата() во временной интервал? + условное форматир (Формулы/Formulas)
входит ли Тдата() во временной интервал? + условное форматир
lFJl Дата: Понедельник, 22.02.2016, 17:48 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Доброго дня!
подскажите, какой формулой можно посчитать, входит ли ТДАТА() во временной интервал, который задан в 2х ячейках от и до. Пример написал.
Хочу это использовать Услов. Формат.
Я вроде все сделал, да вот когда интервал например от 23.00-12.00, а текущее время 11.00 например, не могу додумать формулу. Хоть задачка кажется мне простой, решения я не нашел.
К сообщению приложен файл: 0200343.xlsx(11Kb)
 
Ответить
СообщениеДоброго дня!
подскажите, какой формулой можно посчитать, входит ли ТДАТА() во временной интервал, который задан в 2х ячейках от и до. Пример написал.
Хочу это использовать Услов. Формат.
Я вроде все сделал, да вот когда интервал например от 23.00-12.00, а текущее время 11.00 например, не могу додумать формулу. Хоть задачка кажется мне простой, решения я не нашел.

Автор - lFJl
Дата добавления - 22.02.2016 в 17:48
Pelena Дата: Понедельник, 22.02.2016, 17:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
По мотивам Вашей формулы
Код
=ЕСЛИ($A2<=$B2;И(ОСТАТ(ТДАТА();1)>=$A2;ОСТАТ(ТДАТА();1)<=$B2);ИЛИ(ОСТАТ(ТДАТА();1)>=$A2;ОСТАТ(ТДАТА();1)<=$B2))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПо мотивам Вашей формулы
Код
=ЕСЛИ($A2<=$B2;И(ОСТАТ(ТДАТА();1)>=$A2;ОСТАТ(ТДАТА();1)<=$B2);ИЛИ(ОСТАТ(ТДАТА();1)>=$A2;ОСТАТ(ТДАТА();1)<=$B2))

Автор - Pelena
Дата добавления - 22.02.2016 в 17:57
lFJl Дата: Понедельник, 22.02.2016, 20:17 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
Pelena, В сотый раз спасибо! :)
 
Ответить
СообщениеPelena, В сотый раз спасибо! :)

Автор - lFJl
Дата добавления - 22.02.2016 в 20:17
_Boroda_ Дата: Понедельник, 22.02.2016, 21:35 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=МЕДИАНА(A2;B2+(B2<A2);ОСТАТ(ТДАТА();1))=ОСТАТ(ТДАТА();1)

Медиана дает середину из трех (в нашем случае) чисел
Или
Код
=(A2<=ОСТАТ(ТДАТА();1))*(B2+(B2<A2)>=ОСТАТ(ТДАТА();1))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=МЕДИАНА(A2;B2+(B2<A2);ОСТАТ(ТДАТА();1))=ОСТАТ(ТДАТА();1)

Медиана дает середину из трех (в нашем случае) чисел
Или
Код
=(A2<=ОСТАТ(ТДАТА();1))*(B2+(B2<A2)>=ОСТАТ(ТДАТА();1))

Автор - _Boroda_
Дата добавления - 22.02.2016 в 21:35
lFJl Дата: Среда, 24.02.2016, 17:25 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 3 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, И снова спасибо! :)
 
Ответить
Сообщение_Boroda_, И снова спасибо! :)

Автор - lFJl
Дата добавления - 24.02.2016 в 17:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » входит ли Тдата() во временной интервал? + условное форматир (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!