Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Изменение имени ячейки в формуле для диапазона ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение имени ячейки в формуле для диапазона ячеек (Формулы/Formulas)
Изменение имени ячейки в формуле для диапазона ячеек
0074977 Дата: Среда, 24.02.2016, 09:23 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
На листе 2 берутся данные с листа 1. Поскольку на первом листе блоки занимают 5 строк, а на листе 2 - 8 строк, то данные для 2-го листа для 2-го блока берутся на 3 строчки ниже, чем нужно. Например: в ячейке Лист2 D11 должна стоять формула =Лист1!D11, а стоит =Лист1!D14.

Есть ли какая-нибудь формула, чтобы на 2-ом листе во втором блоке строк в формулах у имен ячеек отнять 3?
К сообщению приложен файл: 0530998.xlsx(53Kb)
 
Ответить
СообщениеНа листе 2 берутся данные с листа 1. Поскольку на первом листе блоки занимают 5 строк, а на листе 2 - 8 строк, то данные для 2-го листа для 2-го блока берутся на 3 строчки ниже, чем нужно. Например: в ячейке Лист2 D11 должна стоять формула =Лист1!D11, а стоит =Лист1!D14.

Есть ли какая-нибудь формула, чтобы на 2-ом листе во втором блоке строк в формулах у имен ячеек отнять 3?

Автор - 0074977
Дата добавления - 24.02.2016 в 09:23
Nic70y Дата: Среда, 24.02.2016, 09:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3471
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
как-то так:
Код
=ИНДЕКС(Лист1!D:D;ОКРУГЛВВЕРХ(СТРОКА(A2)/9;)*5+ЦЕЛОЕ(СТРОКА(A2)/9))
К сообщению приложен файл: 2708512.xlsx(51Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениекак-то так:
Код
=ИНДЕКС(Лист1!D:D;ОКРУГЛВВЕРХ(СТРОКА(A2)/9;)*5+ЦЕЛОЕ(СТРОКА(A2)/9))

Автор - Nic70y
Дата добавления - 24.02.2016 в 09:47
Pelena Дата: Среда, 24.02.2016, 09:49 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ещё вариант
К сообщению приложен файл: 2904611.xlsx(53Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант

Автор - Pelena
Дата добавления - 24.02.2016 в 09:49
0074977 Дата: Среда, 24.02.2016, 10:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо, попробую применить.
 
Ответить
СообщениеСпасибо, попробую применить.

Автор - 0074977
Дата добавления - 24.02.2016 в 10:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Изменение имени ячейки в формуле для диапазона ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!