Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Табель учета рабочего времени: Не правильно считает формула - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Табель учета рабочего времени: Не правильно считает формула (Формулы/Formulas)
Табель учета рабочего времени: Не правильно считает формула
Sem1970 Дата: Понедельник, 29.02.2016, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте знатоки!
Прошу Вас помочь разобраться почему не работает формула. Я так думаю не считает работу в выходные дни, но могу ошибаться. Более подробная информация в файле.
С уважением,
Семен :(
К сообщению приложен файл: 2207510.xlsx(81Kb)
 
Ответить
СообщениеЗдравствуйте знатоки!
Прошу Вас помочь разобраться почему не работает формула. Я так думаю не считает работу в выходные дни, но могу ошибаться. Более подробная информация в файле.
С уважением,
Семен :(

Автор - Sem1970
Дата добавления - 29.02.2016 в 13:17
_Boroda_ Дата: Понедельник, 29.02.2016, 13:56 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(AD23="";"";СУММПРОИЗВ((F22:U25=AD23)*((ЕСЛИОШИБКА(ДЕНЬНЕД($F$17:$U$20;2);7)<6)+ЕЧИСЛО(ПОИСКПОЗ($F$17:$U$20;выхрабд;0))>0)*(ЕНД(ПОИСКПОЗ($F$17:$U$20;празд;0))))&"("&СУММПРОИЗВ((F22:U25=AD23)*((ЕСЛИОШИБКА(ДЕНЬНЕД($F$17:$U$20;2);7)<6)+ЕЧИСЛО(ПОИСКПОЗ($F$17:$U$20;выхрабд;0))>0)*(ЕНД(ПОИСКПОЗ($F$17:$U$20;празд;0))))*8-СЧЁТ(ПОИСКПОЗ(F$17:U$20;предпр;))&")")
К сообщению приложен файл: 2207510_1.xlsx(79Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(AD23="";"";СУММПРОИЗВ((F22:U25=AD23)*((ЕСЛИОШИБКА(ДЕНЬНЕД($F$17:$U$20;2);7)<6)+ЕЧИСЛО(ПОИСКПОЗ($F$17:$U$20;выхрабд;0))>0)*(ЕНД(ПОИСКПОЗ($F$17:$U$20;празд;0))))&"("&СУММПРОИЗВ((F22:U25=AD23)*((ЕСЛИОШИБКА(ДЕНЬНЕД($F$17:$U$20;2);7)<6)+ЕЧИСЛО(ПОИСКПОЗ($F$17:$U$20;выхрабд;0))>0)*(ЕНД(ПОИСКПОЗ($F$17:$U$20;празд;0))))*8-СЧЁТ(ПОИСКПОЗ(F$17:U$20;предпр;))&")")

Автор - _Boroda_
Дата добавления - 29.02.2016 в 13:56
Sem1970 Дата: Понедельник, 29.02.2016, 13:58 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, огромное Вам спасибо!!! hands
 
Ответить
СообщениеДа, огромное Вам спасибо!!! hands

Автор - Sem1970
Дата добавления - 29.02.2016 в 13:58
Sem1970 Дата: Понедельник, 29.02.2016, 14:47 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу прощения, но есть ошибка в формуле, где не могу понять. В приложенном файле все описал.
С уважением,
Семен. :(
К сообщению приложен файл: 3906404.xlsx(82Kb)
 
Ответить
СообщениеПрошу прощения, но есть ошибка в формуле, где не могу понять. В приложенном файле все описал.
С уважением,
Семен. :(

Автор - Sem1970
Дата добавления - 29.02.2016 в 14:47
_Boroda_ Дата: Понедельник, 29.02.2016, 15:54 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
22 февраля косячил
К сообщению приложен файл: 3906404_1.xlsx(81Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение22 февраля косячил

Автор - _Boroda_
Дата добавления - 29.02.2016 в 15:54
Sem1970 Дата: Понедельник, 29.02.2016, 16:07 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Еще раз низкий Вам поклон за Вашу работу. У меня нет слов... СПАСИБО! hands hands hands
 
Ответить
СообщениеЕще раз низкий Вам поклон за Вашу работу. У меня нет слов... СПАСИБО! hands hands hands

Автор - Sem1970
Дата добавления - 29.02.2016 в 16:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Табель учета рабочего времени: Не правильно считает формула (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!