Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Объединение нескольких условий ЕСЛИ в одной формуле - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение нескольких условий ЕСЛИ в одной формуле (Формулы/Formulas)
Объединение нескольких условий ЕСЛИ в одной формуле
lolkisonik Дата: Понедельник, 29.02.2016, 18:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Люди добрые подскажите, как объединить несколько условий если в одно.
Пример:
=Если(A2-B2<5000;B1)
=Если(A2-C2<5000;C1)
=Если(A2-D2<5000;D1)
Надо еще чтоб значение через запятую выводилось (B1,C1,D1)
 
Ответить
СообщениеЛюди добрые подскажите, как объединить несколько условий если в одно.
Пример:
=Если(A2-B2<5000;B1)
=Если(A2-C2<5000;C1)
=Если(A2-D2<5000;D1)
Надо еще чтоб значение через запятую выводилось (B1,C1,D1)

Автор - lolkisonik
Дата добавления - 29.02.2016 в 18:06
Manyasha Дата: Понедельник, 29.02.2016, 18:17 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1587
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
lolkisonik, так?
Код
=ЕСЛИ(A2-B2<5000;B1&", ";"")&ЕСЛИ(A2-C2<5000;C1&", ";"")&ЕСЛИ(A2-D2<5000;D1&", ";"")


UPD
лучше так (чтобы последняя запятая убивалась):
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЕСЛИ(A2-B2<5000;B1&" ";"")&ЕСЛИ(A2-C2<5000;C1&" ";"")&ЕСЛИ(A2-D2<5000;D1&" ";""));" ";", ")

Если не то, показывайте пример в файле.


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Понедельник, 29.02.2016, 18:26
 
Ответить
Сообщениеlolkisonik, так?
Код
=ЕСЛИ(A2-B2<5000;B1&", ";"")&ЕСЛИ(A2-C2<5000;C1&", ";"")&ЕСЛИ(A2-D2<5000;D1&", ";"")


UPD
лучше так (чтобы последняя запятая убивалась):
Код
=ПОДСТАВИТЬ(СЖПРОБЕЛЫ(ЕСЛИ(A2-B2<5000;B1&" ";"")&ЕСЛИ(A2-C2<5000;C1&" ";"")&ЕСЛИ(A2-D2<5000;D1&" ";""));" ";", ")

Если не то, показывайте пример в файле.

Автор - Manyasha
Дата добавления - 29.02.2016 в 18:17
lolkisonik Дата: Понедельник, 29.02.2016, 20:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Спасибо все работает, только теперь другой вопрос:
можно сделать так что б значение(B1,C1,D1) не менялись при копировании на (b2,C2,D2)
[moder]Вы зачем рапортуете? Эта кнопка не для того сделана.


Сообщение отредактировал _Boroda_ - Понедельник, 29.02.2016, 21:05
 
Ответить
СообщениеСпасибо все работает, только теперь другой вопрос:
можно сделать так что б значение(B1,C1,D1) не менялись при копировании на (b2,C2,D2)
[moder]Вы зачем рапортуете? Эта кнопка не для того сделана.

Автор - lolkisonik
Дата добавления - 29.02.2016 в 20:57
китин Дата: Понедельник, 29.02.2016, 21:03 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а значок $ поставить не вариант? типа $B$1.?
а это ведь уже другой вопрос.а по правилам один вопрос одна тема !


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 29.02.2016, 21:04
 
Ответить
Сообщениеа значок $ поставить не вариант? типа $B$1.?
а это ведь уже другой вопрос.а по правилам один вопрос одна тема !

Автор - китин
Дата добавления - 29.02.2016 в 21:03
Gustav Дата: Понедельник, 29.02.2016, 21:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1211
Репутация: 484 ±
Замечаний: 0% ±

начинал с Excel 4.0...
[offtop]В чём ВАЖНОСТЬ этой темы? Почему она в таком топе?


Мой tip box - яд 41001663842605
 
Ответить
Сообщение[offtop]В чём ВАЖНОСТЬ этой темы? Почему она в таком топе?

Автор - Gustav
Дата добавления - 29.02.2016 в 21:55
китин Дата: Понедельник, 29.02.2016, 21:58 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеуже разъяснили

Автор - китин
Дата добавления - 29.02.2016 в 21:58
m-akhmedveliev Дата: Суббота, 05.03.2016, 09:35 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем привет! Подскажите пожалуйста формулу: мне нужно, например:
Если значение (Текст) такой-то такой-то в одной ячейке, и значение (Текст) такой-то такой-то во второй ячейке, то значение в третей такое
 
Ответить
СообщениеВсем привет! Подскажите пожалуйста формулу: мне нужно, например:
Если значение (Текст) такой-то такой-то в одной ячейке, и значение (Текст) такой-то такой-то во второй ячейке, то значение в третей такое

Автор - m-akhmedveliev
Дата добавления - 05.03.2016 в 09:35
Nic70y Дата: Суббота, 05.03.2016, 10:07 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Так и напишите
Код
=ЕСЛИ(И(A1="такой-то такой-то";B2="такой-то такой-то");"такое-то")
, а если нет, то:
Код
=ЕСЛИ(И(A1="такой-то такой-то";B2="такой-то такой-то");"такое-то";"никакое")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 05.03.2016, 17:04
 
Ответить
СообщениеТак и напишите
Код
=ЕСЛИ(И(A1="такой-то такой-то";B2="такой-то такой-то");"такое-то")
, а если нет, то:
Код
=ЕСЛИ(И(A1="такой-то такой-то";B2="такой-то такой-то");"такое-то";"никакое")

Автор - Nic70y
Дата добавления - 05.03.2016 в 10:07
Василинка-Малинка Дата: Понедельник, 07.03.2016, 08:32 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
У меня вопрос по формуле ЕСЛИ, можно здесь спросить или новую тему открывать? А то у вас тут все строго, даже страшновато немного, поставят в бан, а мне ответ нужен.
[moder]Да, у нас тут строго. Строго по Правилам форума[/moder]


Сообщение отредактировал Pelena - Понедельник, 07.03.2016, 09:53
 
Ответить
СообщениеУ меня вопрос по формуле ЕСЛИ, можно здесь спросить или новую тему открывать? А то у вас тут все строго, даже страшновато немного, поставят в бан, а мне ответ нужен.
[moder]Да, у нас тут строго. Строго по Правилам форума[/moder]

Автор - Василинка-Малинка
Дата добавления - 07.03.2016 в 08:32
Василинка-Малинка Дата: Среда, 09.03.2016, 11:08 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нужно посчитать сумму премии с несколькими условиями. Если процент (желтая ячейка) от 90 до 92% от выполненного плана, то премия будет 0,1% от общей суммы (синяя ячейка), если 92% от плана, то 0,2% от общей суммы и т.д. Условия написаны справа.
Можно это все в 1 ячейки написать?
[moder]Почитайте п 5q Правил форума.
Создайте свою тему.[/moder]
К сообщению приложен файл: 3730714.xlsx(40Kb)


Сообщение отредактировал Manyasha - Среда, 09.03.2016, 11:18
 
Ответить
СообщениеНужно посчитать сумму премии с несколькими условиями. Если процент (желтая ячейка) от 90 до 92% от выполненного плана, то премия будет 0,1% от общей суммы (синяя ячейка), если 92% от плана, то 0,2% от общей суммы и т.д. Условия написаны справа.
Можно это все в 1 ячейки написать?
[moder]Почитайте п 5q Правил форума.
Создайте свою тему.[/moder]

Автор - Василинка-Малинка
Дата добавления - 09.03.2016 в 11:08
maksimusus Дата: Четверг, 24.03.2016, 16:31 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день. Есть данные:
до 1 000 000 - 0.0354%
свыше 1 000 000 до 5 000 000 - 0.0295%
свыше 5 000 000 до 10 000 000 - 0.0236%
свыше 10 000 000 до 20 000 000 - 0.0177%
свыше 20 000 000 до 50 000 000 - 0.01534%
свыше 50 000 000 до 100 000 000 - 0.0118%
свыше 100 000 000 - 0,00944%
Вопрос как внести данные условия формулой в одну ячейку.. Что б эксель видя число в ячейке условно B1, в ячейке C1 ставил соответствующее данным процентное число. запутался с "ЕСЛИ"..
[moder]Приложите пример в файле[/moder]

в ячейку " процент комиссии" должен выставляться, процент соответствующий Сумма 1 + Сумма 2 в свой строке.
К сообщению приложен файл: 2900524.xls(28Kb)


Сообщение отредактировал maksimusus - Четверг, 24.03.2016, 16:57
 
Ответить
СообщениеДобрый день. Есть данные:
до 1 000 000 - 0.0354%
свыше 1 000 000 до 5 000 000 - 0.0295%
свыше 5 000 000 до 10 000 000 - 0.0236%
свыше 10 000 000 до 20 000 000 - 0.0177%
свыше 20 000 000 до 50 000 000 - 0.01534%
свыше 50 000 000 до 100 000 000 - 0.0118%
свыше 100 000 000 - 0,00944%
Вопрос как внести данные условия формулой в одну ячейку.. Что б эксель видя число в ячейке условно B1, в ячейке C1 ставил соответствующее данным процентное число. запутался с "ЕСЛИ"..
[moder]Приложите пример в файле[/moder]

в ячейку " процент комиссии" должен выставляться, процент соответствующий Сумма 1 + Сумма 2 в свой строке.

Автор - maksimusus
Дата добавления - 24.03.2016 в 16:31
Nic70y Дата: Четверг, 24.03.2016, 16:45 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
вариант
Код
=ПРОСМОТР(B1;{0;1000000,01;5000000,01;10000000,01;20000000,01;50000000,01};{0,0354;0,0295;0,236;0,0177;0,0118;0,00944})%


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениевариант
Код
=ПРОСМОТР(B1;{0;1000000,01;5000000,01;10000000,01;20000000,01;50000000,01};{0,0354;0,0295;0,236;0,0177;0,0118;0,00944})%

Автор - Nic70y
Дата добавления - 24.03.2016 в 16:45
_Boroda_ Дата: Четверг, 24.03.2016, 16:49 | Сообщение № 13
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Из той же серии
Код
=ВПР((B2-0,1)%%%;{0;0,000354:1;0,000295:5;0,000236:10;0,000177:20;0,0001534:50;0,000118:100;0,0000944};2)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИз той же серии
Код
=ВПР((B2-0,1)%%%;{0;0,000354:1;0,000295:5;0,000236:10;0,000177:20;0,0001534:50;0,000118:100;0,0000944};2)

Автор - _Boroda_
Дата добавления - 24.03.2016 в 16:49
maksimusus Дата: Четверг, 24.03.2016, 16:55 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
в ячейку " процент комиссии" должен выставляться, процент соответствующий Сумма 1 + Сумма 2 в свой строке.
К сообщению приложен файл: 4055207.xls(28Kb)
 
Ответить
Сообщениев ячейку " процент комиссии" должен выставляться, процент соответствующий Сумма 1 + Сумма 2 в свой строке.

Автор - maksimusus
Дата добавления - 24.03.2016 в 16:55
maksimusus Дата: Четверг, 24.03.2016, 17:00 | Сообщение № 15
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, спасибо!
 
Ответить
Сообщение_Boroda_, спасибо!

Автор - maksimusus
Дата добавления - 24.03.2016 в 17:00
maksimusus Дата: Четверг, 24.03.2016, 17:01 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Nic70y, спасибо!
 
Ответить
СообщениеNic70y, спасибо!

Автор - maksimusus
Дата добавления - 24.03.2016 в 17:01
vikttur Дата: Четверг, 24.03.2016, 17:24 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Чтобы не путаться со сложной записью формулы, можно создать таблицу соответствий и диапазоном для функции ВПР брать эту таблицу. Примеров на форуме достаточно.
Код
=ВПР(B2;$F$3:$G$9;2)


Да, и редактировать диапазоны в случае необходимости проще.
К сообщению приложен файл: 8968665.xls(29Kb)


Сообщение отредактировал vikttur - Четверг, 24.03.2016, 17:31
 
Ответить
СообщениеЧтобы не путаться со сложной записью формулы, можно создать таблицу соответствий и диапазоном для функции ВПР брать эту таблицу. Примеров на форуме достаточно.
Код
=ВПР(B2;$F$3:$G$9;2)


Да, и редактировать диапазоны в случае необходимости проще.

Автор - vikttur
Дата добавления - 24.03.2016 в 17:24
maksimusus Дата: Пятница, 25.03.2016, 01:06 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
vikttur, спасибо, тоже вариант удобный, особенно если менять исходные данные
 
Ответить
Сообщениеvikttur, спасибо, тоже вариант удобный, особенно если менять исходные данные

Автор - maksimusus
Дата добавления - 25.03.2016 в 01:06
Skip Дата: Суббота, 26.03.2016, 19:57 | Сообщение № 19
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Здравствуйте.
Очень много знаний черпаю с данного ресурса (спасибо ВСЕМ).
Возникли трудности в написании (дополнении) формулы.
Кто чем может помогите плиз...
инф. в прикреплённом фале)
[moder]Вопрос не относится к теме "Объединение Нескольких значений ЕСЛИ в одно". Ответ удален[/moder]
К сообщению приложен файл: Help.xls(16Kb)


Сообщение отредактировал Pelena - Суббота, 26.03.2016, 20:13
 
Ответить
СообщениеЗдравствуйте.
Очень много знаний черпаю с данного ресурса (спасибо ВСЕМ).
Возникли трудности в написании (дополнении) формулы.
Кто чем может помогите плиз...
инф. в прикреплённом фале)
[moder]Вопрос не относится к теме "Объединение Нескольких значений ЕСЛИ в одно". Ответ удален[/moder]

Автор - Skip
Дата добавления - 26.03.2016 в 19:57
StoTisteg Дата: Суббота, 26.03.2016, 20:08 | Сообщение № 20
Группа: Авторы
Ранг: Ветеран
Сообщений: 541
Репутация: 45 ±
Замечаний: 0% ±

Excel 2010
Ответ удален


Проверь всё. ThisWorkbook.Save. On Error Resume Next.

Сообщение отредактировал Pelena - Суббота, 26.03.2016, 20:13
 
Ответить
СообщениеОтвет удален

Автор - StoTisteg
Дата добавления - 26.03.2016 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Объединение нескольких условий ЕСЛИ в одной формуле (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!