Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Избежать #H/Д при расчете через ЕСЛИ и ПОИСКПОЗ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Избежать #H/Д при расчете через ЕСЛИ и ПОИСКПОЗ (Формулы/Formulas)
Избежать #H/Д при расчете через ЕСЛИ и ПОИСКПОЗ
lebensvoll Дата: Среда, 02.03.2016, 13:18 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Добрый день форумчане!!!
Помогите избежать #Н/Д формула:
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28)

Не могу избежать #Н/Д хотелось чтоб было пусто :( (так ведь красиво выглядит таблица). Думал вот так вот:
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28);0;ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28)

Но и тут одержал поражение ((( ОШИБКА В ФОРМУЛЕ!!! Как можно было бы избежать #Н/Д в ячейке J11 (выделил желтым цветом), я потом по аналогии сделаю в других ячейках также.
ЗАРАНЕЕ ПРИ МНОГО БЛАГОДАРНОСТЕЙ ВАМ!
К сообщению приложен файл: ____.xlsx(16Kb)


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеДобрый день форумчане!!!
Помогите избежать #Н/Д формула:
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28)

Не могу избежать #Н/Д хотелось чтоб было пусто :( (так ведь красиво выглядит таблица). Думал вот так вот:
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28);0;ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J28)

Но и тут одержал поражение ((( ОШИБКА В ФОРМУЛЕ!!! Как можно было бы избежать #Н/Д в ячейке J11 (выделил желтым цветом), я потом по аналогии сделаю в других ячейках также.
ЗАРАНЕЕ ПРИ МНОГО БЛАГОДАРНОСТЕЙ ВАМ!

Автор - lebensvoll
Дата добавления - 02.03.2016 в 13:18
_Boroda_ Дата: Среда, 02.03.2016, 13:20 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ЕСЛИОШИБКА(формула;)

Для Вашей таблицы достаточно
Код
=ЕЧИСЛО(ПОИСКПОЗ($V$25;$B$4:$B$7;0))*J28

Вернее, вот так (для I11 и тянете вправо и вниз)
Код
=ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0))*I28

Или сразу
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0));ЕСЛИ(H11="";"";ЕСЛИ($B$2=$V$19;C28;ЕСЛИ($B$2=$V$18;3;"")));"")
К сообщению приложен файл: _55.xlsx(16Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(формула;)

Для Вашей таблицы достаточно
Код
=ЕЧИСЛО(ПОИСКПОЗ($V$25;$B$4:$B$7;0))*J28

Вернее, вот так (для I11 и тянете вправо и вниз)
Код
=ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0))*I28

Или сразу
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0));ЕСЛИ(H11="";"";ЕСЛИ($B$2=$V$19;C28;ЕСЛИ($B$2=$V$18;3;"")));"")

Автор - _Boroda_
Дата добавления - 02.03.2016 в 13:20
lebensvoll Дата: Среда, 02.03.2016, 13:28 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Александр добрый день!
Да я пробовал
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J29)

он мне тогда значение 3 выдает ((( хотя я не выбрал испытание "Ультразвук" (в столбце В4:7) значится в данной ячейке J11 (выделил желтым цветом) должно быть пусто ((((( или может я что то не так все продумал


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеАлександр добрый день!
Да я пробовал
Код
=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J29)

он мне тогда значение 3 выдает ((( хотя я не выбрал испытание "Ультразвук" (в столбце В4:7) значится в данной ячейке J11 (выделил желтым цветом) должно быть пусто ((((( или может я что то не так все продумал

Автор - lebensvoll
Дата добавления - 02.03.2016 в 13:28
_Boroda_ Дата: Среда, 02.03.2016, 13:29 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да я пробовал

=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J29)

Еще раз внимательно перечитайте мой пост. Разве я где-то писал про связку ЕСЛИ-ПОИСКПОЗ?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Да я пробовал

=ЕСЛИ(ПОИСКПОЗ($V$25;$B$4:$B$7;0);J29)

Еще раз внимательно перечитайте мой пост. Разве я где-то писал про связку ЕСЛИ-ПОИСКПОЗ?

Автор - _Boroda_
Дата добавления - 02.03.2016 в 13:29
lebensvoll Дата: Среда, 02.03.2016, 13:31 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0));ЕСЛИ(H11="";"";ЕСЛИ($B$2=$V$19;C28;ЕСЛИ($B$2=$V$18;3;"")));"")

Вот эта формула совсем то что НУЖНО!!!! и избегаем промежуточного итого который я создавал под таблицей. ВЫ ГЕНИЙ!!! hands


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(I$10;$B$4:$B$7;0));ЕСЛИ(H11="";"";ЕСЛИ($B$2=$V$19;C28;ЕСЛИ($B$2=$V$18;3;"")));"")

Вот эта формула совсем то что НУЖНО!!!! и избегаем промежуточного итого который я создавал под таблицей. ВЫ ГЕНИЙ!!! hands

Автор - lebensvoll
Дата добавления - 02.03.2016 в 13:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Избежать #H/Д при расчете через ЕСЛИ и ПОИСКПОЗ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!