Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отчет из базы по участкам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отчет из базы по участкам (Формулы/Formulas)
Отчет из базы по участкам
snejok Дата: Четверг, 03.03.2016, 18:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброе время суток господа, хотел сначала сказать спасибо вашему форуму за помощь, в прошлый раз вы мне очень помогли, Спасибо))
Но снова нужна ваша помощь, все тот же файл)
Страница "Отчет!!!" - Это вид отчета по участкам, как можно сюда собрать информацию об участках?
Доп: в страницу отчет должна подтягиваться информация с первого листа, даже если участок находить "в работе" - то есть когда стоит одна дата, что участок выдали.
Спасибо за помощь, все что нужно отметил желтым цветом...
[moder]Заполните лист отчет вручную, а то не понятно, что туда надо переносить.[/moder]
К сообщению приложен файл: 9706441.xlsx(25Kb)


Сообщение отредактировал Manyasha - Пятница, 04.03.2016, 10:35
 
Ответить
СообщениеДоброе время суток господа, хотел сначала сказать спасибо вашему форуму за помощь, в прошлый раз вы мне очень помогли, Спасибо))
Но снова нужна ваша помощь, все тот же файл)
Страница "Отчет!!!" - Это вид отчета по участкам, как можно сюда собрать информацию об участках?
Доп: в страницу отчет должна подтягиваться информация с первого листа, даже если участок находить "в работе" - то есть когда стоит одна дата, что участок выдали.
Спасибо за помощь, все что нужно отметил желтым цветом...
[moder]Заполните лист отчет вручную, а то не понятно, что туда надо переносить.[/moder]

Автор - snejok
Дата добавления - 03.03.2016 в 18:34
snejok Дата: Пятница, 04.03.2016, 14:29 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
snejok,
Готово... Только главное по возрастанию от наименьшего по дате (по дате "Отдал участок")
К сообщению приложен файл: 9293937.xlsx(25Kb)
 
Ответить
Сообщениеsnejok,
Готово... Только главное по возрастанию от наименьшего по дате (по дате "Отдал участок")

Автор - snejok
Дата добавления - 04.03.2016 в 14:29
snejok Дата: Пятница, 04.03.2016, 15:54 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
snejok, Собрал формулу, но не получается ее запустить, выходит ошибку что нельзя использовать объединенные ячейки
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!B2:B25;НАИМЕНЬШИЙ(ЕСЛИ($B$5='Ведение участков'!A2:A25;СТРОКА('Ведение участков'!B2:B25)-1;"");СТРОКА()-7));"")

может по другому как то можно?
[moder]Оформляйте формулы тегами (кнопка fx).
На первый раз поправила за Вас.[/moder]


Сообщение отредактировал Manyasha - Пятница, 04.03.2016, 16:02
 
Ответить
Сообщениеsnejok, Собрал формулу, но не получается ее запустить, выходит ошибку что нельзя использовать объединенные ячейки
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!B2:B25;НАИМЕНЬШИЙ(ЕСЛИ($B$5='Ведение участков'!A2:A25;СТРОКА('Ведение участков'!B2:B25)-1;"");СТРОКА()-7));"")

может по другому как то можно?
[moder]Оформляйте формулы тегами (кнопка fx).
На первый раз поправила за Вас.[/moder]

Автор - snejok
Дата добавления - 04.03.2016 в 15:54
Udik Дата: Пятница, 04.03.2016, 17:10 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
так вроде
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!$D$2:$E$25;ПОИСКПОЗ(ИНДЕКС($A$5:$P$5;;СТОЛБЕЦ()+1-ЕЧЁТН(СТОЛБЕЦ()))&ИНДЕКС($A7:$P7;;СТОЛБЕЦ()-ЕЧЁТН(СТОЛБЕЦ()));'Ведение участков'!$A$2:$A$25&'Ведение участков'!$B$2:$B$25;0);1+ЕЧЁТН(СТОЛБЕЦ()));"не найдено")

[p.s.] лучше бы ввод имени сделать с проверкой, а то напишут Кирил вместо Кирилл, або ещё учудять всякое B)
К сообщению приложен файл: t2.xlsx(31Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 04.03.2016, 17:14
 
Ответить
Сообщениетак вроде
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!$D$2:$E$25;ПОИСКПОЗ(ИНДЕКС($A$5:$P$5;;СТОЛБЕЦ()+1-ЕЧЁТН(СТОЛБЕЦ()))&ИНДЕКС($A7:$P7;;СТОЛБЕЦ()-ЕЧЁТН(СТОЛБЕЦ()));'Ведение участков'!$A$2:$A$25&'Ведение участков'!$B$2:$B$25;0);1+ЕЧЁТН(СТОЛБЕЦ()));"не найдено")

[p.s.] лучше бы ввод имени сделать с проверкой, а то напишут Кирил вместо Кирилл, або ещё учудять всякое B)

Автор - Udik
Дата добавления - 04.03.2016 в 17:10
snejok Дата: Пятница, 04.03.2016, 19:03 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
угу, крутая формула... все так)) с именами только проблемка) они тоже должны сами подтягиваться в отчет(
 
Ответить
Сообщениеугу, крутая формула... все так)) с именами только проблемка) они тоже должны сами подтягиваться в отчет(

Автор - snejok
Дата добавления - 04.03.2016 в 19:03
Udik Дата: Пятница, 04.03.2016, 22:11 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1202
Репутация: 152 ±
Замечаний: 0% ±

Excel 2013
Тогда ставьте задачу точнее, что должно искаться исходя из заданных параметров. Параметры тоже не забудьте перечислить :) А то как-то непонятно. Например, в листе Отчет на участке 4 нарисован Кирилл. Так мало, что такого имени нет ни на листе Сотрудники, ни на листе Ведение участков , так и Кирил не отметился в управлении данным участком. Вывод: имена вводятся вручную. B) .


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 04.03.2016, 22:12
 
Ответить
СообщениеТогда ставьте задачу точнее, что должно искаться исходя из заданных параметров. Параметры тоже не забудьте перечислить :) А то как-то непонятно. Например, в листе Отчет на участке 4 нарисован Кирилл. Так мало, что такого имени нет ни на листе Сотрудники, ни на листе Ведение участков , так и Кирил не отметился в управлении данным участком. Вывод: имена вводятся вручную. B) .

Автор - Udik
Дата добавления - 04.03.2016 в 22:11
snejok Дата: Суббота, 05.03.2016, 06:40 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Udik, :D :D спасибо за критику, сейчас все опишу)
и так... на первую страницу поступает информация об использовании участков, (просто поступает она не упорядоченно по участкам) - кому выдали, когда и когда он вернул.
на листе с отчетом должен формироваться отчет на основании первого листа, он должен по номеру участка достать информацию: Кому выдавали участок (в порядке последовательности, например участком номер 3 пользовались 4 человека, они все должны быть в отчете (сортировка по дате от наименьшего)) ну и даты когда ему отдали и когда он вернул (пример заполнения на странице отчет в самом верху). я попробовал решить задачу такой формулой:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!B2:B25;НАИМЕНЬШИЙ(ЕСЛИ($B$5='Ведение участков'!A2:A25;СТРОКА('Ведение участков'!B2:B25)-1;"");СТРОКА()-7));"")

но она не совсем удобная потому что у меня почти 400 участков, это 400 граф, + по 20 ячеек, так как ее нужно вписывать в отдельную ячейку, а потом ячейки сливать, времени очень много потребуется(( :( :( :( %) %) %)
Заранее спасибо за помощь yes


Сообщение отредактировал snejok - Суббота, 05.03.2016, 06:40
 
Ответить
СообщениеUdik, :D :D спасибо за критику, сейчас все опишу)
и так... на первую страницу поступает информация об использовании участков, (просто поступает она не упорядоченно по участкам) - кому выдали, когда и когда он вернул.
на листе с отчетом должен формироваться отчет на основании первого листа, он должен по номеру участка достать информацию: Кому выдавали участок (в порядке последовательности, например участком номер 3 пользовались 4 человека, они все должны быть в отчете (сортировка по дате от наименьшего)) ну и даты когда ему отдали и когда он вернул (пример заполнения на странице отчет в самом верху). я попробовал решить задачу такой формулой:
Код
=ЕСЛИОШИБКА(ИНДЕКС('Ведение участков'!B2:B25;НАИМЕНЬШИЙ(ЕСЛИ($B$5='Ведение участков'!A2:A25;СТРОКА('Ведение участков'!B2:B25)-1;"");СТРОКА()-7));"")

но она не совсем удобная потому что у меня почти 400 участков, это 400 граф, + по 20 ячеек, так как ее нужно вписывать в отдельную ячейку, а потом ячейки сливать, времени очень много потребуется(( :( :( :( %) %) %)
Заранее спасибо за помощь yes

Автор - snejok
Дата добавления - 05.03.2016 в 06:40
snejok Дата: Суббота, 05.03.2016, 12:48 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день друзья) Задачу решил почти сам, но остался последний момент, как можно сделать проверку на пустую ячейку кроме слова Если
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1;"");СТРОКА()-4));"")="";"";ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1;"");СТРОКА()-4));""))

формула работает, просто не очень красиво она выглядит, можно ли ее сократить?
 
Ответить
СообщениеДобрый день друзья) Задачу решил почти сам, но остался последний момент, как можно сделать проверку на пустую ячейку кроме слова Если
Код
=ЕСЛИ(ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1;"");СТРОКА()-4));"")="";"";ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1;"");СТРОКА()-4));""))

формула работает, просто не очень красиво она выглядит, можно ли ее сократить?

Автор - snejok
Дата добавления - 05.03.2016 в 12:48
Pelena Дата: Суббота, 05.03.2016, 13:42 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
А зачем тут проверка? Разве так не то же самое?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1);СТРОКА()-4));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА зачем тут проверка? Разве так не то же самое?
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$2:D$17;НАИМЕНЬШИЙ(ЕСЛИ($J$4=A$2:A$17;СТРОКА(B$2:B$17)-1);СТРОКА()-4));"")

Автор - Pelena
Дата добавления - 05.03.2016 в 13:42
snejok Дата: Суббота, 05.03.2016, 13:53 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, да, но почему то возвращается вот такое значение 00.01.00 а хочется что бы она была пустой)
формат ячеек "дата" и той и другой
ячейка на возврат - пустая


Сообщение отредактировал snejok - Суббота, 05.03.2016, 14:05
 
Ответить
СообщениеPelena, да, но почему то возвращается вот такое значение 00.01.00 а хочется что бы она была пустой)
формат ячеек "дата" и той и другой
ячейка на возврат - пустая

Автор - snejok
Дата добавления - 05.03.2016 в 13:53
snejok Дата: Суббота, 05.03.2016, 14:12 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, ВСЕ Нормально)) мне все равно переносить эти формулы в итоге в libreOffice он не возвращает это значение, ячейки пустые))
ВСем спасибо за содействие)
 
Ответить
СообщениеPelena, ВСЕ Нормально)) мне все равно переносить эти формулы в итоге в libreOffice он не возвращает это значение, ячейки пустые))
ВСем спасибо за содействие)

Автор - snejok
Дата добавления - 05.03.2016 в 14:12
Pelena Дата: Суббота, 05.03.2016, 14:16 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9839
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
значение 00.01.00 а хочется что бы она была пустой)

Это ноль в формате даты.
Чтобы нули не отображались, можно поставить формат ДД.ММ.ГГГГ;;


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
значение 00.01.00 а хочется что бы она была пустой)

Это ноль в формате даты.
Чтобы нули не отображались, можно поставить формат ДД.ММ.ГГГГ;;

Автор - Pelena
Дата добавления - 05.03.2016 в 14:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отчет из базы по участкам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!