Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как значение в ячейке #ССЫЛКА! считать "0" - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как значение в ячейке #ССЫЛКА! считать "0" (Формулы/Formulas)
Как значение в ячейке #ССЫЛКА! считать "0"
dan1lov Дата: Четверг, 03.03.2016, 18:56 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер! Подскажите пожалуйста, имею сводную таблицу которая мне кол-во умножает на сумму, так вот, если этой позиции нет, то мне в столбце "сумма" пишет #ССЫЛКА!, что соответственно влияет на итог. Как значение в ячейке #ССЫЛКА! считать "0"?
К сообщению приложен файл: _1-7-1.xlsx(36Kb)


С уважением к Вам, Данилов Сергей.
 
Ответить
СообщениеДобрый вечер! Подскажите пожалуйста, имею сводную таблицу которая мне кол-во умножает на сумму, так вот, если этой позиции нет, то мне в столбце "сумма" пишет #ССЫЛКА!, что соответственно влияет на итог. Как значение в ячейке #ССЫЛКА! считать "0"?

Автор - dan1lov
Дата добавления - 03.03.2016 в 18:56
китин Дата: Четверг, 03.03.2016, 19:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в В15 формула массива
Код
=СУММ(ЕСЛИОШИБКА((D3:D12);0))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениев В15 формула массива
Код
=СУММ(ЕСЛИОШИБКА((D3:D12);0))

Автор - китин
Дата добавления - 03.03.2016 в 19:11
Pelena Дата: Четверг, 03.03.2016, 19:16 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или в D3 формулу
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("Вид упаковки";$F$16;"Вид упаковки";B3)*C3;0)
К сообщению приложен файл: 3756172.xlsx(36Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИли в D3 формулу
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("Вид упаковки";$F$16;"Вид упаковки";B3)*C3;0)

Автор - Pelena
Дата добавления - 03.03.2016 в 19:16
китин Дата: Четверг, 03.03.2016, 19:20 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Лена пытался я так же сделать но почему то у меня во всех ячейках ноль выдает ?????? :'( %)
К сообщению приложен файл: 231.xlsx(36Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 03.03.2016, 19:22
 
Ответить
СообщениеЛена пытался я так же сделать но почему то у меня во всех ячейках ноль выдает ?????? :'( %)

Автор - китин
Дата добавления - 03.03.2016 в 19:20
dan1lov Дата: Четверг, 03.03.2016, 19:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Или в D3 формулу

=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("Вид упаковки";$F$16;"Вид упаковки";B3)*C3;0)


Спасибо, помогло, только я зацепился не за ячейку "В", а к итогам сводной таблице, потому что так будет правильнее. Всем спасибо.


С уважением к Вам, Данилов Сергей.
 
Ответить
Сообщение
Или в D3 формулу

=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ("Вид упаковки";$F$16;"Вид упаковки";B3)*C3;0)


Спасибо, помогло, только я зацепился не за ячейку "В", а к итогам сводной таблице, потому что так будет правильнее. Всем спасибо.

Автор - dan1lov
Дата добавления - 03.03.2016 в 19:52
Pelena Дата: Четверг, 03.03.2016, 19:58 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Игорь, я в качестве критерия для Вида упаковки взяла не константу, а ссылку на ячейку B3. А в твоём случае вообще варианта "КОНВЕРТ" в сводной нет


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИгорь, я в качестве критерия для Вида упаковки взяла не константу, а ссылку на ячейку B3. А в твоём случае вообще варианта "КОНВЕРТ" в сводной нет

Автор - Pelena
Дата добавления - 03.03.2016 в 19:58
китин Дата: Пятница, 04.03.2016, 07:14 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ ни разу не пробовал. Лена спасибо yes


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ ни разу не пробовал. Лена спасибо yes

Автор - китин
Дата добавления - 04.03.2016 в 07:14
_Boroda_ Дата: Пятница, 04.03.2016, 09:32 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
я в качестве критерия для Вида упаковки взяла не константу, а ссылку

Более того, если перевести сводную в классический вид (тогда все поля будут выведены в названиях), то можно вот так написать
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(F$16&"";F$16;G$16;B3)*C3;0)

Кстати, обратите внимание, что прямая ссылка на первое текстовое значение F$16 не работает. Т.е. вот так не прокатит
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(F$16;F$16;G$16;B3)*C3;0)
А вот если к тексту приклеить еще пустое значение, то работает - F$16&""
К сообщению приложен файл: 3756172_2.xlsx(35Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
я в качестве критерия для Вида упаковки взяла не константу, а ссылку

Более того, если перевести сводную в классический вид (тогда все поля будут выведены в названиях), то можно вот так написать
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(F$16&"";F$16;G$16;B3)*C3;0)

Кстати, обратите внимание, что прямая ссылка на первое текстовое значение F$16 не работает. Т.е. вот так не прокатит
Код
=ЕСЛИОШИБКА(ПОЛУЧИТЬ.ДАННЫЕ.СВОДНОЙ.ТАБЛИЦЫ(F$16;F$16;G$16;B3)*C3;0)
А вот если к тексту приклеить еще пустое значение, то работает - F$16&""

Автор - _Boroda_
Дата добавления - 04.03.2016 в 09:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как значение в ячейке #ССЫЛКА! считать "0" (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!