Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Авто заполнение ячеек при делении на выпадающий список - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто заполнение ячеек при делении на выпадающий список (Формулы/Formulas)
Авто заполнение ячеек при делении на выпадающий список
MihanM Дата: Среда, 09.03.2016, 10:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Помогите с формулой в ячейках A3;B3;C3;D3. Нужно А1 разделить на значение в выпадающем списке. Например:
A1 имеет значение 100, если
A1 разделить на 1 то получаем: A3=100; B3=0; C3=0; D3=0
A1 разделить на 2 то получаем: A3=50; B3=50; C3=0; D3=0
A1 разделить на 3 то получаем: A3=33; B3=33; C3=33; D3=0
A1 разделить на 4 то получаем: A3=25; B3=25; C3=25; D3=25
К сообщению приложен файл: _Microsoft_Exce.xls(26Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите с формулой в ячейках A3;B3;C3;D3. Нужно А1 разделить на значение в выпадающем списке. Например:
A1 имеет значение 100, если
A1 разделить на 1 то получаем: A3=100; B3=0; C3=0; D3=0
A1 разделить на 2 то получаем: A3=50; B3=50; C3=0; D3=0
A1 разделить на 3 то получаем: A3=33; B3=33; C3=33; D3=0
A1 разделить на 4 то получаем: A3=25; B3=25; C3=25; D3=25

Автор - MihanM
Дата добавления - 09.03.2016 в 10:51
Manyasha Дата: Среда, 09.03.2016, 10:58 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
MihanM, у Вас же связь с ячейкой G1, так почему бы на нее не разделить?
только я не поняла откуда нули?
UPD
Поняла )
начиная с В3:
Код
=ЕСЛИ(СУММ($A$3:A3)<100;$A$1/$G$1;)

файл перевложила
К сообщению приложен файл: 0000846.xls(26Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Среда, 09.03.2016, 11:03
 
Ответить
СообщениеMihanM, у Вас же связь с ячейкой G1, так почему бы на нее не разделить?
только я не поняла откуда нули?
UPD
Поняла )
начиная с В3:
Код
=ЕСЛИ(СУММ($A$3:A3)<100;$A$1/$G$1;)

файл перевложила

Автор - Manyasha
Дата добавления - 09.03.2016 в 10:58
MihanM Дата: Среда, 09.03.2016, 11:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Большое СПАСИБО!!! hands
 
Ответить
СообщениеБольшое СПАСИБО!!! hands

Автор - MihanM
Дата добавления - 09.03.2016 в 11:59
MihanM Дата: Среда, 09.03.2016, 12:15 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Если значение в ячейке A1 поменять, как сделать, что бы формула работала?
 
Ответить
СообщениеЕсли значение в ячейке A1 поменять, как сделать, что бы формула работала?

Автор - MihanM
Дата добавления - 09.03.2016 в 12:15
MihanM Дата: Среда, 09.03.2016, 12:26 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Разобрался, надо в место <100 указать ячейку A1. :D
 
Ответить
СообщениеРазобрался, надо в место <100 указать ячейку A1. :D

Автор - MihanM
Дата добавления - 09.03.2016 в 12:26
Wasilich Дата: Среда, 09.03.2016, 12:44 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 866
Репутация: 221 ±
Замечаний: 0% ±

2003
И так можно
Код
=ЕСЛИ($G$1>=1;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=2;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=3;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=4;$A$1/$G$1;0)


Сообщение отредактировал Wasilich - Среда, 09.03.2016, 12:47
 
Ответить
СообщениеИ так можно
Код
=ЕСЛИ($G$1>=1;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=2;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=3;$A$1/$G$1;0)
Код
=ЕСЛИ($G$1>=4;$A$1/$G$1;0)

Автор - Wasilich
Дата добавления - 09.03.2016 в 12:44
MihanM Дата: Среда, 09.03.2016, 13:01 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Wasilich, yahoo
 
Ответить
СообщениеWasilich, yahoo

Автор - MihanM
Дата добавления - 09.03.2016 в 13:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Авто заполнение ячеек при делении на выпадающий список (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!