Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать сумму премии с несколькими условиями ЕСЛИ. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму премии с несколькими условиями ЕСЛИ. (Формулы/Formulas)
Посчитать сумму премии с несколькими условиями ЕСЛИ.
Василинка-Малинка Дата: Среда, 09.03.2016, 12:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Нужно посчитать сумму премии с несколькими условиями. Если процент (желтая ячейка) от 90 до 92% от выполненного плана, то премия будет 0,1% от общей суммы (синяя ячейка), если 92% от плана, то 0,2% от общей суммы и т.д. Условия написаны справа.
Можно это все в 1 ячейки написать?
К сообщению приложен файл: 0442644.xlsx(40Kb)
 
Ответить
СообщениеНужно посчитать сумму премии с несколькими условиями. Если процент (желтая ячейка) от 90 до 92% от выполненного плана, то премия будет 0,1% от общей суммы (синяя ячейка), если 92% от плана, то 0,2% от общей суммы и т.д. Условия написаны справа.
Можно это все в 1 ячейки написать?

Автор - Василинка-Малинка
Дата добавления - 09.03.2016 в 12:12
Manyasha Дата: Среда, 09.03.2016, 12:28 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Василинка-Малинка, если сделать отдельную табличку для вычисления премии, то можно ВПРом вытянуть
Код
=ВПР(AI11;$AN$7:$AO$16;2)*AG12
К сообщению приложен файл: 0442644-1.xlsx(41Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеВасилинка-Малинка, если сделать отдельную табличку для вычисления премии, то можно ВПРом вытянуть
Код
=ВПР(AI11;$AN$7:$AO$16;2)*AG12

Автор - Manyasha
Дата добавления - 09.03.2016 в 12:28
Василинка-Малинка Дата: Среда, 09.03.2016, 13:24 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Manyasha, спасибо что откликнулись на просьбу, но в первом случае должна получиться цифра 1420,62рубля, а у вас получилось 284124,12.
 
Ответить
СообщениеManyasha, спасибо что откликнулись на просьбу, но в первом случае должна получиться цифра 1420,62рубля, а у вас получилось 284124,12.

Автор - Василинка-Малинка
Дата добавления - 09.03.2016 в 13:24
Manyasha Дата: Среда, 09.03.2016, 13:38 | Сообщение № 4
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Василинка-Малинка, формат ячеек в таблице поменяла, а знак % в формулу забыла добавить:
*AG12%.
Это по поводу разрядности, а по поводу значения не поняла:
Цитата Василинка-Малинка, 09.03.2016 в 12:12, в сообщении № 1
если 92% от плана, то 0,2%
В файле 92% (92,31%, если точнее) , значит возвращаем AG*0,2%
Или нет?


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеВасилинка-Малинка, формат ячеек в таблице поменяла, а знак % в формулу забыла добавить:
*AG12%.
Это по поводу разрядности, а по поводу значения не поняла:
Цитата Василинка-Малинка, 09.03.2016 в 12:12, в сообщении № 1
если 92% от плана, то 0,2%
В файле 92% (92,31%, если точнее) , значит возвращаем AG*0,2%
Или нет?

Автор - Manyasha
Дата добавления - 09.03.2016 в 13:38
Василинка-Малинка Дата: Среда, 09.03.2016, 13:44 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Manyasha,
Там стоит округление и я тоже у начальника спросила как к этому относиться? он мне сказал, что если даже 91,56% а в округлении 92%, то уже считаем как 92%.
Мне не понятно, почему так, но уточнять не стала. Он начальник ему видней. Хотя я бы поставила до 91,99 - 91%, а 92,00-92,99 уже 92%. Но это уже мое мнение и с ним ни кто не считается.
 
Ответить
СообщениеManyasha,
Там стоит округление и я тоже у начальника спросила как к этому относиться? он мне сказал, что если даже 91,56% а в округлении 92%, то уже считаем как 92%.
Мне не понятно, почему так, но уточнять не стала. Он начальник ему видней. Хотя я бы поставила до 91,99 - 91%, а 92,00-92,99 уже 92%. Но это уже мое мнение и с ним ни кто не считается.

Автор - Василинка-Малинка
Дата добавления - 09.03.2016 в 13:44
Manyasha Дата: Среда, 09.03.2016, 14:15 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1721
Репутация: 722 ±
Замечаний: 0% ±

Excel 2007, 2010
Василинка-Малинка, а так?
Код
=ВПР(ОКРУГЛВНИЗ(AI11;2);$AN$7:$AO$16;2)%*AG12

Обратите внимание на таблицу $AN$7:$AO$16 - увеличила значения в 1-м столбце на 0,001
К сообщению приложен файл: 0442644-2.xlsx(41Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеВасилинка-Малинка, а так?
Код
=ВПР(ОКРУГЛВНИЗ(AI11;2);$AN$7:$AO$16;2)%*AG12

Обратите внимание на таблицу $AN$7:$AO$16 - увеличила значения в 1-м столбце на 0,001

Автор - Manyasha
Дата добавления - 09.03.2016 в 14:15
Che79 Дата: Среда, 09.03.2016, 15:00 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 215
Репутация: 28 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
Василинка-Малинка, добрый день.
На основе первоначального файла от Марины и Ваших комментариев выше, предлагаю такой вариант. См. столбец AJ.
Формулу в AJ5 и протянуть вниз
Код
=ЕСЛИ(B5<>$B$11;"";ПРОСМОТР(AI5;$AM$7:$AM$16;$AO$7:$AO$16)*AG6%*(B6="ОБЩ. РУБ."))
К сообщению приложен файл: 09032015.xlsx(42Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеВасилинка-Малинка, добрый день.
На основе первоначального файла от Марины и Ваших комментариев выше, предлагаю такой вариант. См. столбец AJ.
Формулу в AJ5 и протянуть вниз
Код
=ЕСЛИ(B5<>$B$11;"";ПРОСМОТР(AI5;$AM$7:$AM$16;$AO$7:$AO$16)*AG6%*(B6="ОБЩ. РУБ."))

Автор - Che79
Дата добавления - 09.03.2016 в 15:00
Василинка-Малинка Дата: Среда, 09.03.2016, 18:35 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Manyasha, Che79,
спасибо большое, просмотрю все варианты, задам начальнику наводящие вопросы, в зависимости от ответов выберу наилучший.
Спасибо, что не прошли мимо.
 
Ответить
СообщениеManyasha, Che79,
спасибо большое, просмотрю все варианты, задам начальнику наводящие вопросы, в зависимости от ответов выберу наилучший.
Спасибо, что не прошли мимо.

Автор - Василинка-Малинка
Дата добавления - 09.03.2016 в 18:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать сумму премии с несколькими условиями ЕСЛИ. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!