Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Возврат значения при разрозненном диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значения при разрозненном диапазоне (Формулы/Formulas)
Возврат значения при разрозненном диапазоне
ONeeX Дата: Четверг, 10.03.2016, 11:00 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день,

Помогите, пожалуйста:
1)В красной ячейке (в приложенном файле) ищется минимальная цена в разрозненном диапазоне ячеек.
2) Необходимо чтобы в желтой ячейке возвращалось название поставщика (из шапки), где удалось найти минимальную цену.

Заранее спасибо

П.С. В дальнейшем тут будет не 3 поставщика, а штук 7-10. Поэтому через ЕСЛИ не подходит.
К сообщению приложен файл: 7642360.xlsx(18Kb)


Сообщение отредактировал ONeeX - Четверг, 10.03.2016, 11:01
 
Ответить
СообщениеДобрый день,

Помогите, пожалуйста:
1)В красной ячейке (в приложенном файле) ищется минимальная цена в разрозненном диапазоне ячеек.
2) Необходимо чтобы в желтой ячейке возвращалось название поставщика (из шапки), где удалось найти минимальную цену.

Заранее спасибо

П.С. В дальнейшем тут будет не 3 поставщика, а штук 7-10. Поэтому через ЕСЛИ не подходит.

Автор - ONeeX
Дата добавления - 10.03.2016 в 11:00
Manyasha Дата: Четверг, 10.03.2016, 11:38 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1832
Репутация: 766 ±
Замечаний: 0% ±

Excel 2007, 2010
ONeeX, так?
для красной ячейки:
Код
=МИН(ЕСЛИ(($F$5:$AI$5 = "цена в р")*($H$5:$AK$5= "цена за д");G6:AJ6;9^9))

для желтой:
Код
=ИНДЕКС($G$4:$AJ$4;МИН(ЕСЛИ(($F$5:$AI$5 = "цена в р")*($H$5:$AK$5= "цена за д")*(G6:AJ6=AP6);СТОЛБЕЦ(G6:AJ6)-6;9^9)))

обе формулы массивные, вводятся через ctrl+shift+enter
К сообщению приложен файл: 7642360-1.xlsx(18Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеONeeX, так?
для красной ячейки:
Код
=МИН(ЕСЛИ(($F$5:$AI$5 = "цена в р")*($H$5:$AK$5= "цена за д");G6:AJ6;9^9))

для желтой:
Код
=ИНДЕКС($G$4:$AJ$4;МИН(ЕСЛИ(($F$5:$AI$5 = "цена в р")*($H$5:$AK$5= "цена за д")*(G6:AJ6=AP6);СТОЛБЕЦ(G6:AJ6)-6;9^9)))

обе формулы массивные, вводятся через ctrl+shift+enter

Автор - Manyasha
Дата добавления - 10.03.2016 в 11:38
Karataev Дата: Четверг, 10.03.2016, 12:02 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 837
Репутация: 312 ±
Замечаний: 0% ±

Excel
для красной
Код
=МИН(G:G;Q:Q;AA:AA)

для желтой
Код
=ИНДЕКС($4:$4;1;МАКС((МИН(G:G)=AP6)*7;(МИН(Q:Q)=AP6)*17;(МИН(AA:AA)=AP6)*27))
К сообщению приложен файл: file.xlsx(17Kb)


 
Ответить
Сообщениедля красной
Код
=МИН(G:G;Q:Q;AA:AA)

для желтой
Код
=ИНДЕКС($4:$4;1;МАКС((МИН(G:G)=AP6)*7;(МИН(Q:Q)=AP6)*17;(МИН(AA:AA)=AP6)*27))

Автор - Karataev
Дата добавления - 10.03.2016 в 12:02
ONeeX Дата: Четверг, 10.03.2016, 14:24 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Спасибо друзья, то что нужно
 
Ответить
СообщениеСпасибо друзья, то что нужно

Автор - ONeeX
Дата добавления - 10.03.2016 в 14:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Возврат значения при разрозненном диапазоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!