Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Синхронизация данных исходника и результата - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация данных исходника и результата (Формулы/Formulas)
Синхронизация данных исходника и результата
NNK1 Дата: Четверг, 10.03.2016, 14:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Есть проблема - большой массив информации для обработки В 2014 и 2015 многие предприятия сменили форму собственности, теперь нужно формулой объединить данные и получить "результат" (объединив предприятия изменившие форму собственности).
Есть код предприятия и необходимо к нему подвязать данные (объединяя предприятия по кодам)

Пример во вложении

Заранее спасибо
К сообщению приложен файл: 8223444.xls(28Kb)
 
Ответить
СообщениеДобрый день!
Есть проблема - большой массив информации для обработки В 2014 и 2015 многие предприятия сменили форму собственности, теперь нужно формулой объединить данные и получить "результат" (объединив предприятия изменившие форму собственности).
Есть код предприятия и необходимо к нему подвязать данные (объединяя предприятия по кодам)

Пример во вложении

Заранее спасибо

Автор - NNK1
Дата добавления - 10.03.2016 в 14:16
Che79 Дата: Четверг, 10.03.2016, 14:18 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 359
Репутация: 52 ±
Замечаний: 0% ±

Excel 2007, 2010, 2016 RUS
NNK1, так нужно?
Код
=СУММПРОИЗВ(D$3:D$8*(ПРАВБ($C$3:$C$8;2)=ПРАВБ($I3;2))*($B$3:$B$8=$H3)*($A$3:$A$8=$G3))

Формулы в желтых ячейках в файле
К сообщению приложен файл: 10032016.xls(37Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеNNK1, так нужно?
Код
=СУММПРОИЗВ(D$3:D$8*(ПРАВБ($C$3:$C$8;2)=ПРАВБ($I3;2))*($B$3:$B$8=$H3)*($A$3:$A$8=$G3))

Формулы в желтых ячейках в файле

Автор - Che79
Дата добавления - 10.03.2016 в 14:18
NNK1 Дата: Четверг, 10.03.2016, 15:23 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Немного не так есть исходник есть коды магазинов к ним нужно подтянуть и текст и цифры
Новое приложение
К сообщению приложен файл: 0034388.xls(28Kb)
 
Ответить
СообщениеНемного не так есть исходник есть коды магазинов к ним нужно подтянуть и текст и цифры
Новое приложение

Автор - NNK1
Дата добавления - 10.03.2016 в 15:23
китин Дата: Четверг, 10.03.2016, 15:36 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4110
Репутация: 635 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Немного не так
может так? без промежуточного вида.сама формирует список уникальных кодов
К сообщению приложен файл: NNK1.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Немного не так
может так? без промежуточного вида.сама формирует список уникальных кодов

Автор - китин
Дата добавления - 10.03.2016 в 15:36
Wasilich Дата: Четверг, 10.03.2016, 15:41 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1195
Репутация: 316 ±
Замечаний: 0% ±

2003
А так разве не катит?
Код
=СУММЕСЛИ($A$3:$A$8;$G3;D$3:D$8)

ЗЫ
нужно подтянуть и текст и цифры
Задача меняется на лету!


Сообщение отредактировал Wasilich - Четверг, 10.03.2016, 15:47
 
Ответить
СообщениеА так разве не катит?
Код
=СУММЕСЛИ($A$3:$A$8;$G3;D$3:D$8)

ЗЫ
нужно подтянуть и текст и цифры
Задача меняется на лету!

Автор - Wasilich
Дата добавления - 10.03.2016 в 15:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Синхронизация данных исходника и результата (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!