Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое проставление порядковых номеров - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое проставление порядковых номеров (Формулы/Formulas)
Автоматическое проставление порядковых номеров
ASM_0408 Дата: Пятница, 11.03.2016, 08:39 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 135
Репутация: 0 ±
Замечаний: 20% ±

2016
Доброе утро! Подскажите пожалуйста как можно сделать формулу автоматического проставления порядкового номера записи при условии наличия записи в соседней ячейке. Если рассматривать пример то в ячейке A10 должно проставляться 1 если в В10 имеется запись, в А11 должно проставляться 2 если в В11 имеется запись и т.д. Пользовался поиском нужного решения не нашел. Спасибо!
К сообщению приложен файл: 2465568.xlsx(60Kb)
 
Ответить
СообщениеДоброе утро! Подскажите пожалуйста как можно сделать формулу автоматического проставления порядкового номера записи при условии наличия записи в соседней ячейке. Если рассматривать пример то в ячейке A10 должно проставляться 1 если в В10 имеется запись, в А11 должно проставляться 2 если в В11 имеется запись и т.д. Пользовался поиском нужного решения не нашел. Спасибо!

Автор - ASM_0408
Дата добавления - 11.03.2016 в 08:39
Nic70y Дата: Пятница, 11.03.2016, 08:43 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3475
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(B10<>"";СЧЁТЕСЛИ(B$10:B10;"*");"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(B10<>"";СЧЁТЕСЛИ(B$10:B10;"*");"")

Автор - Nic70y
Дата добавления - 11.03.2016 в 08:43
buchlotnik Дата: Пятница, 11.03.2016, 09:01 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
или так
Код
=ЕСЛИ(ЕПУСТО(B10);"";СЧЁТЗ($B$10:B10))
К сообщению приложен файл: 2465568-1-.xlsx(59Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеили так
Код
=ЕСЛИ(ЕПУСТО(B10);"";СЧЁТЗ($B$10:B10))

Автор - buchlotnik
Дата добавления - 11.03.2016 в 09:01
Wasilich Дата: Пятница, 11.03.2016, 09:02 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 858
Репутация: 220 ±
Замечаний: 0% ±

2003
Еще 2 варианта. С условием, что записи в каждой строке.
Код
=ЕСЛИ(B10<>"";СТРОКА()-9;"")

В 10 строке ставите 1-цу в остальных
Код
=ЕСЛИ(B11<>"";A10+1;"")


Сообщение отредактировал Wasilich - Пятница, 11.03.2016, 09:06
 
Ответить
СообщениеЕще 2 варианта. С условием, что записи в каждой строке.
Код
=ЕСЛИ(B10<>"";СТРОКА()-9;"")

В 10 строке ставите 1-цу в остальных
Код
=ЕСЛИ(B11<>"";A10+1;"")

Автор - Wasilich
Дата добавления - 11.03.2016 в 09:02
китин Дата: Пятница, 11.03.2016, 15:05 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и еще вариант без учета
что записи в каждой строке

Код
=ЕСЛИ(B10="";"";СЧЁТЗ($B$10:B10))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи еще вариант без учета
что записи в каждой строке

Код
=ЕСЛИ(B10="";"";СЧЁТЗ($B$10:B10))

Автор - китин
Дата добавления - 11.03.2016 в 15:05
DrMini Дата: Пятница, 11.03.2016, 15:14 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
Ещё вариант:
Код
=ЕСЛИ(ЕПУСТО(B10);"";СЧЁТЗ($B$10:B10))

[moder]На первый раз поправила за Вас формулу[/moder]
К сообщению приложен файл: 160311.xlsx(59Kb)


Сообщение отредактировал Manyasha - Пятница, 11.03.2016, 16:00
 
Ответить
СообщениеЕщё вариант:
Код
=ЕСЛИ(ЕПУСТО(B10);"";СЧЁТЗ($B$10:B10))

[moder]На первый раз поправила за Вас формулу[/moder]

Автор - DrMini
Дата добавления - 11.03.2016 в 15:14
китин Дата: Пятница, 11.03.2016, 15:20 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
DrMini, для оформления формул существуют тэги

выделяете формулу и нажимаете кнопочку.реально неудобно читать формулу без тэга
К сообщению приложен файл: 6472881.gif(21Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеDrMini, для оформления формул существуют тэги

выделяете формулу и нажимаете кнопочку.реально неудобно читать формулу без тэга

Автор - китин
Дата добавления - 11.03.2016 в 15:20
DrMini Дата: Пятница, 11.03.2016, 16:19 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 151
Репутация: 1 ±
Замечаний: 20% ±

Excel 2010, 2013
китин, Спасибо за подсказку. Я первый раз. Не знал, как это делается.
Код
=ПРОВЕРКА

[moder]Всё это и многое другое есть в Правилах форума[/moder]


Сообщение отредактировал Pelena - Пятница, 11.03.2016, 16:39
 
Ответить
Сообщениекитин, Спасибо за подсказку. Я первый раз. Не знал, как это делается.
Код
=ПРОВЕРКА

[moder]Всё это и многое другое есть в Правилах форума[/moder]

Автор - DrMini
Дата добавления - 11.03.2016 в 16:19
Che79 Дата: Пятница, 11.03.2016, 16:50 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
всех приветствую!
вдогонку, вот еще, вроде такого варианта не было
Код
=СЧЁТЕСЛИ(B$10:B10;"*")*(B10<>"")

и формат ячеек ###0;###0;* ??;-@-
К сообщению приложен файл: 2465568_2.xlsx(59Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщениевсех приветствую!
вдогонку, вот еще, вроде такого варианта не было
Код
=СЧЁТЕСЛИ(B$10:B10;"*")*(B10<>"")

и формат ячеек ###0;###0;* ??;-@-

Автор - Che79
Дата добавления - 11.03.2016 в 16:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое проставление порядковых номеров (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!