Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование суммы по столбцам с наступлением нового мясяца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование суммы по столбцам с наступлением нового мясяца (Формулы/Formulas)
Суммирование суммы по столбцам с наступлением нового мясяца
vorona Дата: Понедельник, 14.03.2016, 09:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Помогите пожалуйста с моей проблемой, которую описал в файле в ячейке J3
[moder]Дайте теме более конкретное название в соответствии с Правилами форума. До исправления все ответы будут удаляться[/moder]


Сообщение отредактировал vorona - Понедельник, 14.03.2016, 10:03
 
Ответить
СообщениеПомогите пожалуйста с моей проблемой, которую описал в файле в ячейке J3
[moder]Дайте теме более конкретное название в соответствии с Правилами форума. До исправления все ответы будут удаляться[/moder]

Автор - vorona
Дата добавления - 14.03.2016 в 09:11
vorona Дата: Понедельник, 14.03.2016, 09:12 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Файл
К сообщению приложен файл: _2016.xlsx(18Kb)
 
Ответить
СообщениеФайл

Автор - vorona
Дата добавления - 14.03.2016 в 09:12
mathiax90 Дата: Понедельник, 14.03.2016, 09:18 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 155
Репутация: 20 ±
Замечаний: 60% ±

Excel 2007
А как рассчитывается эта сумма?
[moder]Пока автор не изменит название темы согласно п.2 Правил форума - ответы будут удаляться.[/moder]
[moder]Замечание исправлено[/moder]


webmoney: R242692021885
ЯД:410013877261817


Сообщение отредактировал Pelena - Понедельник, 14.03.2016, 10:05
 
Ответить
СообщениеА как рассчитывается эта сумма?
[moder]Пока автор не изменит название темы согласно п.2 Правил форума - ответы будут удаляться.[/moder]
[moder]Замечание исправлено[/moder]

Автор - mathiax90
Дата добавления - 14.03.2016 в 09:18
vorona Дата: Понедельник, 14.03.2016, 10:04 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Суммы выделенные синим проставляю я сам на каждый квартал.
 
Ответить
СообщениеСуммы выделенные синим проставляю я сам на каждый квартал.

Автор - vorona
Дата добавления - 14.03.2016 в 10:04
_Boroda_ Дата: Понедельник, 14.03.2016, 10:10 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(ИНДЕКС(5:5;МЕСЯЦ(СЕГОДНЯ())+4):ИНДЕКС(38:38;МЕСЯЦ(СЕГОДНЯ())+4))

Вернее, не 38, а 27
Код
=СУММ(ИНДЕКС(5:5;МЕСЯЦ(СЕГОДНЯ())+4):ИНДЕКС(27:27;МЕСЯЦ(СЕГОДНЯ())+4))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММ(ИНДЕКС(5:5;МЕСЯЦ(СЕГОДНЯ())+4):ИНДЕКС(38:38;МЕСЯЦ(СЕГОДНЯ())+4))

Вернее, не 38, а 27
Код
=СУММ(ИНДЕКС(5:5;МЕСЯЦ(СЕГОДНЯ())+4):ИНДЕКС(27:27;МЕСЯЦ(СЕГОДНЯ())+4))

Автор - _Boroda_
Дата добавления - 14.03.2016 в 10:10
vorona Дата: Понедельник, 14.03.2016, 10:22 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А при наступлении апреля в ячейки будет суммы апреля?
И еще у меня с 28 строки другой объект его нужно тоже в эту ячейку.
 
Ответить
СообщениеА при наступлении апреля в ячейки будет суммы апреля?
И еще у меня с 28 строки другой объект его нужно тоже в эту ячейку.

Автор - vorona
Дата добавления - 14.03.2016 в 10:22
_Boroda_ Дата: Понедельник, 14.03.2016, 10:24 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, будет
Не заметил.
Тогда общая формула
Код
=СУММ(ЕСЛИОШИБКА(--E4:P$99;)*(ЛЕВБ(A4:A$99;ДЛСТР(A3) )=A3&"")*(E4:P4=ТЕКСТ(СЕГОДНЯ();"ММММ")))

Это формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
или
Код
=СУММ(ЕСЛИОШИБКА(E4:P$99*(ЛЕВБ(A4:A$99;ДЛСТР(A3))-A3=0)*(E4:P4=ТЕКСТ(СЕГОДНЯ();"ММММ"));))

Код
=СУММ(ЕСЛИОШИБКА(E4:P$99*(ЛЕВБ(A4:A$99;ДЛСТР(A2)+1)=A2&".")*(E3:P3=ТЕКСТ(СЕГОДНЯ();"ММММ"));))
К сообщению приложен файл: _2016_12.xlsx(18Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, будет
Не заметил.
Тогда общая формула
Код
=СУММ(ЕСЛИОШИБКА(--E4:P$99;)*(ЛЕВБ(A4:A$99;ДЛСТР(A3) )=A3&"")*(E4:P4=ТЕКСТ(СЕГОДНЯ();"ММММ")))

Это формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
или
Код
=СУММ(ЕСЛИОШИБКА(E4:P$99*(ЛЕВБ(A4:A$99;ДЛСТР(A3))-A3=0)*(E4:P4=ТЕКСТ(СЕГОДНЯ();"ММММ"));))

Код
=СУММ(ЕСЛИОШИБКА(E4:P$99*(ЛЕВБ(A4:A$99;ДЛСТР(A2)+1)=A2&".")*(E3:P3=ТЕКСТ(СЕГОДНЯ();"ММММ"));))

Автор - _Boroda_
Дата добавления - 14.03.2016 в 10:24
vorona Дата: Понедельник, 14.03.2016, 10:44 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
А лучше использовать общую формулу или как вы предлагаете формулу массива?
 
Ответить
СообщениеА лучше использовать общую формулу или как вы предлагаете формулу массива?

Автор - vorona
Дата добавления - 14.03.2016 в 10:44
vorona Дата: Понедельник, 14.03.2016, 10:49 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
И еще, если у нас поменяется план работ и мне нужно добавить в строки с 10 по 20 на март выполнения считать не будет?
 
Ответить
СообщениеИ еще, если у нас поменяется план работ и мне нужно добавить в строки с 10 по 20 на март выполнения считать не будет?

Автор - vorona
Дата добавления - 14.03.2016 в 10:49
vorona Дата: Понедельник, 14.03.2016, 10:52 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
и строки с 30 по 38 не попадают в сумму в вашем файле который вы прислали
 
Ответить
Сообщениеи строки с 30 по 38 не попадают в сумму в вашем файле который вы прислали

Автор - vorona
Дата добавления - 14.03.2016 в 10:52
_Boroda_ Дата: Понедельник, 14.03.2016, 11:10 | Сообщение № 11
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
строки с 30 по 38 не попадают в сумму

Конечно. Они считаются в строке 28
лучше использовать общую формулу или как вы предлагаете формулу массива?

Это обе формулы массива. Просто немного по-разному написаны. Используйте ту, которая больше нравится.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
строки с 30 по 38 не попадают в сумму

Конечно. Они считаются в строке 28
лучше использовать общую формулу или как вы предлагаете формулу массива?

Это обе формулы массива. Просто немного по-разному написаны. Используйте ту, которая больше нравится.

Автор - _Boroda_
Дата добавления - 14.03.2016 в 11:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование суммы по столбцам с наступлением нового мясяца (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!