Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать столбец в массиве по двум условиям. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать столбец в массиве по двум условиям. (Формулы/Formulas)
Выбрать столбец в массиве по двум условиям.
Leksa Дата: Вторник, 15.03.2016, 12:59 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Задача такова: на листе БП есть исходные данные нужно их подтянуть на лист БДР.
понимаю, что скорее всего функция индекс(), н е знаю как номер столбца по двум условиям отобрать.
К сообщению приложен файл: 3983826.xlsx(10Kb)


Сообщение отредактировал Leksa - Вторник, 15.03.2016, 13:06
 
Ответить
СообщениеДобрый день. Задача такова: на листе БП есть исходные данные нужно их подтянуть на лист БДР.
понимаю, что скорее всего функция индекс(), н е знаю как номер столбца по двум условиям отобрать.

Автор - Leksa
Дата добавления - 15.03.2016 в 12:59
lebensvoll Дата: Вторник, 15.03.2016, 13:01 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Leksa, Так вам ни кто не поможет (((( вы бы хоть пример приложили для понимания вашей задачи


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеLeksa, Так вам ни кто не поможет (((( вы бы хоть пример приложили для понимания вашей задачи

Автор - lebensvoll
Дата добавления - 15.03.2016 в 13:01
Leksa Дата: Вторник, 15.03.2016, 13:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
lebensvoll, так это понятно - пример пытаюсь приложить - оказалось, что весит более 100 - не могу понять почему - в файле 6 строк на одном листе и на втором не больше.
 
Ответить
Сообщениеlebensvoll, так это понятно - пример пытаюсь приложить - оказалось, что весит более 100 - не могу понять почему - в файле 6 строк на одном листе и на втором не больше.

Автор - Leksa
Дата добавления - 15.03.2016 в 13:04
Leksa Дата: Вторник, 15.03.2016, 13:07 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
lebensvoll, вот пример
[moder]Что нужно получить и почему? Заполните итоговую таблицу вручную
У Вас две разных аренды и две статьи 2 - как их различать?
К сообщению приложен файл: 5472565.xlsx(10Kb)


Сообщение отредактировал _Boroda_ - Вторник, 15.03.2016, 13:37
 
Ответить
Сообщениеlebensvoll, вот пример
[moder]Что нужно получить и почему? Заполните итоговую таблицу вручную
У Вас две разных аренды и две статьи 2 - как их различать?

Автор - Leksa
Дата добавления - 15.03.2016 в 13:07
abtextime Дата: Вторник, 15.03.2016, 13:19 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Есть для этого специальная функция в Excel
Код
=ПодтянутьИсходныеДанныесЛистаБПнаЛистБДР()

:)
 
Ответить
СообщениеЕсть для этого специальная функция в Excel
Код
=ПодтянутьИсходныеДанныесЛистаБПнаЛистБДР()

:)

Автор - abtextime
Дата добавления - 15.03.2016 в 13:19
китин Дата: Вторник, 15.03.2016, 13:20 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а я вот так понял
Код
=СУММПРОИЗВ(БП!$B$3:$M$6*(БП!$B$1:$M$1=БДР!$B2)*(БДР!C$1=БП!$B$2:$M$2)*($A2=БП!$A$3:$A$6))
К сообщению приложен файл: Leksa.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа я вот так понял
Код
=СУММПРОИЗВ(БП!$B$3:$M$6*(БП!$B$1:$M$1=БДР!$B2)*(БДР!C$1=БП!$B$2:$M$2)*($A2=БП!$A$3:$A$6))

Автор - китин
Дата добавления - 15.03.2016 в 13:20
Leksa Дата: Вторник, 15.03.2016, 14:27 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 28
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, спасибо это то что нужно!
 
Ответить
Сообщениекитин, спасибо это то что нужно!

Автор - Leksa
Дата добавления - 15.03.2016 в 14:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать столбец в массиве по двум условиям. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!