Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Особенности работы оператора ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Особенности работы оператора ЕСЛИ (Формулы/Formulas)
Особенности работы оператора ЕСЛИ
dkonst Дата: Среда, 16.03.2016, 09:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Тема не нова, но вопрос остался
В прикрепленном файле ( Лист 2)
В ячейках Е1 и Е2 соответвенно практически две одинаковые формулы, но в Е1 - работает исчитает а вторая выдаёт ЛОЖЬ
Е1
Код
=ЕСЛИ(C1=MC!A$6;ЕСЛИ(D1=MC!B$6;MC!D$6);ЕСЛИ(C1=MC!A$7;ЕСЛИ(D1=MC!B$7;MC!D$7);ЕСЛИ(C1=MC!A$8;ЕСЛИ(D1=MC!B$8;MC!D$8);ЕСЛИ(C1=MC!A$9;ЕСЛИ(D1=MC!B$9;MC!D$9);ЕСЛИ(C1=MC!A$10;ЕСЛИ(D1=MC!B$10;MC!D$10);ЕСЛИ(C1=MC!A$11;ЕСЛИ(D1=MC!B$11;MC!D$11)))))))

Е2
Код
=ЕСЛИ(C2=MC!A$6;ЕСЛИ(D2=MC!B$6;MC!D$6);ЕСЛИ(C2=MC!A$7;ЕСЛИ(D2=MC!B$7;MC!D$7);ЕСЛИ(C2=MC!A$8;ЕСЛИ(D2=MC!B$8;MC!D$8);ЕСЛИ(C2=MC!A$9;ЕСЛИ(D2=MC!B$9;MC!D$9);ЕСЛИ(C2=MC!A$10;ЕСЛИ(D2=MC!B$10;MC!D$10);ЕСЛИ(C2=MC!A$11;ЕСЛИ(D2=MC!B$11;MC!D$11);ЕСЛИ(C2=MC!A$12;ЕСЛИ(D2=MC!B$12;MC!D$12))))))))

Не могу понять в чем дело. Точнее в чем тонкость работы оператора. В ячейке D2 если ="8 " заменить на ="6 " то все работает как и должно.
Может кто сталкивался с такми или есть мымли почему формула с числом 6 все считает а если в окно данных вводить число 8 то ничего не считается
К сообщению приложен файл: 3483957.xlsx(72Kb)
 
Ответить
СообщениеТема не нова, но вопрос остался
В прикрепленном файле ( Лист 2)
В ячейках Е1 и Е2 соответвенно практически две одинаковые формулы, но в Е1 - работает исчитает а вторая выдаёт ЛОЖЬ
Е1
Код
=ЕСЛИ(C1=MC!A$6;ЕСЛИ(D1=MC!B$6;MC!D$6);ЕСЛИ(C1=MC!A$7;ЕСЛИ(D1=MC!B$7;MC!D$7);ЕСЛИ(C1=MC!A$8;ЕСЛИ(D1=MC!B$8;MC!D$8);ЕСЛИ(C1=MC!A$9;ЕСЛИ(D1=MC!B$9;MC!D$9);ЕСЛИ(C1=MC!A$10;ЕСЛИ(D1=MC!B$10;MC!D$10);ЕСЛИ(C1=MC!A$11;ЕСЛИ(D1=MC!B$11;MC!D$11)))))))

Е2
Код
=ЕСЛИ(C2=MC!A$6;ЕСЛИ(D2=MC!B$6;MC!D$6);ЕСЛИ(C2=MC!A$7;ЕСЛИ(D2=MC!B$7;MC!D$7);ЕСЛИ(C2=MC!A$8;ЕСЛИ(D2=MC!B$8;MC!D$8);ЕСЛИ(C2=MC!A$9;ЕСЛИ(D2=MC!B$9;MC!D$9);ЕСЛИ(C2=MC!A$10;ЕСЛИ(D2=MC!B$10;MC!D$10);ЕСЛИ(C2=MC!A$11;ЕСЛИ(D2=MC!B$11;MC!D$11);ЕСЛИ(C2=MC!A$12;ЕСЛИ(D2=MC!B$12;MC!D$12))))))))

Не могу понять в чем дело. Точнее в чем тонкость работы оператора. В ячейке D2 если ="8 " заменить на ="6 " то все работает как и должно.
Может кто сталкивался с такми или есть мымли почему формула с числом 6 все считает а если в окно данных вводить число 8 то ничего не считается

Автор - dkonst
Дата добавления - 16.03.2016 в 09:39
_Boroda_ Дата: Среда, 16.03.2016, 10:37 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тонкость в том, что у Вас в ячейке не одно число, а два
Вот так попробуйте
Код
=ПРОСМОТР(;-1/(MC!A$7:A$99=C1)/ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(" "&D1&" ");" "&MC!B$7:B$99&" "))/(D1<>"");MC!D$7:D$99)

или убрать ошибки
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(MC!A$7:A$99=C1)/ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(" "&D1&" ");" "&MC!B$7:B$99&" "))/(D1<>"");MC!D$7:D$99);"")
К сообщению приложен файл: 3483957_1.xlsx(55Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТонкость в том, что у Вас в ячейке не одно число, а два
Вот так попробуйте
Код
=ПРОСМОТР(;-1/(MC!A$7:A$99=C1)/ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(" "&D1&" ");" "&MC!B$7:B$99&" "))/(D1<>"");MC!D$7:D$99)

или убрать ошибки
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(MC!A$7:A$99=C1)/ЕЧИСЛО(ПОИСК(СЖПРОБЕЛЫ(" "&D1&" ");" "&MC!B$7:B$99&" "))/(D1<>"");MC!D$7:D$99);"")

Автор - _Boroda_
Дата добавления - 16.03.2016 в 10:37
dkonst Дата: Среда, 16.03.2016, 11:10 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
МОлодой человек. я безгранично вам благодарен за мастеркласс по работе функции "ПРОСМОТР"
 
Ответить
СообщениеМОлодой человек. я безгранично вам благодарен за мастеркласс по работе функции "ПРОСМОТР"

Автор - dkonst
Дата добавления - 16.03.2016 в 11:10
dkonst Дата: Среда, 16.03.2016, 11:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
_Boroda_,
мне для осознания всего счета не хватает ума
может еще подскажите как если воспользоваться вашей формулой в ячейках E1 и Е2 сделать что б бралось занчение из ячеек D11 и D12
в том виде как есть оно почему то берется из ячейки D15 (где есть значнеия 16 и 18, хотя ищятся значения 6 и 8
К сообщению приложен файл: 6138354.xlsx(61Kb)
 
Ответить
Сообщение_Boroda_,
мне для осознания всего счета не хватает ума
может еще подскажите как если воспользоваться вашей формулой в ячейках E1 и Е2 сделать что б бралось занчение из ячеек D11 и D12
в том виде как есть оно почему то берется из ячейки D15 (где есть значнеия 16 и 18, хотя ищятся значения 6 и 8

Автор - dkonst
Дата добавления - 16.03.2016 в 11:41
_Boroda_ Дата: Среда, 16.03.2016, 13:30 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11545
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Действительно.
Тогда так
Код
=ПРОСМОТР(;-1/(MC!A$7:A$52=C1)/ЕЧИСЛО(ПОИСК(" "&D1&" ";" "&ПОДСТАВИТЬ(MC!B$7:B$52;";";" ")&" "))/(D1<>"");MC!D$7:D$52)

А вот эти
кл А3 А400;500 22
кл А3 А400;500 25
засовывайте в одну ячейку в листе МС

Или используйте вот такую формулу
Код
=ПРОСМОТР(;-1/(ПРОСМОТР(СТРОКА(MC!A$7:A$52);СТРОКА(MC!A$7:A$52)/(MC!A$7:A$52<>"");MC!A$7:A$52)=C1)/ЕЧИСЛО(ПОИСК(" "&D1&" ";" "&ПОДСТАВИТЬ(MC!B$7:B$52;";";" ")&" "));ПРОСМОТР(СТРОКА(MC!A$7:A$52);СТРОКА(MC!A$7:A$52)/(MC!D$7:D$52<>"");MC!D$7:D$52))
К сообщению приложен файл: 6138354_1.xlsx(53Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДействительно.
Тогда так
Код
=ПРОСМОТР(;-1/(MC!A$7:A$52=C1)/ЕЧИСЛО(ПОИСК(" "&D1&" ";" "&ПОДСТАВИТЬ(MC!B$7:B$52;";";" ")&" "))/(D1<>"");MC!D$7:D$52)

А вот эти
кл А3 А400;500 22
кл А3 А400;500 25
засовывайте в одну ячейку в листе МС

Или используйте вот такую формулу
Код
=ПРОСМОТР(;-1/(ПРОСМОТР(СТРОКА(MC!A$7:A$52);СТРОКА(MC!A$7:A$52)/(MC!A$7:A$52<>"");MC!A$7:A$52)=C1)/ЕЧИСЛО(ПОИСК(" "&D1&" ";" "&ПОДСТАВИТЬ(MC!B$7:B$52;";";" ")&" "));ПРОСМОТР(СТРОКА(MC!A$7:A$52);СТРОКА(MC!A$7:A$52)/(MC!D$7:D$52<>"");MC!D$7:D$52))

Автор - _Boroda_
Дата добавления - 16.03.2016 в 13:30
r_roman_r Дата: Среда, 16.03.2016, 14:37 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Присоединюсь к вашей теме.
Есть таблица.
Нужно сделать заполнение ячейки символами "СПАН.", если ячейка справа не пустая.
=ЕСЛИ(ЕПУСТО(RC[1])="ЛОЖЬ";[0];["СПАН."]) выдает ошибку.
Что я делаю не так?
[moder]Много чего. Самое главное, что Правила форума не прочитали. В этой теме ответы на Ваш вопрос будут удалены. Создавайте свою, прикладывайте файл, обрамляйте формулу тегами - все это (и многое другое) есть в Правилах форума.
К сообщению приложен файл: 2332801.jpg(46Kb)


Сообщение отредактировал _Boroda_ - Среда, 16.03.2016, 14:42
 
Ответить
СообщениеПрисоединюсь к вашей теме.
Есть таблица.
Нужно сделать заполнение ячейки символами "СПАН.", если ячейка справа не пустая.
=ЕСЛИ(ЕПУСТО(RC[1])="ЛОЖЬ";[0];["СПАН."]) выдает ошибку.
Что я делаю не так?
[moder]Много чего. Самое главное, что Правила форума не прочитали. В этой теме ответы на Ваш вопрос будут удалены. Создавайте свою, прикладывайте файл, обрамляйте формулу тегами - все это (и многое другое) есть в Правилах форума.

Автор - r_roman_r
Дата добавления - 16.03.2016 в 14:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Особенности работы оператора ЕСЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!