Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск слово в ячейке по функцию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слово в ячейке по функцию (Формулы/Formulas)
Поиск слово в ячейке по функцию
vegarus Дата: Четверг, 17.03.2016, 00:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Столкнулся с проблемой функцией. В ячейке содержит текст (слово) по разным номерам ячейки. И у меня не получается, в другом ячейке выводится #Н/Д (Типа не найдено слово). В первой столбце существующие слово и в каждой строке свое слово, во второй столбце выводится текст "Есть" или "Нет" с функцией "Если", функция должна выполнять поиск в третьей столбце по разным номерам строк ячеек. Допустим: C4 - Собака, C9 - Кошка, C20 - Крокодил, а в первой столбце: A1 - Собака = Есть, A2 - Крокодил = Есть, A3 - Кошка = Есть, A4 - Еж = Нет. Но почему то функция не работает, когда я удаляю ячейку, и в другой ячейке не меняет текст.

Код
ЕСЛИ(ЕНД(ПРОСМОТР(2;1/ПОИСК($C$1:$C$50;A1)));"Не найден в каталоге";"Есть")
К сообщению приложен файл: earch_find_fun.xlsx(9Kb)


Сообщение отредактировал vegarus - Четверг, 17.03.2016, 00:21
 
Ответить
СообщениеЗдравствуйте! Столкнулся с проблемой функцией. В ячейке содержит текст (слово) по разным номерам ячейки. И у меня не получается, в другом ячейке выводится #Н/Д (Типа не найдено слово). В первой столбце существующие слово и в каждой строке свое слово, во второй столбце выводится текст "Есть" или "Нет" с функцией "Если", функция должна выполнять поиск в третьей столбце по разным номерам строк ячеек. Допустим: C4 - Собака, C9 - Кошка, C20 - Крокодил, а в первой столбце: A1 - Собака = Есть, A2 - Крокодил = Есть, A3 - Кошка = Есть, A4 - Еж = Нет. Но почему то функция не работает, когда я удаляю ячейку, и в другой ячейке не меняет текст.

Код
ЕСЛИ(ЕНД(ПРОСМОТР(2;1/ПОИСК($C$1:$C$50;A1)));"Не найден в каталоге";"Есть")

Автор - vegarus
Дата добавления - 17.03.2016 в 00:19
_Boroda_ Дата: Четверг, 17.03.2016, 00:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;$C$1:$C$50;));"Не найден в каталоге";"Есть")
К сообщению приложен файл: 8877860.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A1;$C$1:$C$50;));"Не найден в каталоге";"Есть")

Автор - _Boroda_
Дата добавления - 17.03.2016 в 00:26
vegarus Дата: Четверг, 17.03.2016, 00:57 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - vegarus
Дата добавления - 17.03.2016 в 00:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск слово в ячейке по функцию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!