Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рассчитать увеличение или уменьшение продаж - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать увеличение или уменьшение продаж (Формулы/Formulas)
Рассчитать увеличение или уменьшение продаж
Baranzev Дата: Пятница, 18.03.2016, 19:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Не могу подобрать формулу, что бы не выдавала ошибку (см. вложение)

Нужно в процентном соотношении рассчитать насколько увеличились или уменьшились продажи.
Не знаю на первый взгляд для меня задача проще простого.
Но если в одной строке стоит 0, то у меня возникли вопросы.

Код
=СУММ(A1-B1)/B1
выдает ошибку, если в графе B1 стоит 0

Код
=ЕСЛИОШИБКА(A3-B3/B3;0)
Если формат ячейки поставить Процентный, то выдает не понятные проценты.

Спасибо заранее.


Сообщение отредактировал Pelena - Воскресенье, 20.03.2016, 15:56
 
Ответить
СообщениеНе могу подобрать формулу, что бы не выдавала ошибку (см. вложение)

Нужно в процентном соотношении рассчитать насколько увеличились или уменьшились продажи.
Не знаю на первый взгляд для меня задача проще простого.
Но если в одной строке стоит 0, то у меня возникли вопросы.

Код
=СУММ(A1-B1)/B1
выдает ошибку, если в графе B1 стоит 0

Код
=ЕСЛИОШИБКА(A3-B3/B3;0)
Если формат ячейки поставить Процентный, то выдает не понятные проценты.

Спасибо заранее.

Автор - Baranzev
Дата добавления - 18.03.2016 в 19:34
Baranzev Дата: Пятница, 18.03.2016, 19:35 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Не прикрепился файл.
[moder]Исправляйте название темы согласно п.2 Правил форума и обрамляйте формулы тегами согласно п.3. И согласно ему же, прикладывайте файл в Excel.[/moder]
[moder] Для akobir - еще одно сообщение ни о чем - получите сразу кучу замечаний. Трепаться в другое место идите. Или это для увеличения количества постов и получения соответствующего статуса? Короче, я всё удаляю и буду следить.
К сообщению приложен файл: 7444097.png(10Kb)
 
Ответить
СообщениеНе прикрепился файл.
[moder]Исправляйте название темы согласно п.2 Правил форума и обрамляйте формулы тегами согласно п.3. И согласно ему же, прикладывайте файл в Excel.[/moder]
[moder] Для akobir - еще одно сообщение ни о чем - получите сразу кучу замечаний. Трепаться в другое место идите. Или это для увеличения количества постов и получения соответствующего статуса? Короче, я всё удаляю и буду следить.

Автор - Baranzev
Дата добавления - 18.03.2016 в 19:35
Baranzev Дата: Воскресенье, 20.03.2016, 15:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
На справедливое замечание модератора deal , выкладываю Excel файл.
Если бы можно редактировать свои сообщения, то не плодились бы такого рода сообщения ))) После этого меня отправят в утиль ))) или на страницу "Вопросы по работе форума"
К сообщению приложен файл: 9401833.xls(32Kb)
 
Ответить
СообщениеНа справедливое замечание модератора deal , выкладываю Excel файл.
Если бы можно редактировать свои сообщения, то не плодились бы такого рода сообщения ))) После этого меня отправят в утиль ))) или на страницу "Вопросы по работе форума"

Автор - Baranzev
Дата добавления - 20.03.2016 в 15:26
gling Дата: Воскресенье, 20.03.2016, 15:50 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Может так должно быть?
Код
=ЕСЛИОШИБКА((C3-D3)/D3;1)
 
Ответить
СообщениеМожет так должно быть?
Код
=ЕСЛИОШИБКА((C3-D3)/D3;1)

Автор - gling
Дата добавления - 20.03.2016 в 15:50
Baranzev Дата: Воскресенье, 20.03.2016, 16:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
gling, Да именно так должно быть. Спасибо большое. Что я только не перепробовал, а надо было всего двойную скобку открыть.
 
Ответить
Сообщениеgling, Да именно так должно быть. Спасибо большое. Что я только не перепробовал, а надо было всего двойную скобку открыть.

Автор - Baranzev
Дата добавления - 20.03.2016 в 16:34
Baranzev Дата: Воскресенье, 20.03.2016, 17:17 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
gling, Сразу не доглядел. Если применять формулу, которую вы предлагаете, то если за период 2015 и 2016 года были показатели 0, то в процентах показывает 100%. А это пагубно влияет на средний итог (см. вложенный файл).
Вот как сделать, так чтобы даже нулевые значения приводили значение 0,00%
К сообщению приложен файл: 5935748.xls(33Kb)
 
Ответить
Сообщениеgling, Сразу не доглядел. Если применять формулу, которую вы предлагаете, то если за период 2015 и 2016 года были показатели 0, то в процентах показывает 100%. А это пагубно влияет на средний итог (см. вложенный файл).
Вот как сделать, так чтобы даже нулевые значения приводили значение 0,00%

Автор - Baranzev
Дата добавления - 20.03.2016 в 17:17
Udik Дата: Воскресенье, 20.03.2016, 17:23 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1215
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
чтобы даже нулевые значения приводили значение 0,00%

ноль вместо единички в формуле gling


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Воскресенье, 20.03.2016, 17:26
 
Ответить
Сообщение
чтобы даже нулевые значения приводили значение 0,00%

ноль вместо единички в формуле gling

Автор - Udik
Дата добавления - 20.03.2016 в 17:23
Baranzev Дата: Воскресенье, 20.03.2016, 17:33 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Udik, Нет... пробовал. Тогда получается, что если за 2016г были показатели (продажи), а за 2015г. не было (стоит 0 или пусто), то итог 0,00%, а должно быть 100%, тк был прирост.
Во вложенном файле пометил зеленным цветом.
К сообщению приложен файл: 4928928.xls(33Kb)
 
Ответить
СообщениеUdik, Нет... пробовал. Тогда получается, что если за 2016г были показатели (продажи), а за 2015г. не было (стоит 0 или пусто), то итог 0,00%, а должно быть 100%, тк был прирост.
Во вложенном файле пометил зеленным цветом.

Автор - Baranzev
Дата добавления - 20.03.2016 в 17:33
Udik Дата: Воскресенье, 20.03.2016, 17:43 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1215
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
если ничего не забыли упомянуть, то так:
Код
=ЕСЛИОШИБКА((C8-D8)/D8;1)*(C8>0)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениеесли ничего не забыли упомянуть, то так:
Код
=ЕСЛИОШИБКА((C8-D8)/D8;1)*(C8>0)

Автор - Udik
Дата добавления - 20.03.2016 в 17:43
gling Дата: Воскресенье, 20.03.2016, 18:02 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Можно и так
Код
=ЕСЛИОШИБКА((C3-D3)/D3;ЕСЛИ(C3;1;0))
 
Ответить
СообщениеМожно и так
Код
=ЕСЛИОШИБКА((C3-D3)/D3;ЕСЛИ(C3;1;0))

Автор - gling
Дата добавления - 20.03.2016 в 18:02
Baranzev Дата: Воскресенье, 20.03.2016, 19:30 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Udik, Ваша формула подошла под мои потребности. Спасибо. А вот gling, к сожалению не совсем то. Если в 2015г стоят показатели, а в 2016 еще нет, то считает не правильно, выдает результат -100%. Но всем спасибо.
 
Ответить
СообщениеUdik, Ваша формула подошла под мои потребности. Спасибо. А вот gling, к сожалению не совсем то. Если в 2015г стоят показатели, а в 2016 еще нет, то считает не правильно, выдает результат -100%. Но всем спасибо.

Автор - Baranzev
Дата добавления - 20.03.2016 в 19:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рассчитать увеличение или уменьшение продаж (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!