Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма диапазона в зависимости от названия диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма диапазона в зависимости от названия диапазона (Формулы/Formulas)
Сумма диапазона в зависимости от названия диапазона
noobik Дата: Пятница, 18.03.2016, 23:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Извините за такую формулировку названия темы, лучше не придумал))
Прилагаю пример.
Как автоматически вычислить сумму диапазона ячеек столбца F одного инвентарного номера (столбец А)?
К сообщению приложен файл: primer.xls(24Kb)


Сообщение отредактировал noobik - Суббота, 19.03.2016, 00:00
 
Ответить
СообщениеИзвините за такую формулировку названия темы, лучше не придумал))
Прилагаю пример.
Как автоматически вычислить сумму диапазона ячеек столбца F одного инвентарного номера (столбец А)?

Автор - noobik
Дата добавления - 18.03.2016 в 23:54
buchlotnik Дата: Суббота, 19.03.2016, 00:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так?
Код
=ЕСЛИ(A6<>A5;СУММЕСЛИ($A$2:A5;A5;$F$2:F5);"")


хотя я бы сводной делал
К сообщению приложен файл: 2804683.xls(22Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 19.03.2016, 00:33
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(A6<>A5;СУММЕСЛИ($A$2:A5;A5;$F$2:F5);"")


хотя я бы сводной делал

Автор - buchlotnik
Дата добавления - 19.03.2016 в 00:22
Nic70y Дата: Суббота, 19.03.2016, 09:55 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
еще вариант
Код
=ЕСЛИ(A2=A3;"";(СУММ(F$2:F2)-СУММ(G$1:G1)))
К сообщению приложен файл: 1257975.xls(25Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениееще вариант
Код
=ЕСЛИ(A2=A3;"";(СУММ(F$2:F2)-СУММ(G$1:G1)))

Автор - Nic70y
Дата добавления - 19.03.2016 в 09:55
akobir Дата: Суббота, 19.03.2016, 11:47 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, Nic70y,
А если не будет сортировки (как в примере), работать формулы не будут.

Я бы создал отдельный лист с инвентарными номерами, перенес туда столбец А, удалил дубликаты и подтянул сумму.
К сообщению приложен файл: 4333302.xls(20Kb)


e-mail: akobir.ismailov@gmail.com
 
Ответить
Сообщениеbuchlotnik, Nic70y,
А если не будет сортировки (как в примере), работать формулы не будут.

Я бы создал отдельный лист с инвентарными номерами, перенес туда столбец А, удалил дубликаты и подтянул сумму.

Автор - akobir
Дата добавления - 19.03.2016 в 11:47
_Boroda_ Дата: Суббота, 19.03.2016, 11:54 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9352
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если не будет сортировки, то так можно
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;A$1:A1;));СУММЕСЛИ(A$2:A$99;A2;F$2:F$99);"")
К сообщению приложен файл: primer_1.xls(28Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли не будет сортировки, то так можно
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A2;A$1:A1;));СУММЕСЛИ(A$2:A$99;A2;F$2:F$99);"")

Автор - _Boroda_
Дата добавления - 19.03.2016 в 11:54
Nic70y Дата: Суббота, 19.03.2016, 12:00 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;A3:A$9;));"";СУММЕСЛИ(A$2:A$8;A2;F$2:F$8))

принцип тот-же как и у Александра оказался.
Цитата
перенес туда столбец А, удалил дубликаты и подтянул сумму
зачем такие сложности?
Цитата
сводной делал
сооб.№2


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 19.03.2016, 12:03
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ(A2;A3:A$9;));"";СУММЕСЛИ(A$2:A$8;A2;F$2:F$8))

принцип тот-же как и у Александра оказался.
Цитата
перенес туда столбец А, удалил дубликаты и подтянул сумму
зачем такие сложности?
Цитата
сводной делал
сооб.№2

Автор - Nic70y
Дата добавления - 19.03.2016 в 12:00
buchlotnik Дата: Суббота, 19.03.2016, 12:01 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
А если не будет сортировки (как в примере), работать формулы не будут
ясен-красен! формулы-то пишутся под пример - каков пример, таков и ответ ;)
Цитата
Я бы создал
сводная чем не устроила?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Суббота, 19.03.2016, 12:03
 
Ответить
Сообщение
Цитата
А если не будет сортировки (как в примере), работать формулы не будут
ясен-красен! формулы-то пишутся под пример - каков пример, таков и ответ ;)
Цитата
Я бы создал
сводная чем не устроила?

Автор - buchlotnik
Дата добавления - 19.03.2016 в 12:01
akobir Дата: Суббота, 19.03.2016, 17:13 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 9 ±
Замечаний: 0% ±

Excel 2010
Nic70y, buchlotnik,
Меня - всем.
А вдруг автор не умеет работать со сводными?
[moder]Не умеет - научим. От нас так просто не уйдешь!


e-mail: akobir.ismailov@gmail.com

Сообщение отредактировал _Boroda_ - Суббота, 19.03.2016, 18:31
 
Ответить
СообщениеNic70y, buchlotnik,
Меня - всем.
А вдруг автор не умеет работать со сводными?
[moder]Не умеет - научим. От нас так просто не уйдешь!

Автор - akobir
Дата добавления - 19.03.2016 в 17:13
AlexMen Дата: Суббота, 19.03.2016, 17:58 | Сообщение № 9
Группа: Заблокированные
Ранг: Участник
Сообщений: 66
Репутация: 4 ±
Замечаний: 100% ±

Excel 2010
да, сводная все это автоматом бы делала.


lebensvoll отпишите на почту, а то меня _Boroda_ забанил, я Вам функцию сброшу
 
Ответить
Сообщениеда, сводная все это автоматом бы делала.

Автор - AlexMen
Дата добавления - 19.03.2016 в 17:58
noobik Дата: Суббота, 19.03.2016, 23:58 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Ребята, всем спасибо) Выручили!!!!
 
Ответить
СообщениеРебята, всем спасибо) Выручили!!!!

Автор - noobik
Дата добавления - 19.03.2016 в 23:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма диапазона в зависимости от названия диапазона (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!