Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формулы для вычисления положительных и отрицательных значени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формулы для вычисления положительных и отрицательных значени (Формулы/Formulas)
Формулы для вычисления положительных и отрицательных значени
Mirloveinfiniti Дата: Суббота, 19.03.2016, 12:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, необходимо составить формулу со следующим условием, Лист2!В3 =0, если Лист1!B4>=0; если на Лист1!B4<0, то Лист2!В3 должен быть равен тому числу которое указано в Лист1!B4(только без знака минус). И вторая формула... Лист2!С3 =0, если Лист1!B4<=0;если на Лист1!B4>0, то Лист2!С3 равен тому числу которое указано в ячейке Лист1!B4... Заранее благодарю, с Уважением Сандра!!!
К сообщению приложен файл: 3841450.xlsx(9Kb)


Сообщение отредактировал Mirloveinfiniti - Суббота, 19.03.2016, 15:26
 
Ответить
СообщениеДобрый день, необходимо составить формулу со следующим условием, Лист2!В3 =0, если Лист1!B4>=0; если на Лист1!B4<0, то Лист2!В3 должен быть равен тому числу которое указано в Лист1!B4(только без знака минус). И вторая формула... Лист2!С3 =0, если Лист1!B4<=0;если на Лист1!B4>0, то Лист2!С3 равен тому числу которое указано в ячейке Лист1!B4... Заранее благодарю, с Уважением Сандра!!!

Автор - Mirloveinfiniti
Дата добавления - 19.03.2016 в 12:19
Nic70y Дата: Суббота, 19.03.2016, 12:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Mirloveinfiniti, можно не архивировать файл для примера?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Суббота, 19.03.2016, 12:35
 
Ответить
СообщениеMirloveinfiniti, можно не архивировать файл для примера?

Автор - Nic70y
Дата добавления - 19.03.2016 в 12:33
Mirloveinfiniti Дата: Суббота, 19.03.2016, 15:27 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
да, можно)))
 
Ответить
Сообщениеда, можно)))

Автор - Mirloveinfiniti
Дата добавления - 19.03.2016 в 15:27
МВТ Дата: Суббота, 19.03.2016, 15:56 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 475
Репутация: 135 ±
Замечаний: 0% ±

Excel 2007
Немного путано объяснили, но мне кажется, так
Код
=ЕСЛИ(Лист1!B4>=0;0;ABS(Лист1!B4))

и
Код
=ЕСЛИ(B4=0;0;B4)
 
Ответить
СообщениеНемного путано объяснили, но мне кажется, так
Код
=ЕСЛИ(Лист1!B4>=0;0;ABS(Лист1!B4))

и
Код
=ЕСЛИ(B4=0;0;B4)

Автор - МВТ
Дата добавления - 19.03.2016 в 15:56
_Boroda_ Дата: Суббота, 19.03.2016, 16:12 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Варианты для В
Код
=--ТЕКСТ(Лист1!B4;"\0;0")
Код
=МАКС(;-Лист1!B4)
Код
=-МИН(;Лист1!B4)

Для С
Код
=--ТЕКСТ(Лист1!B4;"0;\0")
Код
=МАКС(;Лист1!B4)
Код
=-МИН(;-Лист1!B4)
Код
=Лист1!B4*НЕ(B3)
К сообщению приложен файл: 3841450_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВарианты для В
Код
=--ТЕКСТ(Лист1!B4;"\0;0")
Код
=МАКС(;-Лист1!B4)
Код
=-МИН(;Лист1!B4)

Для С
Код
=--ТЕКСТ(Лист1!B4;"0;\0")
Код
=МАКС(;Лист1!B4)
Код
=-МИН(;-Лист1!B4)
Код
=Лист1!B4*НЕ(B3)

Автор - _Boroda_
Дата добавления - 19.03.2016 в 16:12
Mirloveinfiniti Дата: Суббота, 19.03.2016, 17:55 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем спасибо огромное!!!!!))))))))))
 
Ответить
СообщениеВсем спасибо огромное!!!!!))))))))))

Автор - Mirloveinfiniti
Дата добавления - 19.03.2016 в 17:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формулы для вычисления положительных и отрицательных значени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!