Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос остатка которые меняется - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос остатка которые меняется (Формулы/Formulas)
Перенос остатка которые меняется
bobrenja Дата: Вторник, 22.03.2016, 02:04 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Есть лист для контроля за пробегом.
Как создать условие, что бы показатели километража за вчерашний день автомобиля, при вводе марки автомобиля на следующий день, автоматом подтягивались в ячейку С с ячейки Е?

Что то пробывал с масивами по индексу вычислять наибольшее значение и вставлять, то получается циклическая формула.

Подскажите решение, а то голова кругом уже.

Заранее спасибо
К сообщению приложен файл: 4976267.xlsx(43Kb)


Сообщение отредактировал bobrenja - Вторник, 22.03.2016, 02:05
 
Ответить
СообщениеЕсть лист для контроля за пробегом.
Как создать условие, что бы показатели километража за вчерашний день автомобиля, при вводе марки автомобиля на следующий день, автоматом подтягивались в ячейку С с ячейки Е?

Что то пробывал с масивами по индексу вычислять наибольшее значение и вставлять, то получается циклическая формула.

Подскажите решение, а то голова кругом уже.

Заранее спасибо

Автор - bobrenja
Дата добавления - 22.03.2016 в 02:04
krosav4ig Дата: Вторник, 22.03.2016, 02:57 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1346
Репутация: 547 ±
Замечаний: 0% ±

Excel 2007, 2013
для C5 массивная формула
Код
=МАКС($D$2:D4*($B$2:B4=B5))
К сообщению приложен файл: 5422775.xlsx(9Kb)


(_)Õvõ(_)
 
Ответить
Сообщениедля C5 массивная формула
Код
=МАКС($D$2:D4*($B$2:B4=B5))

Автор - krosav4ig
Дата добавления - 22.03.2016 в 02:57
_Boroda_ Дата: Вторник, 22.03.2016, 04:00 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще варианты. Обычными формулами.
Код
=ПРОСМОТР(;-1/(B$2:B4=B5);D$2:D4)

Код
=ВПР(B5;B$2:E4;4;0)+СУММЕСЛИ(B$2:B4;B5;C$2:C4)

Только Вам нужно что-то и вручную заносить - или "пробег", или "км конец". Иначе никак.
К сообщению приложен файл: 4976267_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще варианты. Обычными формулами.
Код
=ПРОСМОТР(;-1/(B$2:B4=B5);D$2:D4)

Код
=ВПР(B5;B$2:E4;4;0)+СУММЕСЛИ(B$2:B4;B5;C$2:C4)

Только Вам нужно что-то и вручную заносить - или "пробег", или "км конец". Иначе никак.

Автор - _Boroda_
Дата добавления - 22.03.2016 в 04:00
bobrenja Дата: Вторник, 22.03.2016, 09:06 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Пробег вручную.
 
Ответить
СообщениеПробег вручную.

Автор - bobrenja
Дата добавления - 22.03.2016 в 09:06
bobrenja Дата: Вторник, 22.03.2016, 09:37 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
А будет работать??

Если в Строке B с разным интервалом будут автомобили появляется и в разной последовательности.
Нужно еще делать поиск по столбцу B
[moder]Все уже сделано. Просто попробуйте приведенные выше формулы.


Сообщение отредактировал _Boroda_ - Вторник, 22.03.2016, 09:53
 
Ответить
СообщениеА будет работать??

Если в Строке B с разным интервалом будут автомобили появляется и в разной последовательности.
Нужно еще делать поиск по столбцу B
[moder]Все уже сделано. Просто попробуйте приведенные выше формулы.

Автор - bobrenja
Дата добавления - 22.03.2016 в 09:37
bobrenja Дата: Вторник, 22.03.2016, 19:19 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Спасибо большое. Все просто работает замечательно.

Всем плюсики.
 
Ответить
СообщениеСпасибо большое. Все просто работает замечательно.

Всем плюсики.

Автор - bobrenja
Дата добавления - 22.03.2016 в 19:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос остатка которые меняется (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!