Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Массовое переименование заначения в соответсвующий ему текс - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массовое переименование заначения в соответсвующий ему текс (Формулы/Formulas)
Массовое переименование заначения в соответсвующий ему текс
igorrostov Дата: Вторник, 22.03.2016, 12:56 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Столкнулся с проблемой. Мне нужно переделать xml прайс в excel. Поставщик в прайсе вместо названия категории указал числовое значение , которое соответствует этой категории.
Получается в начале документа размещены категории и в соседней ячейки число. О потом идет весь прайс с товаром где категория это число. Подскажите как мне можно массово заменить эти числа на соотв. им название категории.
Прикрепляю принт.
[moder]Зачем нам принт? Показывайте в файле Excel.
И список соответствия туда же приложите.
И желаемым результатом вручную несколько позиций заполните.
К сообщению приложен файл: 4997829.png(24Kb)
 
Ответить
СообщениеДобрый день!
Столкнулся с проблемой. Мне нужно переделать xml прайс в excel. Поставщик в прайсе вместо названия категории указал числовое значение , которое соответствует этой категории.
Получается в начале документа размещены категории и в соседней ячейки число. О потом идет весь прайс с товаром где категория это число. Подскажите как мне можно массово заменить эти числа на соотв. им название категории.
Прикрепляю принт.
[moder]Зачем нам принт? Показывайте в файле Excel.
И список соответствия туда же приложите.
И желаемым результатом вручную несколько позиций заполните.

Автор - igorrostov
Дата добавления - 22.03.2016 в 12:56
китин Дата: Вторник, 22.03.2016, 12:59 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3719
Репутация: 574 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ВПР вам в помощь.
[p.s.]форум по фотошопу на соседней улице


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеВПР вам в помощь.
[p.s.]форум по фотошопу на соседней улице

Автор - китин
Дата добавления - 22.03.2016 в 12:59
igorrostov Дата: Вторник, 22.03.2016, 13:41 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прикрепляю файл EXCEL.
Там в примечании написал как есть и как должно быть.
К сообщению приложен файл: opt_ready.xlsx(15Kb)


Сообщение отредактировал igorrostov - Вторник, 22.03.2016, 13:42
 
Ответить
СообщениеПрикрепляю файл EXCEL.
Там в примечании написал как есть и как должно быть.

Автор - igorrostov
Дата добавления - 22.03.2016 в 13:41
buchlotnik Дата: Вторник, 22.03.2016, 14:30 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2203
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
как-то так
Код
=ИНДЕКС($A$2:$A$9;ПОИСКПОЗ(E10;$B$2:$B$9;0))
К сообщению приложен файл: opt_ready-1-.xlsx(16Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениекак-то так
Код
=ИНДЕКС($A$2:$A$9;ПОИСКПОЗ(E10;$B$2:$B$9;0))

Автор - buchlotnik
Дата добавления - 22.03.2016 в 14:30
Che79 Дата: Вторник, 22.03.2016, 15:59 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 215
Репутация: 28 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
Еще варианты:
Код
=ПРОСМОТР(E10;$B$2:$B$9;$A$2:$A$9)

Код
=ВПР(E10;ВЫБОР({1;2};$B$2:$B$9;$A$2:$A$9);2;)


Делай нормально и будет нормально!
 
Ответить
СообщениеЕще варианты:
Код
=ПРОСМОТР(E10;$B$2:$B$9;$A$2:$A$9)

Код
=ВПР(E10;ВЫБОР({1;2};$B$2:$B$9;$A$2:$A$9);2;)

Автор - Che79
Дата добавления - 22.03.2016 в 15:59
igorrostov Дата: Вторник, 22.03.2016, 16:01 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Большое спасибо за помощь!
Формула подошла. Буду весь прайс таким образом переделывать
 
Ответить
СообщениеБольшое спасибо за помощь!
Формула подошла. Буду весь прайс таким образом переделывать

Автор - igorrostov
Дата добавления - 22.03.2016 в 16:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Массовое переименование заначения в соответсвующий ему текс (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!