Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значений на разных листах - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений на разных листах (Формулы/Formulas)
Поиск значений на разных листах
Блондинка Дата: Вторник, 22.03.2016, 16:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Подскажите, пожалуйста, по следующему вопросу.
Имеются 2 листа в книге. На первом такая таблица: дата, название продукции и себестоимость на указанную дату. Т.е. в данной таблице могут быть одинаковые наименования продукции, но в зависимости от даты у них будет разная себестоимость.
На 2-м листе таблица: дата, название продукции количество, цена продажи и выручка.
Мне необходимо на 2-м листе добавить столбец с информацией о том, какая себестоимость продукции была в момент её продажи.

Мучилась с функциями ИНДЕКС и ПОИСКПОЗ, но что-то ничего не вышло...
Пожалуйста, помогите, как это всё организовать.. Прикрепляю файл.
К сообщению приложен файл: 2519379.xls(59Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, по следующему вопросу.
Имеются 2 листа в книге. На первом такая таблица: дата, название продукции и себестоимость на указанную дату. Т.е. в данной таблице могут быть одинаковые наименования продукции, но в зависимости от даты у них будет разная себестоимость.
На 2-м листе таблица: дата, название продукции количество, цена продажи и выручка.
Мне необходимо на 2-м листе добавить столбец с информацией о том, какая себестоимость продукции была в момент её продажи.

Мучилась с функциями ИНДЕКС и ПОИСКПОЗ, но что-то ничего не вышло...
Пожалуйста, помогите, как это всё организовать.. Прикрепляю файл.

Автор - Блондинка
Дата добавления - 22.03.2016 в 16:52
_Boroda_ Дата: Вторник, 22.03.2016, 17:00 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ПРОСМОТР(;-1/(B2='Лист1 '!B$2:B$152)/('Лист1 '!A$2:A$152-A2<=0);'Лист1 '!C$2:C$152)
К сообщению приложен файл: 2519379_1.xls(66Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ПРОСМОТР(;-1/(B2='Лист1 '!B$2:B$152)/('Лист1 '!A$2:A$152-A2<=0);'Лист1 '!C$2:C$152)

Автор - _Boroda_
Дата добавления - 22.03.2016 в 17:00
Блондинка Дата: Вторник, 22.03.2016, 17:10 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Супер! Большое Спасибо! :D hands
 
Ответить
СообщениеСупер! Большое Спасибо! :D hands

Автор - Блондинка
Дата добавления - 22.03.2016 в 17:10
Блондинка Дата: Среда, 23.03.2016, 15:14 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Добрый день!
Создаю следующие листы в данной книге, но формулой пользоваться не могу. Что делаю не так?
К сообщению приложен файл: 8611915.xls(79Kb)
 
Ответить
Сообщение_Boroda_, Добрый день!
Создаю следующие листы в данной книге, но формулой пользоваться не могу. Что делаю не так?

Автор - Блондинка
Дата добавления - 23.03.2016 в 15:14
_Boroda_ Дата: Среда, 23.03.2016, 15:25 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Сравните мою формулу и свою.
У Вас
Код
=ПРОСМОТР(;-1/(B2=сети!A$2:A$40-сети2!A$2:A$36<=0);сети!C2:C40)

нужно
Код
=ПРОСМОТР(;-1/(B2=сети!B$2:B$40)/(сети!A$2:A$40-A2<=0);сети!C$2:C$40)

Там, где даст ошибку - в листе Сети нед даты раньше искомой
Избавиться от ошибки можно, например, так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(B2=сети!B$2:B$40)/(сети!A$2:A$40-A2<=0);сети!C$2:C$40);)
К сообщению приложен файл: 8611915_1.xls(88Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСравните мою формулу и свою.
У Вас
Код
=ПРОСМОТР(;-1/(B2=сети!A$2:A$40-сети2!A$2:A$36<=0);сети!C2:C40)

нужно
Код
=ПРОСМОТР(;-1/(B2=сети!B$2:B$40)/(сети!A$2:A$40-A2<=0);сети!C$2:C$40)

Там, где даст ошибку - в листе Сети нед даты раньше искомой
Избавиться от ошибки можно, например, так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(B2=сети!B$2:B$40)/(сети!A$2:A$40-A2<=0);сети!C$2:C$40);)

Автор - _Boroda_
Дата добавления - 23.03.2016 в 15:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значений на разных листах (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!