Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула =SUMIFS не подсчитывает результаты согласно критерия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула =SUMIFS не подсчитывает результаты согласно критерия (Формулы/Formulas)
формула =SUMIFS не подсчитывает результаты согласно критерия
tawki Дата: Среда, 23.03.2016, 11:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день.
Подскажите пожалуйста что я неправильно пишу в формуле (в ячейке отмеченной красным цветом).
Код
=SUMIFS(E10:E21;A10:A21;"a";D10:D21;"Breakdown";D10:D21;"Setup_and_Adjustments")
Код
=SUMIFS(E10:E21;A10:A21;"a";D10:D21;"Breakdown:Setup_and_Adjustments")

никак не получается.
Заранее благодарю.
[moder]Формулы нужно обрамлять тегами - кнопка fx. Поправил на первый раз
К сообщению приложен файл: example.xlsx(30Kb)


Сообщение отредактировал _Boroda_ - Среда, 23.03.2016, 11:13
 
Ответить
СообщениеВсем добрый день.
Подскажите пожалуйста что я неправильно пишу в формуле (в ячейке отмеченной красным цветом).
Код
=SUMIFS(E10:E21;A10:A21;"a";D10:D21;"Breakdown";D10:D21;"Setup_and_Adjustments")
Код
=SUMIFS(E10:E21;A10:A21;"a";D10:D21;"Breakdown:Setup_and_Adjustments")

никак не получается.
Заранее благодарю.
[moder]Формулы нужно обрамлять тегами - кнопка fx. Поправил на первый раз

Автор - tawki
Дата добавления - 23.03.2016 в 11:08
Nic70y Дата: Среда, 23.03.2016, 11:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3474
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ((("Breakdown"=D10:D21)+("Setup_and_Adjustments"=D10:D21))*(A10:A21="a")*E10:E21)
что я неправильно пишу в формуле
все неправильно


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((("Breakdown"=D10:D21)+("Setup_and_Adjustments"=D10:D21))*(A10:A21="a")*E10:E21)
что я неправильно пишу в формуле
все неправильно

Автор - Nic70y
Дата добавления - 23.03.2016 в 11:13
_Boroda_ Дата: Среда, 23.03.2016, 11:15 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(СУММЕСЛИМН(E10:E21;A10:A21;"a";D10:D21;{"Breakdown":"Setup_and_Adjustments"}))

СУММЕСЛИМН считает тогда, когда ВСЕ условия выполняются - И первое, И второе, И третье. А у Вас второе и третье взаимоисключающи.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(СУММЕСЛИМН(E10:E21;A10:A21;"a";D10:D21;{"Breakdown":"Setup_and_Adjustments"}))

СУММЕСЛИМН считает тогда, когда ВСЕ условия выполняются - И первое, И второе, И третье. А у Вас второе и третье взаимоисключающи.

Автор - _Boroda_
Дата добавления - 23.03.2016 в 11:15
tawki Дата: Среда, 23.03.2016, 11:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Nic70y,
Спасибо большое. получлось.
Сорри я не спец в EXCEL и возможно этот пример был простой.
 
Ответить
СообщениеNic70y,
Спасибо большое. получлось.
Сорри я не спец в EXCEL и возможно этот пример был простой.

Автор - tawki
Дата добавления - 23.03.2016 в 11:22
Nic70y Дата: Среда, 23.03.2016, 11:32 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3474
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
[offtop]
Nic70y,
Спасибо большое
а _Boroda_ значит по бороде... :D
[/offtop]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение[offtop]
Nic70y,
Спасибо большое
а _Boroda_ значит по бороде... :D
[/offtop]

Автор - Nic70y
Дата добавления - 23.03.2016 в 11:32
tawki Дата: Среда, 23.03.2016, 16:40 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
:( Nic70y, Сорри но формула _Boroda_, почему то не получилась
 
Ответить
Сообщение:( Nic70y, Сорри но формула _Boroda_, почему то не получилась

Автор - tawki
Дата добавления - 23.03.2016 в 16:40
vikttur Дата: Среда, 23.03.2016, 16:41 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Код
=СУММ(СУММЕСЛИМН(E10:E21;A10:A21;"a";D10:D21;{"Breakdown";"Setup_and_Adjustments"}))
 
Ответить
Сообщение
Код
=СУММ(СУММЕСЛИМН(E10:E21;A10:A21;"a";D10:D21;{"Breakdown";"Setup_and_Adjustments"}))

Автор - vikttur
Дата добавления - 23.03.2016 в 16:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула =SUMIFS не подсчитывает результаты согласно критерия (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!