Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка пустых строк в столбец с данными - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка пустых строк в столбец с данными (Формулы/Formulas)
Вставка пустых строк в столбец с данными
Shtein Дата: Среда, 23.03.2016, 15:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день всем.

На первый взгляд легкая задача, но я не могу сразу сообразить, как сделать.
Во вложении 2 случая, которые надо решить, но принцип похож. Есть столбец с данными, между ними нужно вставить одинаковое количество пустых строк.
1-я вкладка - надо после каждой строкой со значением ставить 2 пустых строки.
2-я вкладка - надо после каждых 2-х строк со значениями вставить 1 пустую строку.

Я бы вручную проставил, но столбец с данными большой, может есть способ автоматизировать как-то.
К сообщению приложен файл: 6125052.xlsx(10Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеДобрый день всем.

На первый взгляд легкая задача, но я не могу сразу сообразить, как сделать.
Во вложении 2 случая, которые надо решить, но принцип похож. Есть столбец с данными, между ними нужно вставить одинаковое количество пустых строк.
1-я вкладка - надо после каждой строкой со значением ставить 2 пустых строки.
2-я вкладка - надо после каждых 2-х строк со значениями вставить 1 пустую строку.

Я бы вручную проставил, но столбец с данными большой, может есть способ автоматизировать как-то.

Автор - Shtein
Дата добавления - 23.03.2016 в 15:57
Karataev Дата: Среда, 23.03.2016, 16:35 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 226 ±
Замечаний: 0% ±

Excel
Реализовал с помощью макросов. Кнопки для запусков макросов находятся в ячейках C1.
К сообщению приложен файл: 1199986.xlsm(22Kb)




Сообщение отредактировал Karataev - Среда, 23.03.2016, 16:36
 
Ответить
СообщениеРеализовал с помощью макросов. Кнопки для запусков макросов находятся в ячейках C1.

Автор - Karataev
Дата добавления - 23.03.2016 в 16:35
Pelena Дата: Среда, 23.03.2016, 16:43 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9845
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Вариант формулами
Код
=ЕСЛИ(ОСТАТ(СТРОКА(3:3);3);"";ИНДЕКС($A$2:$A$7;СУММПРОИЗВ(--($E$1:E1<>""))))
К сообщению приложен файл: 2257706.xlsx(11Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант формулами
Код
=ЕСЛИ(ОСТАТ(СТРОКА(3:3);3);"";ИНДЕКС($A$2:$A$7;СУММПРОИЗВ(--($E$1:E1<>""))))

Автор - Pelena
Дата добавления - 23.03.2016 в 16:43
vikttur Дата: Среда, 23.03.2016, 16:52 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2029
Репутация: 355 ±
Замечаний: 0% ±

Код
=ЕСЛИ(ОСТАТ(СТРОКА(A3);3);"";ИНДЕКС($A$2:$A$7;СЧЁТЕСЛИ($E$1:E1;"?*")))
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(СТРОКА(A3);3);"";ИНДЕКС($A$2:$A$7;СЧЁТЕСЛИ($E$1:E1;"?*")))

Автор - vikttur
Дата добавления - 23.03.2016 в 16:52
Shtein Дата: Среда, 23.03.2016, 17:06 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 41
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Благодарю, буду разбираться victory


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеБлагодарю, буду разбираться victory

Автор - Shtein
Дата добавления - 23.03.2016 в 17:06
_Boroda_ Дата: Среда, 23.03.2016, 17:20 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9348
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС(A$2:A$9;ЕСЛИ(НОД(СТРОКА(A3);3)=3;СТРОКА(A3)/3;8))&""

Код
=ИНДЕКС(A:A;СТРОКА(A3)/3+СЧЁТЗ(A:A)*ОСТАТ(СТРОКА(A3);3)+1)&""

Код
=ИНДЕКС(A:A;СТРОКА(A3)/3+9*ОСТАТ(СТРОКА(A3);3)+1)&""
К сообщению приложен файл: 6125052_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС(A$2:A$9;ЕСЛИ(НОД(СТРОКА(A3);3)=3;СТРОКА(A3)/3;8))&""

Код
=ИНДЕКС(A:A;СТРОКА(A3)/3+СЧЁТЗ(A:A)*ОСТАТ(СТРОКА(A3);3)+1)&""

Код
=ИНДЕКС(A:A;СТРОКА(A3)/3+9*ОСТАТ(СТРОКА(A3);3)+1)&""

Автор - _Boroda_
Дата добавления - 23.03.2016 в 17:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка пустых строк в столбец с данными (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!