Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протягиваем ВПР в право - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протягиваем ВПР в право (Формулы/Formulas)
Протягиваем ВПР в право
Chudson Дата: Четверг, 24.03.2016, 15:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Доброго времени суток!
Подскажите, пожалуйста по данному кейсу:

Есть 2 заполненные таблицы, строки первой таблицы описывают отдельные платежи, строки второй – описывают те же платежи, просто содержат другие поля. Столбец "Номер заказа" в этих двух таблицах позволяет идентифицировать платёж, т. е. одно значение в разных таблицах – это один и тот же платёж. Требуется вписать формулу, которая при перетаскивании вниз и вправо, т. е. без изменения самой формулы руками, позволит заполнить ячейки соответствующими значениями. Ну т. е. нужно заполнить нужные поля именно для требуемой транзакции.
Однако при использовании функции СТОЛБЕЦ() ячейка выдает #ссылка
К сообщению приложен файл: 5770508.xlsx(12Kb)
 
Ответить
СообщениеДоброго времени суток!
Подскажите, пожалуйста по данному кейсу:

Есть 2 заполненные таблицы, строки первой таблицы описывают отдельные платежи, строки второй – описывают те же платежи, просто содержат другие поля. Столбец "Номер заказа" в этих двух таблицах позволяет идентифицировать платёж, т. е. одно значение в разных таблицах – это один и тот же платёж. Требуется вписать формулу, которая при перетаскивании вниз и вправо, т. е. без изменения самой формулы руками, позволит заполнить ячейки соответствующими значениями. Ну т. е. нужно заполнить нужные поля именно для требуемой транзакции.
Однако при использовании функции СТОЛБЕЦ() ячейка выдает #ссылка

Автор - Chudson
Дата добавления - 24.03.2016 в 15:22
китин Дата: Четверг, 24.03.2016, 15:30 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ни чё не понял.поработаем экстрасенсом
Код
=ЕСЛИОШИБКА(ИНДЕКС($P$3:$S$16;ПОИСКПОЗ($H3;$O$3:$O$16;0);ПОИСКПОЗ(I$2;$P$2:$S$2;0));"")
К сообщению приложен файл: Chudson.xlsx(12Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениени чё не понял.поработаем экстрасенсом
Код
=ЕСЛИОШИБКА(ИНДЕКС($P$3:$S$16;ПОИСКПОЗ($H3;$O$3:$O$16;0);ПОИСКПОЗ(I$2;$P$2:$S$2;0));"")

Автор - китин
Дата добавления - 24.03.2016 в 15:30
abtextime Дата: Четверг, 24.03.2016, 15:31 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Так хотите? Или я неправильно понял?

Код
=ВПР($H3;$O$3:$S$16;2;0)
К сообщению приложен файл: _5770508.xlsx(13Kb)
 
Ответить
СообщениеТак хотите? Или я неправильно понял?

Код
=ВПР($H3;$O$3:$S$16;2;0)

Автор - abtextime
Дата добавления - 24.03.2016 в 15:31
vikttur Дата: Четверг, 24.03.2016, 15:35 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ЕСЛИОШИБКА(ВПР($H3;$O$3:$S$16;СТОЛБЕЦ(B1););"")
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР($H3;$O$3:$S$16;СТОЛБЕЦ(B1););"")

Автор - vikttur
Дата добавления - 24.03.2016 в 15:35
Gustav Дата: Четверг, 24.03.2016, 15:37 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1211
Репутация: 484 ±
Замечаний: 0% ±

начинал с Excel 4.0...
Для ячейки I3:
Код
=ВПР($H3;$O$3:$S$16;СТОЛБЕЦ()-СТОЛБЕЦ($G3);ЛОЖЬ)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеДля ячейки I3:
Код
=ВПР($H3;$O$3:$S$16;СТОЛБЕЦ()-СТОЛБЕЦ($G3);ЛОЖЬ)

Автор - Gustav
Дата добавления - 24.03.2016 в 15:37
SLAVICK Дата: Четверг, 24.03.2016, 15:38 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1849
Репутация: 614 ±
Замечаний: 0% ±

2007,2010,2013,2016
Насколько понял так:
Код
=ВПР($H3;$O$3:$S$16;СТОЛБЕЦ(B1);0)
К сообщению приложен файл: 5684236.xlsx(13Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеНасколько понял так:
Код
=ВПР($H3;$O$3:$S$16;СТОЛБЕЦ(B1);0)

Автор - SLAVICK
Дата добавления - 24.03.2016 в 15:38
Chudson Дата: Четверг, 24.03.2016, 15:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Прошу прощения за сумбурное пояснение. Попробую объяснить.
У нас есть три таблицы, 2 заполненные, одна (в центре) нет.
В первой таблице Номера заказа выстроены по порядку, начиная с 1 и далее.
А в третьей таблице они намерено перепутаны. ( 1 и 2 заказ идут в конце списка)
Нам нужно данные из третьей таблицы перенести во вторую, но чтобы они выстроились по порядку Номера заказа, чтобы 1 заказ был первой строчкой во второй таблицей с сохранением остальных полей:
1 Россия Москва мужской женат
Далее нужно иметь возможность протянуть эту формулу, чтобы второй строчкой автоматически стал Номер заказа 2 и так далее.

1 Россия Москва мужской женат
2 Франция Париж мужской женат
3 Россия Пермь мужской холост
4 Великобритания Лондон мужской женат
5 Венгрия Будапешт мужской холост
 
Ответить
Сообщениекитин, Прошу прощения за сумбурное пояснение. Попробую объяснить.
У нас есть три таблицы, 2 заполненные, одна (в центре) нет.
В первой таблице Номера заказа выстроены по порядку, начиная с 1 и далее.
А в третьей таблице они намерено перепутаны. ( 1 и 2 заказ идут в конце списка)
Нам нужно данные из третьей таблицы перенести во вторую, но чтобы они выстроились по порядку Номера заказа, чтобы 1 заказ был первой строчкой во второй таблицей с сохранением остальных полей:
1 Россия Москва мужской женат
Далее нужно иметь возможность протянуть эту формулу, чтобы второй строчкой автоматически стал Номер заказа 2 и так далее.

1 Россия Москва мужской женат
2 Франция Париж мужской женат
3 Россия Пермь мужской холост
4 Великобритания Лондон мужской женат
5 Венгрия Будапешт мужской холост

Автор - Chudson
Дата добавления - 24.03.2016 в 15:39
abtextime Дата: Четверг, 24.03.2016, 15:44 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
в столбец H еще внесите

Код
=$B3
К сообщению приложен файл: 5198328.xlsx(13Kb)


Сообщение отредактировал abtextime - Четверг, 24.03.2016, 15:44
 
Ответить
Сообщениев столбец H еще внесите

Код
=$B3

Автор - abtextime
Дата добавления - 24.03.2016 в 15:44
_Boroda_ Дата: Четверг, 24.03.2016, 15:44 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9380
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну, собственно, все решения как раз это и делают.
Ну вот еще такое же по сути, заполняющее и первый столбец
Код
=ВПР($B3;$O$3:$S$16;СТОЛБЕЦ(A3);)
К сообщению приложен файл: 5770508_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу, собственно, все решения как раз это и делают.
Ну вот еще такое же по сути, заполняющее и первый столбец
Код
=ВПР($B3;$O$3:$S$16;СТОЛБЕЦ(A3);)

Автор - _Boroda_
Дата добавления - 24.03.2016 в 15:44
китин Дата: Четверг, 24.03.2016, 15:54 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Нам нужно данные из третьей таблицы перенести во вторую, но чтобы они выстроились по порядку Номера заказа, чтобы 1 заказ был первой строчкой во второй таблицей с сохранением остальных полей:

ну дык посавьте в табл.2 № заказо по порядку(ручками) и посмотрите што будет.имеется в виду в моем файле


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Нам нужно данные из третьей таблицы перенести во вторую, но чтобы они выстроились по порядку Номера заказа, чтобы 1 заказ был первой строчкой во второй таблицей с сохранением остальных полей:

ну дык посавьте в табл.2 № заказо по порядку(ручками) и посмотрите што будет.имеется в виду в моем файле

Автор - китин
Дата добавления - 24.03.2016 в 15:54
Chudson Дата: Четверг, 24.03.2016, 16:03 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем огромное!!!
 
Ответить
СообщениеСпасибо всем огромное!!!

Автор - Chudson
Дата добавления - 24.03.2016 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протягиваем ВПР в право (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!