Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчет среднего значения - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет среднего значения (Формулы/Formulas)
подсчет среднего значения
HelenPerfect Дата: Пятница, 25.03.2016, 12:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 22
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Пытаюсь создать шаблон с вычислением среднего остатка. Данные будут вносится обычной вставкой. Задача такова.
Подсчитать средний остаток по территории с учетом подтипа товара и его категории (т.е. 3 условия).
Абсолютно все данные в таблице будут постоянно меняться как в количественном, так и качественном выражении.
Подскажите, пожалуйста, эту мегаформулу..
Прикладываю пример, красным выделила числа, которые должны получиться.
К сообщению приложен файл: 1705240.xlsx(10Kb)


Сообщение отредактировал HelenPerfect - Пятница, 25.03.2016, 12:26
 
Ответить
СообщениеДобрый день.
Пытаюсь создать шаблон с вычислением среднего остатка. Данные будут вносится обычной вставкой. Задача такова.
Подсчитать средний остаток по территории с учетом подтипа товара и его категории (т.е. 3 условия).
Абсолютно все данные в таблице будут постоянно меняться как в количественном, так и качественном выражении.
Подскажите, пожалуйста, эту мегаформулу..
Прикладываю пример, красным выделила числа, которые должны получиться.

Автор - HelenPerfect
Дата добавления - 25.03.2016 в 12:23
_Boroda_ Дата: Пятница, 25.03.2016, 12:32 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ОКРУГЛ(СРЗНАЧЕСЛИМН(F$2:F$99;A$2:A$99;A2;C$2:C$99;C2;D$2:D$99;D2);)

Или со старыми формулами
Код
=ОКРУГЛ(СУММПРОИЗВ(F$2:F$99*(A$2:A$99=A2)*(C$2:C$99=C2)*(D$2:D$99=D2))/СУММПРОИЗВ((A$2:A$99=A2)*(C$2:C$99=C2)*(D$2:D$99=D2));)
К сообщению приложен файл: 1705240_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ОКРУГЛ(СРЗНАЧЕСЛИМН(F$2:F$99;A$2:A$99;A2;C$2:C$99;C2;D$2:D$99;D2);)

Или со старыми формулами
Код
=ОКРУГЛ(СУММПРОИЗВ(F$2:F$99*(A$2:A$99=A2)*(C$2:C$99=C2)*(D$2:D$99=D2))/СУММПРОИЗВ((A$2:A$99=A2)*(C$2:C$99=C2)*(D$2:D$99=D2));)

Автор - _Boroda_
Дата добавления - 25.03.2016 в 12:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчет среднего значения (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!