Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/График с двумя выпадающими списками - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График с двумя выпадающими списками (Графики и диаграммы/Charts)
График с двумя выпадающими списками
drimdonetsk Дата: Пятница, 25.03.2016, 13:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые форумчане помогите решить небольшую проблемку. Существует огромная таблица нечитабельного вида в которой показаны продажи магазинов в разрезе товаров и месяцев. Так как анализировать данные в таком виде довольно проблематично, необходимо сделать так, чтобы на графике появлялись данные из этой таблицы в зависимости от выбранного магазина и категории товаров. Выбор происходит из двух выпадающих списков. Например, при выборе "магазина №1" и товара "яблоко" на графике появляются продажи яблок в этом магазине в январе, феврале и.т.д. Я так полагаю, что это можно сделать с помощью макроса, а я в этом не силен. Всем заранее спасибо за помощь. Файл с примером прилагаю.
К сообщению приложен файл: 8523892.xlsx(16Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане помогите решить небольшую проблемку. Существует огромная таблица нечитабельного вида в которой показаны продажи магазинов в разрезе товаров и месяцев. Так как анализировать данные в таком виде довольно проблематично, необходимо сделать так, чтобы на графике появлялись данные из этой таблицы в зависимости от выбранного магазина и категории товаров. Выбор происходит из двух выпадающих списков. Например, при выборе "магазина №1" и товара "яблоко" на графике появляются продажи яблок в этом магазине в январе, феврале и.т.д. Я так полагаю, что это можно сделать с помощью макроса, а я в этом не силен. Всем заранее спасибо за помощь. Файл с примером прилагаю.

Автор - drimdonetsk
Дата добавления - 25.03.2016 в 13:44
Manyasha Дата: Пятница, 25.03.2016, 14:09 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1997
Репутация: 829 ±
Замечаний: 0% ±

Excel 2010, 2016
drimdonetsk, можно и формулами.
длинная получилась
Код
=ИНДЕКС($C$20:$CT$29;МИН(ЕСЛИ(($B$20:$B$29=$A$2);СТРОКА($B$20:$B$29)-19;""));НАИМЕНЬШИЙ(ЕСЛИ($C$19:$CT$19=$S$2;СТОЛБЕЦ($C$19:$CT$19)-2;"");СТРОКА(T1)))

формула массивная, вводить нужно через ctrl+shift+enter
К сообщению приложен файл: 8523892-1.xlsx(18Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеdrimdonetsk, можно и формулами.
длинная получилась
Код
=ИНДЕКС($C$20:$CT$29;МИН(ЕСЛИ(($B$20:$B$29=$A$2);СТРОКА($B$20:$B$29)-19;""));НАИМЕНЬШИЙ(ЕСЛИ($C$19:$CT$19=$S$2;СТОЛБЕЦ($C$19:$CT$19)-2;"");СТРОКА(T1)))

формула массивная, вводить нужно через ctrl+shift+enter

Автор - Manyasha
Дата добавления - 25.03.2016 в 14:09
_Boroda_ Дата: Пятница, 25.03.2016, 14:10 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11546
Репутация: 4754 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
это можно сделать с помощью макроса

Да не, зачем, обычными формулами все делается.
Код
=ИНДЕКС(C$20:CT$29;ПОИСКПОЗ(A$2;B$20:B$29;);ПОИСКПОЗ(S$2;C$19:J$19;)+8*(СЧЁТ(C$2:C2)-1))
К сообщению приложен файл: 8523892_1.xlsx(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
это можно сделать с помощью макроса

Да не, зачем, обычными формулами все делается.
Код
=ИНДЕКС(C$20:CT$29;ПОИСКПОЗ(A$2;B$20:B$29;);ПОИСКПОЗ(S$2;C$19:J$19;)+8*(СЧЁТ(C$2:C2)-1))

Автор - _Boroda_
Дата добавления - 25.03.2016 в 14:10
drimdonetsk Дата: Пятница, 25.03.2016, 14:56 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Boroda и Manyasha, Огромное спасибо!!!!!!!!!!! Действительно все работает без макроса.
 
Ответить
СообщениеBoroda и Manyasha, Огромное спасибо!!!!!!!!!!! Действительно все работает без макроса.

Автор - drimdonetsk
Дата добавления - 25.03.2016 в 14:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » График с двумя выпадающими списками (Графики и диаграммы/Charts)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!