Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Печать бланка с разных листов которые добавляются. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Печать бланка с разных листов которые добавляются. (Формулы/Formulas)
Печать бланка с разных листов которые добавляются.
bobrenja Дата: Пятница, 25.03.2016, 23:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
В книге есть бланк для печати, и будут добавляться листы (в примере Январь, Февраль....)
Бланк заполняется формулой
Код
=ВПР("x";январь!B3:F10;3;0)
Со временем появляется новый лист, к примеру Февраль.

Как делать вывод данных в тот же бланк??
Может есть какое то условие ВПР поиск "x" по всем листам которые есть и которые будут добавляться со временем??
 
Ответить
СообщениеВ книге есть бланк для печати, и будут добавляться листы (в примере Январь, Февраль....)
Бланк заполняется формулой
Код
=ВПР("x";январь!B3:F10;3;0)
Со временем появляется новый лист, к примеру Февраль.

Как делать вывод данных в тот же бланк??
Может есть какое то условие ВПР поиск "x" по всем листам которые есть и которые будут добавляться со временем??

Автор - bobrenja
Дата добавления - 25.03.2016 в 23:33
bobrenja Дата: Пятница, 25.03.2016, 23:51 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Вот есть два решения подобных - http://www.excel-vba.ru/chto-um....-listam
Один с формулами, второй VBA (но хочется без макросов.)

Если рассматривать тот вариант, то нужно тогда как то автоматизировать список вывода всех листов в столбце которые есть (будут) в книге
 
Ответить
СообщениеВот есть два решения подобных - http://www.excel-vba.ru/chto-um....-listam
Один с формулами, второй VBA (но хочется без макросов.)

Если рассматривать тот вариант, то нужно тогда как то автоматизировать список вывода всех листов в столбце которые есть (будут) в книге

Автор - bobrenja
Дата добавления - 25.03.2016 в 23:51
bobrenja Дата: Суббота, 26.03.2016, 00:08 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Может проще что бы бланк был на том же листе где таблица?? Тогда при копировании, все будет на месте?
Но если со временем что то в бланке изменится? Придется на всех листах что созданы менять.
Нужно искать решение с бланком на отдельном листе.
 
Ответить
СообщениеМожет проще что бы бланк был на том же листе где таблица?? Тогда при копировании, все будет на месте?
Но если со временем что то в бланке изменится? Придется на всех листах что созданы менять.
Нужно искать решение с бланком на отдельном листе.

Автор - bobrenja
Дата добавления - 26.03.2016 в 00:08
vikttur Дата: Суббота, 26.03.2016, 00:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Код
=ВПР("x";ДВССЫЛ(A1&"!B3:F10";3;0)

В А1 - название листа
 
Ответить
Сообщение
Код
=ВПР("x";ДВССЫЛ(A1&"!B3:F10";3;0)

В А1 - название листа

Автор - vikttur
Дата добавления - 26.03.2016 в 00:13
bobrenja Дата: Суббота, 26.03.2016, 00:37 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
vikttur, ошибку выдает
"Для этой функции были указаны аргументы (слишком много)"
 
Ответить
Сообщениеvikttur, ошибку выдает
"Для этой функции были указаны аргументы (слишком много)"

Автор - bobrenja
Дата добавления - 26.03.2016 в 00:37
vikttur Дата: Суббота, 26.03.2016, 00:39 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Писал на коленке. Скобки посчитать. Потерялась:
Код
=ВПР("x";ДВССЫЛ(A1&"!B3:F10");3;0)
 
Ответить
СообщениеПисал на коленке. Скобки посчитать. Потерялась:
Код
=ВПР("x";ДВССЫЛ(A1&"!B3:F10");3;0)

Автор - vikttur
Дата добавления - 26.03.2016 в 00:39
bobrenja Дата: Суббота, 26.03.2016, 00:59 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Понял что в скобках, но не там лепил ее.
Спасибо

А как в таком формате задать поиск по списку листов??
К примеру
A1 - январь
A2 - февраль

Так не работает
Код

=ВПР("x";ДВССЫЛ(A1:A2&"!B3:F10");3;0)


Сообщение отредактировал Serge_007 - Суббота, 26.03.2016, 01:08
 
Ответить
СообщениеПонял что в скобках, но не там лепил ее.
Спасибо

А как в таком формате задать поиск по списку листов??
К примеру
A1 - январь
A2 - февраль

Так не работает
Код

=ВПР("x";ДВССЫЛ(A1:A2&"!B3:F10");3;0)

Автор - bobrenja
Дата добавления - 26.03.2016 в 00:59
vikttur Дата: Суббота, 26.03.2016, 01:07 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Нет, неправильно.
Правильно - почитать правила и показать файл-пример.
 
Ответить
СообщениеНет, неправильно.
Правильно - почитать правила и показать файл-пример.

Автор - vikttur
Дата добавления - 26.03.2016 в 01:07
bobrenja Дата: Суббота, 26.03.2016, 01:23 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Правильно - почитать правила и показать файл-пример.

Так файл примера в первом сообщении был (думал запрещено несколько раз тот самый файл прикреплять) и в первом сообщении суть проблемы.
Файл удалил кто то. :((((

Вот повторяю его
Поиск нужно по всем листам делать которые есть в книге и будут добавляться .
К сообщению приложен файл: 2499471.xlsx(13Kb)


Сообщение отредактировал bobrenja - Суббота, 26.03.2016, 01:35
 
Ответить
Сообщение
Правильно - почитать правила и показать файл-пример.

Так файл примера в первом сообщении был (думал запрещено несколько раз тот самый файл прикреплять) и в первом сообщении суть проблемы.
Файл удалил кто то. :((((

Вот повторяю его
Поиск нужно по всем листам делать которые есть в книге и будут добавляться .

Автор - bobrenja
Дата добавления - 26.03.2016 в 01:23
vikttur Дата: Суббота, 26.03.2016, 01:34 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Цитата
Файл удалил кто то

Я не брал, у меня своих Excel-файлов - ноут уже распух )

Выпадающий список - и меняйте.
К сообщению приложен файл: 7054778.xlsx(14Kb)
 
Ответить
Сообщение
Цитата
Файл удалил кто то

Я не брал, у меня своих Excel-файлов - ноут уже распух )

Выпадающий список - и меняйте.

Автор - vikttur
Дата добавления - 26.03.2016 в 01:34
bobrenja Дата: Суббота, 26.03.2016, 01:38 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Выпадающий список - и меняйте.

Как вариант ))
Оказывается просто.
А есть возможность автоматического добавления в ячейку названия листа, если он создается/копируется/

Спасибо за помощь.
 
Ответить
Сообщение
Выпадающий список - и меняйте.

Как вариант ))
Оказывается просто.
А есть возможность автоматического добавления в ячейку названия листа, если он создается/копируется/

Спасибо за помощь.

Автор - bobrenja
Дата добавления - 26.03.2016 в 01:38
vikttur Дата: Суббота, 26.03.2016, 01:41 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 2030
Репутация: 355 ±
Замечаний: 0% ±

Цитата
добавления в ячейку названия листа, если он создается/копируется/

Макросом. Но это вопрос другой темы.
 
Ответить
Сообщение
Цитата
добавления в ячейку названия листа, если он создается/копируется/

Макросом. Но это вопрос другой темы.

Автор - vikttur
Дата добавления - 26.03.2016 в 01:41
bobrenja Дата: Суббота, 26.03.2016, 02:22 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 68
Репутация: 0 ±
Замечаний: 20% ±

Excel для Mac
Что бы не путаться с названием листов, вставил формулу для определения названия листа

Код
=ПСТР(ЯЧЕЙКА("ИМЯФАЙЛА";A1);ПОИСК("]";ЯЧЕЙКА("ИМЯФАЙЛА";A1))+1;255)


Далее на лист БЛАНК ссылки на A1 названия листов, что бы формировался выпадающий список.

vikttur, спасибо за направление куда и как копать и за примеры.
К сообщению приложен файл: 6372601.xlsx(15Kb)


Сообщение отредактировал bobrenja - Суббота, 26.03.2016, 02:22
 
Ответить
СообщениеЧто бы не путаться с названием листов, вставил формулу для определения названия листа

Код
=ПСТР(ЯЧЕЙКА("ИМЯФАЙЛА";A1);ПОИСК("]";ЯЧЕЙКА("ИМЯФАЙЛА";A1))+1;255)


Далее на лист БЛАНК ссылки на A1 названия листов, что бы формировался выпадающий список.

vikttur, спасибо за направление куда и как копать и за примеры.

Автор - bobrenja
Дата добавления - 26.03.2016 в 02:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Печать бланка с разных листов которые добавляются. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!