Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула с постепенным возрастанием и понижением - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с постепенным возрастанием и понижением (Формулы/Formulas)
Формула с постепенным возрастанием и понижением
inohodec Дата: Понедельник, 28.03.2016, 15:46 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Есть следующая задача: необходимо построить график на подобие синуса или косинуса.
Есть приделы от 16 до 19,5 в которых кривая графика может извиваться.
Написал формулу
Код
=ЕСЛИ(E2>19,5;E2-5/СЛУЧМЕЖДУ(4;9);ЕСЛИ(E2<16,5;E2+5/СЛУЧМЕЖДУ(4;9);ЕСЛИ(B3<10;E2;E2-0,1)))

Но когда моя кривая доходит до нижнего придела 16,5, то появляется пик резкого возрастания, а потом опять постепенное снижение.
Помогите с формулой, что нужно изменить чтоб вместо резкого пика возрастания было плавное повышение до верхнего придела?
К сообщению приложен файл: 280316.xlsx(27Kb)
 
Ответить
СообщениеДобрый день. Есть следующая задача: необходимо построить график на подобие синуса или косинуса.
Есть приделы от 16 до 19,5 в которых кривая графика может извиваться.
Написал формулу
Код
=ЕСЛИ(E2>19,5;E2-5/СЛУЧМЕЖДУ(4;9);ЕСЛИ(E2<16,5;E2+5/СЛУЧМЕЖДУ(4;9);ЕСЛИ(B3<10;E2;E2-0,1)))

Но когда моя кривая доходит до нижнего придела 16,5, то появляется пик резкого возрастания, а потом опять постепенное снижение.
Помогите с формулой, что нужно изменить чтоб вместо резкого пика возрастания было плавное повышение до верхнего придела?

Автор - inohodec
Дата добавления - 28.03.2016 в 15:46
inohodec Дата: Вторник, 29.03.2016, 11:37 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
А как в обще можно решить данное задание?
Какие есть мысли или предложения?
Может макрос есть похожий?
 
Ответить
СообщениеА как в обще можно решить данное задание?
Какие есть мысли или предложения?
Может макрос есть похожий?

Автор - inohodec
Дата добавления - 29.03.2016 в 11:37
Pelena Дата: Вторник, 29.03.2016, 15:42 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9879
Репутация: 2265 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
У Вас в файле не нашла указанной формулы.
Вручную можете нарисовать примерный вид графика?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вас в файле не нашла указанной формулы.
Вручную можете нарисовать примерный вид графика?

Автор - Pelena
Дата добавления - 29.03.2016 в 15:42
inohodec Дата: Вторник, 29.03.2016, 16:41 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010


а формула в Е3 и в низ протянута
 
Ответить
Сообщение

а формула в Е3 и в низ протянута

Автор - inohodec
Дата добавления - 29.03.2016 в 16:41
inohodec Дата: Вторник, 29.03.2016, 17:00 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
я хотел написать такое условие, чтоб повышалось значения по условию но плавно, а не резко уходило вверх как у меня это происходит
не могу придумать как сделать так чтоб условие повышения выполнялось n-ое количество раз подряд (желательно не постоянное значение)
 
Ответить
Сообщениея хотел написать такое условие, чтоб повышалось значения по условию но плавно, а не резко уходило вверх как у меня это происходит
не могу придумать как сделать так чтоб условие повышения выполнялось n-ое количество раз подряд (желательно не постоянное значение)

Автор - inohodec
Дата добавления - 29.03.2016 в 17:00
abtextime Дата: Вторник, 29.03.2016, 17:41 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
У вас на графике суперпозиция синусоиды и линейной функции (или слегка нелинейного повышающего тренда). Подберите параметры этих двух функций, после чего их можно запрограммировать


Сообщение отредактировал abtextime - Вторник, 29.03.2016, 17:42
 
Ответить
СообщениеУ вас на графике суперпозиция синусоиды и линейной функции (или слегка нелинейного повышающего тренда). Подберите параметры этих двух функций, после чего их можно запрограммировать

Автор - abtextime
Дата добавления - 29.03.2016 в 17:41
inohodec Дата: Вторник, 29.03.2016, 20:44 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
я пытался сделать, что то условно похожее.

но если быть точным,
то мне нужно отобразить на графике как должна работать климатической система;
параметры системы (границы от 16,5 до 19,5);
примерно за 10 часов работы система увеличивает температуру в помещении на 2 градуса;
после 10 часов работы или достижения верхней границы система выключается на 7 часов;
за 7 часов ожидания включения системы температура в помещении падает примерно на 1,5 градуса.
 
Ответить
Сообщениея пытался сделать, что то условно похожее.

но если быть точным,
то мне нужно отобразить на графике как должна работать климатической система;
параметры системы (границы от 16,5 до 19,5);
примерно за 10 часов работы система увеличивает температуру в помещении на 2 градуса;
после 10 часов работы или достижения верхней границы система выключается на 7 часов;
за 7 часов ожидания включения системы температура в помещении падает примерно на 1,5 градуса.

Автор - inohodec
Дата добавления - 29.03.2016 в 20:44
inohodec Дата: Среда, 30.03.2016, 10:20 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
и если температура достигает нижней границы 16,5, то климатической система автоматически включается чтоб поднять температуру на 2 градуса
 
Ответить
Сообщениеи если температура достигает нижней границы 16,5, то климатической система автоматически включается чтоб поднять температуру на 2 градуса

Автор - inohodec
Дата добавления - 30.03.2016 в 10:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула с постепенным возрастанием и понижением (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!