Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ИНДЕКС: Поиск части текста для определения № строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС: Поиск части текста для определения № строки (Формулы/Formulas)
ИНДЕКС: Поиск части текста для определения № строки
Sony Дата: Вторник, 29.03.2016, 13:23 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день!
Поиском сегодня ничего не подобрал, так что обращаюсь к знатокам:

В файле на 3 листах нужно всего навсего сравнить значения 1 и 2 листа на 3.
Для получения данных из 1 листа использую ИНДЕКС + ПОИСКПОЗ(текст в 1 и 3 листах совпадает)
А как достать текст из 2 листа не знаю... ПОИСКПОЗ в чистом виде здесь не подходит.
Ключевые слова "Общее время работы" с обеих сторон имеют другой рандомный текст, в кот может меняться количество знаков с любой стороны: (ааааа "Общее время работы" бббб).

Помогите с костылём...
К сообщению приложен файл: 2016329114844GT.xls(51Kb)
 
Ответить
СообщениеДобрый день!
Поиском сегодня ничего не подобрал, так что обращаюсь к знатокам:

В файле на 3 листах нужно всего навсего сравнить значения 1 и 2 листа на 3.
Для получения данных из 1 листа использую ИНДЕКС + ПОИСКПОЗ(текст в 1 и 3 листах совпадает)
А как достать текст из 2 листа не знаю... ПОИСКПОЗ в чистом виде здесь не подходит.
Ключевые слова "Общее время работы" с обеих сторон имеют другой рандомный текст, в кот может меняться количество знаков с любой стороны: (ааааа "Общее время работы" бббб).

Помогите с костылём...

Автор - Sony
Дата добавления - 29.03.2016 в 13:23
китин Дата: Вторник, 29.03.2016, 13:41 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
получите костыль :D
Код
=ИНДЕКС('Свод 2'!$B$2:$E$6;ПОИСКПОЗ("*"&$A3&"*";'Свод 2'!$A$2:$A$6;0);ПОИСКПОЗ(Сравнение!I$2&"*";'Свод 2'!$B$1:$E$1;0))
К сообщению приложен файл: Sony.xls(59Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 29.03.2016, 13:42
 
Ответить
Сообщениеполучите костыль :D
Код
=ИНДЕКС('Свод 2'!$B$2:$E$6;ПОИСКПОЗ("*"&$A3&"*";'Свод 2'!$A$2:$A$6;0);ПОИСКПОЗ(Сравнение!I$2&"*";'Свод 2'!$B$1:$E$1;0))

Автор - китин
Дата добавления - 29.03.2016 в 13:41
Sony Дата: Вторник, 29.03.2016, 14:00 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, ай красавчик )))) hands ну конечно "*" "*" !!! Спасибо за идею с № столбца, думаю пригодится!
 
Ответить
Сообщениекитин, ай красавчик )))) hands ну конечно "*" "*" !!! Спасибо за идею с № столбца, думаю пригодится!

Автор - Sony
Дата добавления - 29.03.2016 в 14:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ИНДЕКС: Поиск части текста для определения № строки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!