Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать значения массива, пустые заменяем предыдущими - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения массива, пустые заменяем предыдущими (Формулы/Formulas)
Суммировать значения массива, пустые заменяем предыдущими
metez Дата: Вторник, 29.03.2016, 15:44 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Исходные данные в диапазоне левее желтой ячейки, формула должна стоять в желтой ячейке одна и суммировать массив B2:M2 так как будто там данные из диапазона отмеченного зеленым, т.е. вместо пустых значений предыдущее заполненное.

Мои предположения, ошибка в том что диапазон для функции Просмотр меньше диапазона для функции Сумм и равен от ячейки В2 до текущего значения в массиве при сложении
Код
=СУММ((ЕСЛИ(B2:M2="";ПРОСМОТР(9E+307;ДВССЫЛ("B2:"&АДРЕС(СТРОКА();СТОЛБЕЦ(B2:M2)-1)));B2:M2)))


как исправить не пойму
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]
К сообщению приложен файл: 0141141.xlsx(9Kb)


Сообщение отредактировал Pelena - Вторник, 29.03.2016, 15:47
 
Ответить
СообщениеИсходные данные в диапазоне левее желтой ячейки, формула должна стоять в желтой ячейке одна и суммировать массив B2:M2 так как будто там данные из диапазона отмеченного зеленым, т.е. вместо пустых значений предыдущее заполненное.

Мои предположения, ошибка в том что диапазон для функции Просмотр меньше диапазона для функции Сумм и равен от ячейки В2 до текущего значения в массиве при сложении
Код
=СУММ((ЕСЛИ(B2:M2="";ПРОСМОТР(9E+307;ДВССЫЛ("B2:"&АДРЕС(СТРОКА();СТОЛБЕЦ(B2:M2)-1)));B2:M2)))


как исправить не пойму
[moder]Оформляйте формулы тегами (кнопка fx). Исправила на первый раз[/moder]

Автор - metez
Дата добавления - 29.03.2016 в 15:44
китин Дата: Вторник, 29.03.2016, 15:54 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а может так надо?
Код
=ЕСЛИ(C2="";ПРОСМОТР(99^9;$B$2:C2;$B$2:C2);C2)

неправильно :'(
К сообщению приложен файл: metez.xlsx(9Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 29.03.2016, 15:59
 
Ответить
Сообщениеа может так надо?
Код
=ЕСЛИ(C2="";ПРОСМОТР(99^9;$B$2:C2;$B$2:C2);C2)

неправильно :'(

Автор - китин
Дата добавления - 29.03.2016 в 15:54
buchlotnik Дата: Вторник, 29.03.2016, 15:56 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=СУММ(ПРОСМОТР(СТОЛБЕЦ(B2:M2);ЕСЛИ(ЕПУСТО(B2:M2);"";СТОЛБЕЦ(B2:M2));B2:M2))
К сообщению приложен файл: 1969296.xlsx(9Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=СУММ(ПРОСМОТР(СТОЛБЕЦ(B2:M2);ЕСЛИ(ЕПУСТО(B2:M2);"";СТОЛБЕЦ(B2:M2));B2:M2))

Автор - buchlotnik
Дата добавления - 29.03.2016 в 15:56
metez Дата: Вторник, 29.03.2016, 16:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да супер, а что не так в моей формуле, я только начал вникать в тему массивов и интересно, я выбрал совершенно не правильный алгоритм?

и если возможно, я понял что сам себе не правильно поставил задачу, в приложении пример2, надо диапазон B7:M7 просуммировать так, что бы значения суммировались по алгоритму в диапазоне B8:M8

Спасибо
К сообщению приложен файл: 2736028.xlsx(9Kb)


Сообщение отредактировал metez - Вторник, 29.03.2016, 16:07
 
Ответить
СообщениеДа супер, а что не так в моей формуле, я только начал вникать в тему массивов и интересно, я выбрал совершенно не правильный алгоритм?

и если возможно, я понял что сам себе не правильно поставил задачу, в приложении пример2, надо диапазон B7:M7 просуммировать так, что бы значения суммировались по алгоритму в диапазоне B8:M8

Спасибо

Автор - metez
Дата добавления - 29.03.2016 в 16:07
_Boroda_ Дата: Вторник, 29.03.2016, 16:21 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для первой задачи намассивная
Код
=СУММПРОИЗВ(ПРОСМОТР(СТОЛБЕЦ(B2:M2);СТОЛБЕЦ(B2:M2)/ЕЧИСЛО(B2:M2);B2:M2))

Или, уж если у Вас там есть цифры 1-12, то
Код
=СУММПРОИЗВ(ПРОСМОТР(B1:M1;B1:M1/ЕЧИСЛО(B2:M2);B2:M2))

Для второй задачи
Код
=СУММПРОИЗВ(СУММЕСЛИ(B6:M6;"<="&B6:M6;B7:M7))
К сообщению приложен файл: 2736028_1.xlsx(9Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля первой задачи намассивная
Код
=СУММПРОИЗВ(ПРОСМОТР(СТОЛБЕЦ(B2:M2);СТОЛБЕЦ(B2:M2)/ЕЧИСЛО(B2:M2);B2:M2))

Или, уж если у Вас там есть цифры 1-12, то
Код
=СУММПРОИЗВ(ПРОСМОТР(B1:M1;B1:M1/ЕЧИСЛО(B2:M2);B2:M2))

Для второй задачи
Код
=СУММПРОИЗВ(СУММЕСЛИ(B6:M6;"<="&B6:M6;B7:M7))

Автор - _Boroda_
Дата добавления - 29.03.2016 в 16:21
metez Дата: Вторник, 29.03.2016, 16:26 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Гениально, Спасибо, а если для второй задачи не будет цифр 1-12?
 
Ответить
СообщениеГениально, Спасибо, а если для второй задачи не будет цифр 1-12?

Автор - metez
Дата добавления - 29.03.2016 в 16:26
_Boroda_ Дата: Вторник, 29.03.2016, 17:00 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
а если для второй задачи не будет цифр 1-12?

Да не вопрос
Код
=СУММПРОИЗВ(Ч(СМЕЩ(B8;;СТОЛБЕЦ(B8:M8)-2)))


Действительно, ссылку не туда написал.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Вторник, 29.03.2016, 19:34
 
Ответить
Сообщение
а если для второй задачи не будет цифр 1-12?

Да не вопрос
Код
=СУММПРОИЗВ(Ч(СМЕЩ(B8;;СТОЛБЕЦ(B8:M8)-2)))


Действительно, ссылку не туда написал.

Автор - _Boroda_
Дата добавления - 29.03.2016 в 17:00
metez Дата: Вторник, 29.03.2016, 18:41 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Неа, оно просто просуммировало числа как обычная сумма()


Сообщение отредактировал metez - Вторник, 29.03.2016, 18:44
 
Ответить
СообщениеНеа, оно просто просуммировало числа как обычная сумма()

Автор - metez
Дата добавления - 29.03.2016 в 18:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать значения массива, пустые заменяем предыдущими (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!