Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как избавиться от "#н/д" и "0" в ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как избавиться от "#н/д" и "0" в ячейке (Формулы/Formulas)
Как избавиться от "#н/д" и "0" в ячейке
runagroup Дата: Пятница, 01.04.2016, 21:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 49
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
День добрый!
как при использовании такой формулы
Код
=ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H20;card!$B$2:$B$102);2)
сделать так что бы к ячейке не было ни #н/д, ни "0", а была пустая ячейка?

Заранее спасибо
К сообщению приложен файл: 2989145.xls(86Kb)


Сообщение отредактировал Serge_007 - Суббота, 02.04.2016, 17:43
 
Ответить
СообщениеДень добрый!
как при использовании такой формулы
Код
=ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H20;card!$B$2:$B$102);2)
сделать так что бы к ячейке не было ни #н/д, ни "0", а была пустая ячейка?

Заранее спасибо

Автор - runagroup
Дата добавления - 01.04.2016 в 21:15
buchlotnik Дата: Пятница, 01.04.2016, 21:20 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
ошибку формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H21;card!$B$2:$B$102);2);"")
нули форматом ;;;@
К сообщению приложен файл: 0717648.xls(91Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеошибку формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H21;card!$B$2:$B$102);2);"")
нули форматом ;;;@

Автор - buchlotnik
Дата добавления - 01.04.2016 в 21:20
runagroup Дата: Пятница, 01.04.2016, 21:22 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 49
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
buchlotnik, Спасибо!!!
 
Ответить
Сообщениеbuchlotnik, Спасибо!!!

Автор - runagroup
Дата добавления - 01.04.2016 в 21:22
МВТ Дата: Пятница, 01.04.2016, 21:44 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 475
Репутация: 135 ±
Замечаний: 0% ±

Excel 2007
Как вариант снять галку "Показывать нули..."
К сообщению приложен файл: 9515357.png(50Kb)


Сообщение отредактировал Serge_007 - Суббота, 02.04.2016, 17:45
 
Ответить
СообщениеКак вариант снять галку "Показывать нули..."

Автор - МВТ
Дата добавления - 01.04.2016 в 21:44
Nic70y Дата: Суббота, 02.04.2016, 06:57 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3476
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(H21="";"";ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H21;card!$B$2:$B$102);2)&"")
Код
=ЕСЛИ(H21="";"";ВПР($H21;card!$B$3:C$102;2;)&"")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(H21="";"";ИНДЕКС(card!$B$2:$E$102;ПОИСКПОЗ($H21;card!$B$2:$B$102);2)&"")
Код
=ЕСЛИ(H21="";"";ВПР($H21;card!$B$3:C$102;2;)&"")

Автор - Nic70y
Дата добавления - 02.04.2016 в 06:57
zaak88 Дата: Понедельник, 04.04.2016, 12:12 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 94
Репутация: 1 ±
Замечаний: 40% ±

Excel 2013
Можно в этой теме поинтересоваться как можно скрыть в таблице #н/д, ЗНАЧ, 0, ДЕЛ#0 одновременно? Если нет извините, создам отдельную тему. Спасибо, друзья!
[moder]Создавайте. п.5q Правил пока не отменили.


Сообщение отредактировал _Boroda_ - Понедельник, 04.04.2016, 12:19
 
Ответить
СообщениеМожно в этой теме поинтересоваться как можно скрыть в таблице #н/д, ЗНАЧ, 0, ДЕЛ#0 одновременно? Если нет извините, создам отдельную тему. Спасибо, друзья!
[moder]Создавайте. п.5q Правил пока не отменили.

Автор - zaak88
Дата добавления - 04.04.2016 в 12:12
PaulPetrow Дата: Понедельник, 18.04.2016, 08:57 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Просто нажмите CTRL +F заменить пишем "#н/д" или "0" во втором просто пустое.
и Вуаля поиск и замена по всему листу и у вас все чисто)
[moder]Вы испытали свой совет на файле ТС из первого поста? Получилось?[/moder]


Сообщение отредактировал Pelena - Понедельник, 18.04.2016, 09:01
 
Ответить
СообщениеПросто нажмите CTRL +F заменить пишем "#н/д" или "0" во втором просто пустое.
и Вуаля поиск и замена по всему листу и у вас все чисто)
[moder]Вы испытали свой совет на файле ТС из первого поста? Получилось?[/moder]

Автор - PaulPetrow
Дата добавления - 18.04.2016 в 08:57
gge29 Дата: Воскресенье, 24.04.2016, 13:50 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 159
Репутация: 3 ±
Замечаний: 0% ±

Как вариант ещё можно через УФ
-создать правило
-использовать формулу для определения форматируемых ячеек
- =ЕОШИБКА(B2:E102)
- формат
-цвет (белый,фон 1)
[moder]Почему формула без тегов?


Сообщение отредактировал _Boroda_ - Понедельник, 25.04.2016, 10:04
 
Ответить
СообщениеКак вариант ещё можно через УФ
-создать правило
-использовать формулу для определения форматируемых ячеек
- =ЕОШИБКА(B2:E102)
- формат
-цвет (белый,фон 1)
[moder]Почему формула без тегов?

Автор - gge29
Дата добавления - 24.04.2016 в 13:50
akkord87 Дата: Среда, 04.05.2016, 11:42 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Отличные примеры)
 
Ответить
СообщениеОтличные примеры)

Автор - akkord87
Дата добавления - 04.05.2016 в 11:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как избавиться от "#н/д" и "0" в ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!