Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчёт периметра формулой массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт периметра формулой массива (Формулы/Formulas)
Расчёт периметра формулой массива
ryazanov_74 Дата: Понедельник, 04.04.2016, 12:51 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
В таблице есть номера заказов, ширина и высота разверток изделий и количество изделий.
Помогите пожалуйста рассчитать периметр с помощью формулы массива.
Пример в приложении.
К сообщению приложен файл: _6.xlsx(12Kb)
 
Ответить
СообщениеДобрый день!
В таблице есть номера заказов, ширина и высота разверток изделий и количество изделий.
Помогите пожалуйста рассчитать периметр с помощью формулы массива.
Пример в приложении.

Автор - ryazanov_74
Дата добавления - 04.04.2016 в 12:51
_Boroda_ Дата: Понедельник, 04.04.2016, 13:13 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*2*E$3:E$99)%/10

Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*2*E$3:E$99)/1000


Добавлено.
Ну да, действительно, двойку вынести можно
Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*E$3:E$99)%/5
К сообщению приложен файл: _6_1.xlsx(12Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 04.04.2016, 13:53
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*2*E$3:E$99)%/10

Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*2*E$3:E$99)/1000


Добавлено.
Ну да, действительно, двойку вынести можно
Код
=СУММПРОИЗВ((A$3:A$99=H19)*(C$3:C$99+D$3:D$99)*E$3:E$99)%/5

Автор - _Boroda_
Дата добавления - 04.04.2016 в 13:13
jakim Дата: Понедельник, 04.04.2016, 13:18 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Немножко сократил формулу

Код
=SUMPRODUCT(($A$3:$A$15=H19)*(C$3:C$15+D$3:D$15)*E$3:E$15)/500
 
Ответить
Сообщение
Немножко сократил формулу

Код
=SUMPRODUCT(($A$3:$A$15=H19)*(C$3:C$15+D$3:D$15)*E$3:E$15)/500

Автор - jakim
Дата добавления - 04.04.2016 в 13:18
ryazanov_74 Дата: Понедельник, 04.04.2016, 14:19 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Супер, спасибо!!
 
Ответить
СообщениеСупер, спасибо!!

Автор - ryazanov_74
Дата добавления - 04.04.2016 в 14:19
Michael_S Дата: Вторник, 05.04.2016, 00:13 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
_Boroda_, jakim, Вас же просили - формулой массива.
Код
=СУММ(($A$3:$A$15=H19)*(C$3:C$15+D$3:D$15)*E$3:E$15)/500

Вот так формула массива будет.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение_Boroda_, jakim, Вас же просили - формулой массива.
Код
=СУММ(($A$3:$A$15=H19)*(C$3:C$15+D$3:D$15)*E$3:E$15)/500

Вот так формула массива будет.

Автор - Michael_S
Дата добавления - 05.04.2016 в 00:13
AlexM Дата: Вторник, 05.04.2016, 00:44 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Michael_S, тогда так
Код
=СУММ(($A$3:$A$15=H19)*(C$3:D$15)*E$3:E$15)/500


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеMichael_S, тогда так
Код
=СУММ(($A$3:$A$15=H19)*(C$3:D$15)*E$3:E$15)/500

Автор - AlexM
Дата добавления - 05.04.2016 в 00:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчёт периметра формулой массива (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!