Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как правильно сделать сортировку в excel? - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как правильно сделать сортировку в excel? (Формулы/Formulas)
Как правильно сделать сортировку в excel?
lolkisonik Дата: Четверг, 07.04.2016, 14:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Доброго времени суток!
Столкнулся с токой задачей, постоянно приходят прайс листы с техникой старого и нового ассортимент и ее приходится очень долго сортировать( какие модели новые появились а какие вышли из ассортимент). Опишу так, если модель в столбце A имеется и в столбце B, тогда СТРОКИ от B до AN будут подстравиваться автоматически под столбец A, например
встолбце В5 есть такая же модель как и в столбце A7, тогда столбцы от B5 до AN5 перемищаются на строку от B7 до AN7, но если модели нет в столбце A, а есть в столбце B, тогда строки от B до AN перемещаются ниже все таблицы.
На словах очень трудно объяснить пример как сортировать и как должно быть рассортировано в положении.
К сообщению приложен файл: __excel.xlsx(20Kb) · ___excel.xlsx(20Kb)
 
Ответить
СообщениеДоброго времени суток!
Столкнулся с токой задачей, постоянно приходят прайс листы с техникой старого и нового ассортимент и ее приходится очень долго сортировать( какие модели новые появились а какие вышли из ассортимент). Опишу так, если модель в столбце A имеется и в столбце B, тогда СТРОКИ от B до AN будут подстравиваться автоматически под столбец A, например
встолбце В5 есть такая же модель как и в столбце A7, тогда столбцы от B5 до AN5 перемищаются на строку от B7 до AN7, но если модели нет в столбце A, а есть в столбце B, тогда строки от B до AN перемещаются ниже все таблицы.
На словах очень трудно объяснить пример как сортировать и как должно быть рассортировано в положении.

Автор - lolkisonik
Дата добавления - 07.04.2016 в 14:34
pabchek Дата: Четверг, 07.04.2016, 14:42 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 689
Репутация: 152 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Так надо?
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$6:A$23;ПОИСКПОЗ(ИСТИНА;ЕНД(ПОИСКПОЗ(A$6:A$23;B$6:B15;0));0));"")
К сообщению приложен файл: 9569740.xlsx(21Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте. Так надо?
Формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$6:A$23;ПОИСКПОЗ(ИСТИНА;ЕНД(ПОИСКПОЗ(A$6:A$23;B$6:B15;0));0));"")

Автор - pabchek
Дата добавления - 07.04.2016 в 14:42
lolkisonik Дата: Четверг, 07.04.2016, 14:46 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
К сожалению нет, там есть другой файл excel как надо чтобы было. В прицепе у вас ход мыслей верный, посмотрите другой файл excel,я думаю вы поймете.
 
Ответить
СообщениеК сожалению нет, там есть другой файл excel как надо чтобы было. В прицепе у вас ход мыслей верный, посмотрите другой файл excel,я думаю вы поймете.

Автор - lolkisonik
Дата добавления - 07.04.2016 в 14:46
lolkisonik Дата: Четверг, 07.04.2016, 14:46 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Продублирую как надо чтобы было
К сообщению приложен файл: 0881787.xlsx(20Kb)
 
Ответить
СообщениеПродублирую как надо чтобы было

Автор - lolkisonik
Дата добавления - 07.04.2016 в 14:46
Волхв Дата: Четверг, 07.04.2016, 15:09 | Сообщение № 5
Группа: Заблокированные
Ранг: Участник
Сообщений: 70
Репутация: 3 ±
Замечаний: 100% ±

Excel 2010
Код
=ЕСЛИ(И([@[Модель новые ]]="";[@[Модель старые]]="");3;ЕСЛИ([@[Модель новые ]]="";2;1))
К сообщению приложен файл: 8927098.xlsx(24Kb)


Плодить темы - это вообще-то предназначение форума ©Serge_007 админа
 
Ответить
Сообщение
Код
=ЕСЛИ(И([@[Модель новые ]]="";[@[Модель старые]]="");3;ЕСЛИ([@[Модель новые ]]="";2;1))

Автор - Волхв
Дата добавления - 07.04.2016 в 15:09
китин Дата: Четверг, 07.04.2016, 15:17 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4106
Репутация: 633 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
столбце A7, тогда столбцы от B5 до AN5

это как?
[p.s.]мы с вами одной крови:я тоже объяснять не умею :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 07.04.2016, 15:17
 
Ответить
Сообщение
столбце A7, тогда столбцы от B5 до AN5

это как?
[p.s.]мы с вами одной крови:я тоже объяснять не умею :D

Автор - китин
Дата добавления - 07.04.2016 в 15:17
lolkisonik Дата: Четверг, 07.04.2016, 16:27 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
P.S.
мы с вами одной крови:я тоже объяснять не умею

:D
столбце A7, тогда столбцы от B5 до AN5 - постараюсь объяснить), у меня есть прайс лист в excel
Например:
*B C D E F G H I J K L M N
1Q + -
2W + +
3E + -
4R + +
5T + -
6Y + +

В Столбце B имеет перечень названия моделей, в других столбцах характеристики к этой модели
на примере: B1 название модели; C1 + (значит модель имеет черный цвет); D1 - (Не имеет серого оттенка) и т.д
Допустим пришел новый прайс, мне надо выяснить какие модели вышли из ассортимента а какие
модели добавили, для этого я копирую модели из нового прайса в колонку (столбец) A

Рассмотрим на примере:

*A B C D E F G H I J K L M N
1 G Q + -
2 Q W + +
3 C E + -
4 W R + +
5 Y T + -
6 E Y + +
7 T
8 F

Что мы тут видим, в столбце A название моделей из нового прайса, в столбце B
модели из старого прайса,а столбцы С,D,E,F,G и т.д. дают нам характеристики к
моделям из старого прайса то есть к столбце B.
Теперь надо сделать так чтоб столбец B подстроился под столбец A, при это не
теряя свои характеристики С,D,E,F,G и т.д

Рассмотрим на примере:(что должно получится)

*A B C D E F G H I J K L M N
1 G
2 Q Q + -
3 C
4 W W + +
5 Y Y + +
6 E E + -
7 T T + -
8 F
9 *R + +
10

Что мы видим, B9 модель под название R (которая имеет характеристики С9 +, D9 +) и
которой больше нет в новом прайсе (т.е. модель выведена из ассортимента) это модель
должна стоять после всех значений колонки A (то есть в самом низу таблицы)
А модели которые совпали например A2 и B2 встали в одну строчку при этом не теряя
своих характеристик С,D,E,F,G и т.д.
После чего я удаляю столбец B и у меня получается таблица с обновленными моделями и верными характеристиками (моделей из старого прайса).
Думаю вы меня поймете :D


Сообщение отредактировал lolkisonik - Четверг, 07.04.2016, 16:43
 
Ответить
Сообщение
P.S.
мы с вами одной крови:я тоже объяснять не умею

:D
столбце A7, тогда столбцы от B5 до AN5 - постараюсь объяснить), у меня есть прайс лист в excel
Например:
*B C D E F G H I J K L M N
1Q + -
2W + +
3E + -
4R + +
5T + -
6Y + +

В Столбце B имеет перечень названия моделей, в других столбцах характеристики к этой модели
на примере: B1 название модели; C1 + (значит модель имеет черный цвет); D1 - (Не имеет серого оттенка) и т.д
Допустим пришел новый прайс, мне надо выяснить какие модели вышли из ассортимента а какие
модели добавили, для этого я копирую модели из нового прайса в колонку (столбец) A

Рассмотрим на примере:

*A B C D E F G H I J K L M N
1 G Q + -
2 Q W + +
3 C E + -
4 W R + +
5 Y T + -
6 E Y + +
7 T
8 F

Что мы тут видим, в столбце A название моделей из нового прайса, в столбце B
модели из старого прайса,а столбцы С,D,E,F,G и т.д. дают нам характеристики к
моделям из старого прайса то есть к столбце B.
Теперь надо сделать так чтоб столбец B подстроился под столбец A, при это не
теряя свои характеристики С,D,E,F,G и т.д

Рассмотрим на примере:(что должно получится)

*A B C D E F G H I J K L M N
1 G
2 Q Q + -
3 C
4 W W + +
5 Y Y + +
6 E E + -
7 T T + -
8 F
9 *R + +
10

Что мы видим, B9 модель под название R (которая имеет характеристики С9 +, D9 +) и
которой больше нет в новом прайсе (т.е. модель выведена из ассортимента) это модель
должна стоять после всех значений колонки A (то есть в самом низу таблицы)
А модели которые совпали например A2 и B2 встали в одну строчку при этом не теряя
своих характеристик С,D,E,F,G и т.д.
После чего я удаляю столбец B и у меня получается таблица с обновленными моделями и верными характеристиками (моделей из старого прайса).
Думаю вы меня поймете :D

Автор - lolkisonik
Дата добавления - 07.04.2016 в 16:27
SLAVICK Дата: Четверг, 07.04.2016, 16:44 | Сообщение № 8
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
Много букв - устал читать.
Может просто в столбец прописать формулу:
Код
=ПОИСКПОЗ(B6;Старый!B:B;0)

и удалить все строки с Н/Д?
И вариант "наоборот"
Код
=ЕСЛИОШИБКА(ВПР($A6;Старый!$B$4:$AN$36;СТОЛБЕЦ(A$1);0);"")

см. 2-й файл
К сообщению приложен файл: _excel-1-.xlsx(30Kb) · 0881787-1-.xlsx(37Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
СообщениеМного букв - устал читать.
Может просто в столбец прописать формулу:
Код
=ПОИСКПОЗ(B6;Старый!B:B;0)

и удалить все строки с Н/Д?
И вариант "наоборот"
Код
=ЕСЛИОШИБКА(ВПР($A6;Старый!$B$4:$AN$36;СТОЛБЕЦ(A$1);0);"")

см. 2-й файл

Автор - SLAVICK
Дата добавления - 07.04.2016 в 16:44
lolkisonik Дата: Четверг, 07.04.2016, 17:03 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
А можно сделать как нить без старого и нового а просто одна вкладка
 
Ответить
СообщениеА можно сделать как нить без старого и нового а просто одна вкладка

Автор - lolkisonik
Дата добавления - 07.04.2016 в 17:03
pabchek Дата: Четверг, 07.04.2016, 17:08 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 689
Репутация: 152 ±
Замечаний: 0% ±

Excel 2007
Вот вариант без предварительного сопоставления названий
Код
=ЕСЛИОШИБКА(ЕСЛИ(E6=0;ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ(B$6:B$15;D$5:D5;0));B$6:B$15);ЕСЛИОШИБКА(ВПР(E6;B$6:B$15;1;0);"яяя"));"яяя")

Колонку D сохраняем как значения и сортируем. (Для последующего использования формулку гденить сохранить)
К сообщению приложен файл: 2089432.xlsx(18Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеВот вариант без предварительного сопоставления названий
Код
=ЕСЛИОШИБКА(ЕСЛИ(E6=0;ПРОСМОТР(;-1/ЕНД(ПОИСКПОЗ(B$6:B$15;D$5:D5;0));B$6:B$15);ЕСЛИОШИБКА(ВПР(E6;B$6:B$15;1;0);"яяя"));"яяя")

Колонку D сохраняем как значения и сортируем. (Для последующего использования формулку гденить сохранить)

Автор - pabchek
Дата добавления - 07.04.2016 в 17:08
SLAVICK Дата: Четверг, 07.04.2016, 17:15 | Сообщение № 11
Группа: Модераторы
Ранг: Старожил
Сообщений: 1962
Репутация: 669 ±
Замечаний: 0% ±

2007,2010,2013,2016
А можно сделать как нить без старого и нового

Если честно не могу понять что нужно...
Может просто выделить дубликаты и уникальные?
См. пример. в нем два правила УФ
К сообщению приложен файл: 0881787-2-.xlsx(16Kb)


Иногда все проще чем кажется с первого взгляда.
 
Ответить
Сообщение
А можно сделать как нить без старого и нового

Если честно не могу понять что нужно...
Может просто выделить дубликаты и уникальные?
См. пример. в нем два правила УФ

Автор - SLAVICK
Дата добавления - 07.04.2016 в 17:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как правильно сделать сортировку в excel? (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!