Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор значения по нескольким условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения по нескольким условиям (Формулы/Formulas)
Выбор значения по нескольким условиям
ryazanov_74 Дата: Пятница, 08.04.2016, 14:28 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Есть несколько параметров материалов (марка, толщина) есть объём заказа и есть цена в зависимости от объёма заказа.
Подскажите пожалуйста, какую нужно формулу написать, чтобы выбиралось нужное значение?
Пример в приложении.
К сообщению приложен файл: 0481173.xlsx(11Kb)
 
Ответить
СообщениеДобрый день!
Есть несколько параметров материалов (марка, толщина) есть объём заказа и есть цена в зависимости от объёма заказа.
Подскажите пожалуйста, какую нужно формулу написать, чтобы выбиралось нужное значение?
Пример в приложении.

Автор - ryazanov_74
Дата добавления - 08.04.2016 в 14:28
buchlotnik Дата: Пятница, 08.04.2016, 14:39 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=ИНДЕКС($C$5:$E$13;ПОИСКПОЗ(C20&C21;$A$5:$A$13&$B$5:$B$13;0);ПОИСКПОЗ(C19;$C$3:$E$3;1))
(формула массива вводится одновременным нажатием ctrl+shift+enter)
К сообщению приложен файл: 8991037.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 08.04.2016, 14:39
 
Ответить
Сообщениетак нужно?
Код
=ИНДЕКС($C$5:$E$13;ПОИСКПОЗ(C20&C21;$A$5:$A$13&$B$5:$B$13;0);ПОИСКПОЗ(C19;$C$3:$E$3;1))
(формула массива вводится одновременным нажатием ctrl+shift+enter)

Автор - buchlotnik
Дата добавления - 08.04.2016 в 14:39
pabchek Дата: Пятница, 08.04.2016, 14:55 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Подлиннее, но не массивная.
Код
=ИНДЕКС($A$1:$E$13;СУММПРОИЗВ(($A$5:$A$13=C20)*($B$5:$B$13=C21)*СТРОКА($A$5:$A$13));ПРОСМОТР(C19;{0:100:500};$C$2:$E$2))
К сообщению приложен файл: 6629036.xlsx(11Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 08.04.2016, 14:55
 
Ответить
СообщениеПодлиннее, но не массивная.
Код
=ИНДЕКС($A$1:$E$13;СУММПРОИЗВ(($A$5:$A$13=C20)*($B$5:$B$13=C21)*СТРОКА($A$5:$A$13));ПРОСМОТР(C19;{0:100:500};$C$2:$E$2))

Автор - pabchek
Дата добавления - 08.04.2016 в 14:55
ryazanov_74 Дата: Пятница, 08.04.2016, 15:01 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо большое за помощь!
 
Ответить
СообщениеСпасибо большое за помощь!

Автор - ryazanov_74
Дата добавления - 08.04.2016 в 15:01
jakim Дата: Пятница, 08.04.2016, 16:28 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Ещё вариант с формулой

Код
=AGGREGATE(15;6;$C$5:$E$13/($A5:$A13=C$20)/($B5:$B13=C$21)/($C3:$E3<=C$19);1)
К сообщению приложен файл: 7801055.xlsx(12Kb)
 
Ответить
Сообщение
Ещё вариант с формулой

Код
=AGGREGATE(15;6;$C$5:$E$13/($A5:$A13=C$20)/($B5:$B13=C$21)/($C3:$E3<=C$19);1)

Автор - jakim
Дата добавления - 08.04.2016 в 16:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор значения по нескольким условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!